SAS 9.2(TS2M2)でサポートするJava Runtime Environment

このページには、SAS 9.2と使用するJava Runtime Environment(JRE)の最小限のバージョンの必要条件を記載しています。 下記のリストにあるサードパーティソフトウェアの更新されたバージョンを使用することも可能です。 詳細は、SAS Third Party Software Requirements - Baseline and Higher Support(英語)を参照してください。

SAS® 9.2 FoundationおよびSAS® クライアントアプリケーションのためのJava Runtime Environment

SAS 9.2 FoundationおよびいくつかのSAS 9.2クライアントアプリケーションを実行するには、Java Runtime Environment(JRE)が必須です。 これらのJREは、IBM社、Oracle社、またHP社から提供されます。 次の表は、SAS 9.2での使用が推奨されており、SAS Deployment WizardによってインストールされるJREのバージョンをインストールを実行する プラットフォーム別に記載しています。 JREは、表に記載されているベンダーから直接入手することもできます。

SAS 9.2のインストールと設定後に他ののJREまたは、JDKを使用する予定がある場合は、こちらの 手順を参照してください。

アプリケーションサーバーおよびサーブレットエンジンは、完全なJava Software Development Kit(JDK)を必要とします。 サポートしているアプリケーションサーバーで必要なJava Development Kitのリストを参照してください。

プラットフォーム バージョン ベンダーのダウンロードサイト CD 注意
HP-UX PA-RISC 5.0.08 HP 入手できません  
6.0.02 HP 入手できません  
HP-UX Itanium 5.0.08 HP 入手できません  
6.0.02 HP 入手できません  
OpenVMS Itanium 5.0-2 HP 入手できません  
6.0-1 HP 入手できません  
Linux
(32-bit、x86版)
Java 5 Update 14 Sun 入手できません  
Java 6 Update 14 Sun 入手できません  
Linux
(64-bit、x86-64版)
Java 5 Update 14 Sun 入手できません サポートされているJREは32-bitです。 このJREは、Sun社によって「Linux Platform」と表示されています。 Sun社は、「Linux on AMD64 / EM64T architecture」という表示のJREも提供していますが、これは、64-bitのものであり、SAS®9.2ではサポートしていません。
Java 6 Update 14 Sun 入手できません サポートされているJREは32-bitです。 このJREは、Sun社によって「Linux Platform」と表示されています。 Sun社は、「Linux on AMD64 / EM64T architecture」という表示のJREも提供していますが、これは、64-bitのものであり、SAS®9.2ではサポートしていません。
z/OS Java 5 31-bit SDK IBM 入手できません ライセンスの制限により、再配布はできません。 31-bit Java 5 SDKが必要です。
Java 6 31-bit SDK IBM 入手できません ライセンスの制限により、再配布はできません。 31-bit Java 6 SDKが必要です。
AIX

Java 5 SR5, 5.0.0.125 fileset, pap32dev-20070511

IBM 入手できません
詳細は、IBM Developer Kit のFAQ を参照してください。

Java 6 SR3, 6.0.0.75 fileset, pap3260sr3-20081106_07

IBM 入手できません
詳細は、IBM Developer Kit のFAQ を参照してください。
Solaris
(64-bit、 SPARC)
Java 5 Update 12 Sun 入手できません サポートされているJREは32-bitです。
Java 6 Update 14 Sun 入手できません サポートされているJREは32-bitです。
Solaris
(64-bit、x86-64版)
Java 5 Update 12 Sun 入手できません サポートされているJREは32-bitです。 このJREは、Sun社によって「Solaris x86 Platform」と表示されています。 Sun社は、「Solaris on AMD64 / EM64T architecture」という表示のJREも提供していますが、これは、64-bitのものであり、SAS®9.2ではサポートしていません。
Java 6 Update 14 Sun 入手できません サポートされているJREは32-bitです。 このJREは、Sun社によって「Solaris x86 Platform」と表示されています。 Sun社は、「Solaris on AMD64 / EM64T architecture」という表示のJREも提供していますが、これは、64-bitのものであり、サポートしていません。
Windows
(32-bit、x86版)
Java 5 Update 12 Sun 入手できません  
Java 6 Update 14 Sun 入手できません  
Windows
(64-bit Itanium)
1.5.0_08 (5.0 R27.1) Oracle社に連絡してください。 入手できません  
Java 6 Update 12 Sun 入手できません  
Windows
(64-bit、x86-64版)
Java 5 Update 12 Sun 入手できません サポートされているJREは32-bitです。 このJREは、Sun社によって「Windows Platform」と表示されています。 Sun社は、「Windows on AMD64 / EM64T architecture」という表示のJREも提供していますが、これは、64-bitのものであり、SAS®9.2ではサポートしていません。
Java 6 Update 14 Sun 入手できません サポートされているJREは32-bitです。 このJREは、Sun社によって「Windows Platform」と表示されています。 Sun社は、「Windows on AMD64 / EM64T architecture」という表示のJREも提供していますが、これは、64-bitのものであり、サポートしていません。