SAS® VISUAL ANALYTICS
AN OVERVIEW OF POWERFUL DISCOVERY, ANALYSIS AND REPORTING
SAS Visual Analytics is a high-performance, in-memory solution for exploring massive amounts of data very quickly. It enables you to spot patterns, identify opportunities for further analysis and convey visual results via Web reports or a mobile platform such as iPad® or Android-based tablets.

This presentation is a very brief overview of the many features and capabilities of SAS Visual Analytics. It is meant to get you started quickly, with a relatively modest data set example (only 1.4 million rows). For more in-depth information, you can consult the online User Guide, available via the Help menu, or go to the website at http://www.sas.com/technologies/bi/visual-analytics.html.
• Overview of the Data
• Getting Started
• Bar Charts
• Hierarchies
• Filters
• Calculations
• Geographies
• Cross Tabs
• Forecasting and Simulation
• Decision Trees

• Treemaps
• Heatmaps
• Correlations & Regressions
• Network Diagrams
• Box Plots & Statistics
• Bubble Plots With Time Animation
• Text Analytics
• Report Design & Distribution
• Data Dictionary
OVERVIEW OF THE DATA

- Insight Toy Company is an organization that produces and sells toys to resellers ("vendors"). The data is made up of 34 years of Sales information, covering 128 cities across the world.

- For each row of data (transaction) we have:
  - Information on the items sold (product brand, line, make, style, SKU)
  - The sale value ("order total") and various related costs (distribution, marketing, product)
  - Information on the sales representative (rating, sales target, actual to date, etc.)
  - Geographic information (on the vendors as well as the selling facility)
  - Information on the vendors (rating, satisfaction, distance to nearest facility)
  - Text Notes taken at the moment of the order taking, based on conversation with the vendor.

- The data source is made up of 1.4 million rows and 60+ columns

NOTE: a complete data dictionary is available at the end of this document
The toolbar enables you to select your visual explorations and visualizations.

The data pane lists the available categories and measures in your selected data.

The right pane contains tabs that enable you to change the properties of your visualizations, filter the data and create and view comments.

The workspace displays your visualizations.

To start a new visualization on a blank workspace, simply minimize the current visualization.

For more information, please consult the SAS Visual Analytics User Guide, available under the Help menu.
STEP 1: starting with a blank workspace, select **Bar Chart** from the toolbar.

STEP 2: Drag and drop **Facility Continents**, **Gross Margin** and **Order Total** on the workspace. Note: you can select multiple items by holding the CTRL key.

In order to explore this in more detail, we will need to create a hierarchy that will allow us to dig deeper and focus our analysis.
Let's add more “investigative” functionality to this bar chart by creating a drill-down path.

**STEP 1**: From the **Data** tab, select **New Hierarchy**.

**STEP 2**: Name it **Facility Hierarchy**.
Select **Facility Continents**, **Facility Country/Region**, **Facility City** and **Facility** (in that order). Click **OK**.

![Image of the new hierarchy tool with options for Facility Continents, Facility Country/Region, Facility City, and Facility.
USING A HIERARCHY

Drag the new **Facility Hierarchy** from the Data Pane and drop it on **Facility Continents**.

The new hierarchy has replaced the single-level Facility Continent element. Notice that the appearance of the chart does not change, but a “breadcrumb trail” appears in the upper left of the chart.

Double-click on North America to explore further.

💡 You can also click on the label “North America” at the bottom of the chart.
EXPLORING A HIERARCHY

From this graph, it is clear that the US has a much higher **Order Total** and **Gross Margin**. Notice the breadcrumb trail highlighted in the upper left.

You can continue to drill-down and gain even more insight.

Double-click on **United States** to get to city level details.
The Hierarchy was created on the fly, without the need to ask our IT department to create a special data structure, and is IMMEDIATELY applicable to all your data, usable for explorations and reports.

Further, you can easily edit the hierarchy to drill down, from Facilities, to Products, Units, Sales Representatives, etc.
Filters are an easy way to subset the data, allowing you to focus on a specific area. There are two types of filters: **Local** filters affect only the current visualization, while **Global** filters affect all visualizations currently open.

Let’s create a simple visualization to practice Filters:

**STEP 1**: starting with a blank workspace, select **Bar Chart** from the toolbar.

**STEP 2**: Drag and drop **Product Hierarchy** and **Order Total** on the workspace.
Let’s focus on 2012 only.

**STEP 1:** Drag and drop the **Transaction Year** field to the filter tab. Put it in the **Local Filters** section.

**STEP 2:** simply drag the left arrow to subset the data to 2012 – 2013 only.

Notice how SAS Visual Analytics automatically lets us know the general distribution of the data?
FILTERS – SELECT AND INCLUDE

Let’s look at all various Product Make in our **Game** Product line, *except* Puzzle 3d and Card Games.

**STEP 1:** Drill into **Toy** and then **Game**. You can select specific items in your visualization (holding the **CTRL** key), or you can use the mouse to lasso around multiple items. Let’s CTRL-select **Puzzle 3d** and **Card Game**.

**STEP 2:** Now right-click and select **Exclude Selection**.

A new filter is added.
FILTERS - ADVANCED

Filters behave differently depending on if they are for a numerical measure or a category.

Options allow you to **edit a filter**, to refine it even more with various conditions and operators, and to make it as sophisticated as you need.

_Every time you apply filters, SAS Visual Analytics tells you how much of the data you are looking at._
CALCULATIONS

SAS Visual Analytics allows you to create on-the-fly calculations of all your data.

There are two types of calculations:

1. **Calculated Items** are applied to every row of data. The results will be aggregated like any other data.

2. **Aggregated Measures** will be calculated after all data has been aggregated for any visualization. This is usually best for ratios.
CALCULATIONS - CREATING

To create (or edit) a calculation, simply:

**STEP 1:** build the structure of your calculation: drag and drop the operator(s) you want on the main window.

**STEP 2:** drag and drop the data element inside the calculation structure.

You can specify how the results of your calculation will be formatted.

This is the name of the calculated item. It will appear as a data item in the data pane, available for visualizations and reports.

These are the various functions and operators that can be used to create your formula.

These are the various data elements that you can use in a calculation.

You can switch between “visual” (drag and drop) and “text” mode to edit the calculation.
A few calculations have already been created for you in the Insight Toy Company sample exploration. Among them, **Gross Margin**, which is a row-level Calculated Item, and **Gross Margin Ratio**, which is a post-aggregation Measure.

To view how these calculations were created or modify them, simply select one, right-click and select “**Edit…**”.

Note that it is possible to use the result of a Calculated Item in another calculation, but it is not possible to use the result of a an Aggregated Measure calculation in a Calculated Item.
A quick way to create calculations is to right-click on the data element and create a derived item. Derived data items are aggregated measures that perform calculations for your data.

- You can create Distinct Counts on Category Items (for example, to display the number of cities where each product line is sold);
- You can create a Percent of Total, or multiple types of time-derived calculations such as Year-To-Date, Difference From Previous Period, etc.
- As with any calculations, you can view and edit these calculations after they are created.
In SAS Visual Analytics, any category field can be designated as a Geography. You might assign a geography to a pre-defined geographic role (such as country name), or create a customized geography data item to identify geographic information that is specific to your organization (for example: sales regions, warehouse locations, oil platforms, and so on).

Further, we have already created a hierarchy to explore data from continent to country, region and city.

For the purpose of Insight Toy Company, we have already designated the following fields as Geographic locations.
ANALYZING GEOGRAPHIES

If you have any visualization opened, minimize it and start from a blank workspace.

Select **Geo Hierarchy** and hold the **CTRL** key to select **Order Total**. Simply drag and drop them on the workspace. Because the category selected has been pre-defined as a geography item, SAS Visual Analytics will automatically offer us a Map visual.
Since you used a hierarchy, you can drill down on it: double-click on the North America bubble and then on the USA bubble.

You can also add another measure. In this case here, by dragging and dropping Gross Margin Ratio, you are able to see revenue of each region (the size of the bubbles) as well as their relative Gross Margin contribution (the color of the bubbles).

**Insight:** Notice that most revenue (bubble size) seems to be coming more from the East than West side of the country. Gross margin (bubble color) seems to be concentrated in the mid South and North East of the country.
A DIFFERENT WAY TO LOOK AT GEOGRAPHIES

If your geographic category has been determined based on pre-defined names, instead of latitudes and longitudes, you can choose to display the result using **Regions** instead of **Bubbles**.

You can also select **Coordinates**. Coordinates are very useful to represent MANY points.
CROSSTAB – GETTING STARTED

A crosstab shows the intersections of category values and measure values.

**STEP 1**: starting with a blank workspace, select **Crosstab** from the toolbar.

This creates a blank Crosstab palette. Notice the Roles tab on the right. Each element can have multiple categories or measures.
From the Data tab, select **Facility Country/Region** and drop it on the **Columns** box.

Select **Product Line** and drop it on the **Rows** box.

Select **Order Sales Cost** and drop it on the **Measures** box.

Now you have a Crosstab that shows aggregated **Order Sales Cost** for each **Product Line** by **Facility Country/Region**.
CROSSTAB – ADDING DEPTH

Lets add more depth to the Crosstab.
Select **Product Make** and drop it on the **Rows** box.
Select **Order Total** and **Gross Margin Ratio** (which is an aggregated measure) and drop them on the **Measures** box.

<table>
<thead>
<tr>
<th>Facility Country/Region</th>
<th>Facility Product Make</th>
<th>Product Line</th>
<th>Order Sales Cost</th>
<th>Order Total</th>
<th>Gross Margin ratio</th>
<th>Order Sales Cost</th>
<th>Order Total</th>
<th>Gross Margin ratio</th>
<th>Order Sales Cost</th>
<th>Order Total</th>
<th>Gross Margin ratio</th>
</tr>
</thead>
<tbody>
<tr>
<td>Argentina</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Australia</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Brazil</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Now you have multiple rows and columns of aggregated product financial data, in seconds. It is easy to add or replace elements in this manner.
CROSSTAB – DRILL DOWN WITH HIERARCHIES

Lets create a new crosstab. Simply minimize the one you were working with, and start a new one.

This time, select Geo Hierarchy as your Columns, and Product Hierarchy as your Rows.

Select Order Total as your Measure.

Notice how, because we are now using Hierarchies, we can drill down or expand on any row or column? You can read more about hierarchies here.
CROSSTAB – CREATING TOTALS

Select the **Properties** tab on the right pane.

You can turn on **Column subtotals** and **totals**

You can turn on **Row subtotals** and **totals**.

You place these before or after the corresponding data item.

You can also rename the Visualization to something more meaningful than the default “Visualization 1”.

Return to Table of Content
FORECAST – GETTING STARTED

**STEP 1:** starting with a blank workspace, select **Line Chart** from the toolbar.

**STEP 2:** From the Data tab, select **Transaction Month and Year** and **Order Total** and drag them over the workspace.

**IMPORTANT:** your line chart needs to be based on a valid TIME SERIES, otherwise you will not be able to use it for a forecast. A valid time series can be identified by these icons:

- Transaction Month
- Transaction Month and Year
STEP 3: Now that we have a time-series-based line chart, all we have to do is “turn on” forecasting to display a forecast.

The sophisticated forecasting algorithm in SAS Visual Analytics will run multiple forecasting models and pick the ‘winner’ – the forecast model that best fits the particular pattern of data. You can get more information on this forecast model by clicking on the icon.
You can increase the periods forecasted by changing the duration in the Properties tab. Change it to 18 months and click on the checkbox.
We can improve the accuracy of our forecast by adding measures that we believe should have an influence on the revenue.

Select **Order Marketing Cost**, **Vendor Distance**, **Vendor Satisfaction**, and **Market Penetration** and drag them over in the “Underlying Factors” box.
By adding underlying factors to our forecast, many things have happened:

1. The solution has evaluated and determined if the additional variable were having an influence on the forecast results. Notice how “Market Penetration” is greyed out and does not influence the forecast?

2. The forecast itself has been recalculated and is now much more precise, as evidenced by the much tighter confidence interval.

3. A new feature, “Scenario Analysis” has been added, allowing you to perform simulations.
You can now change the future values of the Underlying Factors and see the impact on the Forecast.

Use the mouse to change a value, or right-click and use the dialog box to change multiple values.

Remember to click on Update to apply your changes.
EXPORTING AND USING THE FORECAST DATA

If you select the **Results** tab, you can see the underlying data supporting this forecast.

You can right-click and select “**Export Data**” to obtain a csv file of the current data supporting this forecast.

If you select the **Analysis** tab, more explanation will be given on forecasting, as well as the algorithm that was used.

---

**Results Analysis**

<table>
<thead>
<tr>
<th>Transaction Month and Year</th>
<th>Order Total</th>
<th>Order Total (Upper LL)</th>
<th>Order Total (Lower LL)</th>
<th>Order Total (Baseline)</th>
<th>Order Marketing Cost</th>
<th>Vendor Distance</th>
<th>Vendor Satisfaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan1998</td>
<td>29,524</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Feb1998</td>
<td>34,300</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mar1998</td>
<td>31,937</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Apr1998</td>
<td>26,693</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>May1998</td>
<td>12,281</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Order Total by Transaction Month and Year**

---

**Return to Table of Content**
DECISION TREES – GETTING STARTED

Decision Trees, also known as classification or regression trees, can be used as a prediction process, to explain the behavior of, or as a grouping/segmentation method for your data.

**STEP 1:** starting with a blank workspace, select **Decision Tree** from the toolbar.

**STEP 2:** For this exercise, we want to better understand what drives our **Vendor Satisfaction**. Select it from the Data tab and drag it on the Workspace.
Immediately, the solution returns a histogram representing the distribution of Vendor Satisfaction. Notice that the average vendor satisfaction for Insight Toy is only 57%.

If we had started our analysis with a Category instead of a numerical measure, we’d have a bar chart to represent our population.

**STEP 3:** Select a few variables that you believe should have an impact on Vendor Satisfaction. Select the Vendor Loyalty Program category, and the measures Vendor Distance, Market Penetration, and Sales Rep Rating and drag them on the workspace.

Note: you can select multiple items by holding the CTRL key.
Hovering in the upper right corner of the visualization, you can select Show Overview to open a special Overview window that will allow you to zoom on sections of the Tree.

Our Tree here indicates that **Sales Rep Rating** seems to be the best explanatory variable to explain Vendor Satisfaction. Not only that, but it tells us the best breaking point, when our sales representatives are rated 60% or better.
You can select any segment of the tree and right-click to Create Visualization From Node.

A new visualization will be open with a filter that subsets your data accordingly.
TREEMAPS – GETTING STARTED

STEP 1: starting with a blank workspace, select Treemap from the toolbar.

STEP 2: Drag and drop Product Hierarchy on the Treemap workspace.
This gives you a Treemap of the highest level of the hierarchy (Product Brands) and defaults to the frequency (i.e. how many rows of data) for each product brand.

In order to get a more insightful chart, you need to add measures from the Data pane. For this exercise, drag and drop **Order Total** and **Gross Margin Ratio**.
EXPLORING TREEMAPS

Since you started with a Hierarchy, you can simply drill-down on any rectangles by double-clicking on it. Notice as well the breadcrumb at the top that indicates where you currently are exploring in the hierarchy tree.

💡 Now you can quickly see which product groups have the best relative gross margin (in blue) compared to other groups that have the same level of revenues (size of the rectangle).
TREEMAPS – MORE EXPLORATION

Using the mouse as a lasso to highlight multiple boxes, or by holding the CTRL key, you can select multiple boxes, and, using a right-click menu, include (or exclude) them from your selection, in effect creating a filter.
HEAT MAPS – GETTING STARTED

STEP 1: starting with a blank workspace, select Heat Map from the toolbar.

STEP 2: Select Facility Country/Region, Product Line and Market Penetration from the Data tab with CTRL-click. Drag and drop them onto the Heat Map workspace.
You now have a Heat Map of Market Penetration by Facility Country/Region and Product Line.

It seems that market penetration varies widely by product line (y-axis), but is fairly consistent by country (x-axis).

Let’s change the presentation somewhat to get a better sense of this.
HEAT MAPS – ANOTHER PERSPECTIVE

Let's get a different view of this relationship.

On the Roles tab, drag **Product Line** from the Y axis element and drop it on the X axis element. In effect, swapping **Product Line** and **Facility Country/Region**.

Notice how the map has drastically changed?

Now we see the same information, but from a different, potentially more meaningful perspective. We can see much consistency in terms of market penetration for each country.
HEAT MAPS – IDENTIFYING PROBLEM AREAS

Let's dig a bit deeper. Select Product Make from the Data pane and drag and drop it over Product Line.

Now we have the same data, but at the Product Make level.
HEAT MAPS – IDENTIFYING PROBLEM AREAS

Working with the Y axis scroll bar, you can ‘zoom out’, and identify each Product Make individually.
HEAT MAPS – DRILLING DEEPER

We can single out areas with the lowest Market Penetration.

You can either click and hold the CTRL key or “Lasso” these areas with the mouse by holding the button and selecting the areas to be explored.

Then, press the right mouse button to get the menu and select **Include Only Selection**.

Notice the new filter in the Filters tab?
We are now using only a fraction of the original data.

Return to Table of Content
CORRELATIONS – GETTING STARTED

STEP 1: starting with a blank workspace, select **Correlation Matrix** from the toolbar.

**STEP 2:** Click the first measure (Gross Margin), hold the **SHIFT** key and select the last measure. This should select all measure as shown in the screenshot. Drag them on the Correlation workspace.
Notice the intersection **Vendor Satisfaction** and **Sales Rep Rating**. It has a strong relationship of 0.973 (“1” being the strongest possible correlation).

This implies they share a strong relationship.

Double Click this intersection to explore it further.
There is a strong relationship between **Vendor Satisfaction** and **Sales Rep Rating**. The color is represented as transaction frequency.

Next, drag **Gross Margin** from the data pane to the Visual pane. This will overlay Gross Margin as the color instead of frequency.
As Vendor Satisfaction is increasing, so too is Sales Rep Rating. This makes sense and is good information.

Notice however that some unsatisfied vendors, serviced by some of our lesser rated sales representatives (bottom left), are also making us money (Gross Margins in blue). Interesting as well. We’ll need to investigate.
Using the mouse as a lasso, highlight the blue bins in the bottom left, as shown in the screenshot. Right click on the highlighted transactions and select **Include Only Selection**. This will create an instant filter on our data.
SATISFIED AND PROFITABLE CUSTOMERS... BUY WHICH PRODUCT?

It looks like the highest gross margins come from sales reps with a rating right around 40%. Let’s find out which products are associated with these gross margins to see if those have an effect as well.

Drag **Product Line** into the pane and replace **Sales Rep Rating** with **Product Line**.
GROSS MARGIN RATIO – STAR PRODUCTS

From this map, it is very clear that our highest gross margins come from the **Figure** and **Game** product lines. Click the **Bar Chart** icon in the toolbar. The visualization will change to a Bar Chart.

Drag **Order Total** over **Vendor Satisfaction**. The **Figure** and **Game** product lines not only have the highest gross margins, but the highest sales as well. Good to know.
**NETWORK DIAGRAMS – GETTING STARTED**

**Network Diagrams** are about showing relationships and their structure. Flow can be shown with a direction (arrow).

Most business operations have some form of network: Supply chains, Import/export, Debt and loans, Twitter influencer analysis, transportation routes, etc. In fact, any hierarchy can be represented as a network.

SAS Visual Analytics supports two types of Networks: hierarchy-based, and ungrouped.

Ungrouped networks require two data items: a Source and a Target. The target has to be a subset of the Source. Examples of this type of Network are:

- Employees and their managers (because all managers are also employees)
- Intercompany transactions (subsidiary to subsidiary)
- Transportation origin and destination cities
- Sports team playing against each other

In this Insight Toy example, we will be working with a hierarchical network.
**NETWORK DIAGRAMS – GETTING STARTED**

**STEP 1**: starting with a blank workspace, select **Network Diagram** from the toolbar.

**STEP 2**: From the Roles tab, select the **Hierarchical** Network Type.

**STEP 3**: From the Data Pane, select and drag **Product Hierarchy** onto the workspace.
**NETWORK DIAGRAMS – REFINING THE VISUAL**

**STEP 4:** Select:  
- **Order Total** the Node Size;  
- **Order Count** for the node Color;  
- **Gross margin** for the Link Width; and  
- **Gross Margin link color** for the Link Color.

From here you can drill down and explore on any level. You can also modify many things in the Properties tab.
Network Diagrams are highly dependent on the type of data available. Here are some additional examples of network diagrams based on other sources of data:

- Transportation Route
- Airline source and target destinations
- Twitter feed Analysis
- Manufacturing Supply Chain
Box Plots are a very powerful way to derive multiple statistics about your data. A box plot represents the distribution of data values by using rectangular box and lines called whiskers. Basically, this means that half of your data ends up in this range for the particular measure you are looking at.
Step 1: Minimize any open visualizations, to start with a blank workspace. Select Box Plot from the toolbar.

Step 2: Drag and drop one measure, and one category over the workspace. In this example, we have selected to look at the distribution of the Vendor Distance (measure), per Facility City (geography).

Notice how we can immediately see the average distance that vendors are from our stores. The majority seem fairly close to our stores, but there are definitely a few far away.
BOX PLOTS - REFINEMENT

Here is another example: You can immediately see the Order Marketing Cost by Product Line. You can see that the “Plush” and “Thrift” products have the lowest marketing costs, and that the “Promo” products have the widest distribution of marketing costs.

By further refining this visualization with filters, you will be able to quickly focus on any region, facility or sale representative in order to investigate at a more detailed level.

Return to Table of Content
STEP 1: starting with a blank workspace, select **Bubble Plot** from the toolbar.

Please note that the Bubble Plot visualization is one of the more complex ones, as evidenced by the various field roles available.
STEP 2: Assign a GROUP. The Group is important because it dictates how many elements can be displayed on the screen at one time. Here, we will drag and drop Product Hierarchy as our group.
STEP 3: Now you can assign the rest of your data elements. For this visualization, you will assign:

Sales Rep Rating for the X Axis
Vendor Satisfaction for the Y Axis
Order Total for the Bubble Size.
Since you chose a Hierarchy as your Group, you will be able to drill-down to further explore your visualization by double-clicking on the bubbles.

Notice the bread crumb trail that expands indicating your drill-down path.

Also note that clearly, the better a sales representative is rated, the more his/her vendors seem satisfied. However, this seems independent of the actual sales revenue (the size of the bubble).
Using your mouse as a lasso, you can select a few bubbles, Right-Click and select **Include Only Selection**, to create a filter on-the-fly, and focus on just those items.

See the **Filters** section for more info on filters.
Now, wouldn’t it be interesting to see how that visualization evolves over time?

You can simply select **Transaction Year** and drag and drop it in the **Animation** role.

Now you will be able to **play** the bubble plot, and see how things evolve over time.
SAS Visual Analytics can do two types of word clouds:

- Simple word clouds using a category value; or
- More sophisticated word clouds that leverage SAS Text Analytics. Word clouds that use text analytics analyze each value in a data item as a text document that can contain multiple words. Words that often appear together in the document collection are identified as topics.
For this exercise, we will change exploration and with it the underlying data. This new data actually contains **free form text** that we will explore using SAS Text Analytics.

**STEP 1**: From the Explorer interface, select File > Open.

**STEP 2**: If you are asked to save your exploration, select “Don’t’ Save”
TEXT ANALYTICS – GETTING STARTED / ACCESSING NEW DATA

**STEP 3:** In the OPEN dialog window, navigate to SAS Folders > Shared data > DemoData > Insight Toy Trial > Exploration and Reports

And then select **Insight Toy Text Exploration** and click **OPEN**.

This will open a pre-defined exploration, and will also point you to another data set. This new data contains specific customer comments for the Bead product line, from January to October of 2013.
TEXT ANALYTICS – SIMPLE WORD CLOUDS

**STEP 1:** starting with a blank workspace, select **Word Cloud** from the toolbar.

**STEP 2:** From the Roles tab, select **Using Category Values**.

**STEP 3:** Drag and Drop a category item. Here we selected **Product Style**.
TEXT ANALYTICS – SIMPLE WORD CLOUDS

The result shows the relative size of each Product Style, representing the frequency of our transactions. For example, we see we sell much more Orange Mixed than we do Blue 8mm.

STEP 4: Select and Drag and Drop Gross Margin and Order Total on the workspace. The Visualization is now very different: the size of the Font representing Gross Margin contribution of each Product make, while the color represents the Revenues generated.
TEXT ANALYTICS – LEVERAGING ADVANCED SAS TEXT ANALYTICS

STEP 1: starting with a blank workspace, select Word Cloud from the toolbar.

STEP 2: From the Roles tab, select Using Text Analytics.

To leverage text analytics, we have pre-defined two settings in the data:
1. A data item (Order) has been identified as the “unique row identifier”; and
2. A category (Order Note) has been identified as a “document collection”. This is the data item that will be analyzed.

STEP 3: Back in the Roles tab, click on the little down arrow for Document Collection, and pick the only choice available: Order Note.

Visual Analytics will analyze the content of that data, identify topics (words that often appear together), and represent the most relevant terms for each topic by varying the size of the terms.
TEXT ANALYTICS – LEVERAGING ADVANCED SAS TEXT ANALYTICS

STEP 4: Two sets of topics have been identified in this data. The first one is pretty generic, but the second one might hold some very interesting findings. Select the next Topic from the drop down menu at the top of the visualization.

Terms that we identify as “red flags” (eg. “unhappy”) can be focused on by simply clicking on them, which will display all the Documents that have these terms.

Return to Table of Content

To access the Report Designer, you will first need to go back to Visual Analytics’ Home page. To do so, simply click on the Home button.

Please note that in this trial, you will not be allowed to save your current work.
This is your Home page. From here, you can access Explorations, Reports, Prepare your data and manage your servers. Note that in this trial, you can only access Explorations and Reports.

Some content has already been prepared for you. The first exploration is where you have been working up to now.

Links can be customized for your organization’s needs.

To access Report Designer, click and edit the sample report.
When you click on the Sample Report, you will be given a choice to View it, or Edit it. Click on Edit.
The interface for creating, editing and publishing reports is very similar to the Data Exploration interface, with a few differences…

The right pane contains tabs that enable you to change the properties of your visualizations, filter the data and apply display rules.

The workspace allows for interaction between different objects.

The Objects tab lists the various types of Tables, Graphs, Gauges, Controls and Containers for your report.

As before, the Data tab lists the available categories and measures in your selected data sources.

For more information, please consult the SAS Visual Analytics User Guide, available under the Help menu.
REPORTING IN SAS VISUAL ANALYTICS – CREATING A NEW SECTION

For the purpose of this exercise, we’ll show you how to recreate the **Sales Overview** page.

Reports in SAS Visual Analytics are made of sections (see the three tabs at the top) and each section is made up of tiles.

In this section, we have 3 tiles: a pie chart, a line plot, and a treemap.

On the top right, we also have two pull-downs that allow the user to subset the data (in this case, we’re looking at 2011 and at Europe).

Let’s create a new section by clicking on the + sign at the top.
REPORTING IN SAS VISUAL ANALYTICS – EDITING A NEW SECTION

**STEP 1:** From the **Objects** tab, drag and Drop two **Drop-Down list** controls in the top part to create section prompts.

**STEP 2:** From the **Data** tab, drag and Drop **Facility Continents** on the first Drop-Down list, and **Transaction Year** on the second one.
REPORTING IN SAS VISUAL ANALYTICS – ADDING A PIE CHART

**STEP 1**: From the **Objects** tab, drag and Drop a **Pie Chart** graph object on the report section.

**STEP 2**: From the **Data** tab, drag and Drop **Order Total** on the pie chart and assign it as a **Measure**, and then drag and drop **Facility Country/Region** as your category.
STEP 1: From the **Objects** tab, drag and Drop a **Time Series Plot** graph object on the **RIGHT** side of the report section.

STEP 2: From the **Data** tab, drag and Drop **Order Total** and **Gross Margin** to the Time Series Plot. Assign Gross Margin as a **New Measure**.
**STEP 3**: From the **Data** tab, drag and Drop **Transaction Month and Year** as a **New Category** over the Time Series Plot.

**STEP 4**: Make sure the Time Series plot is selected, and from the **Properties** tab, set the Binning Interval to “Use Format”, so only monthly data gets displayed.
REPORTING IN SAS VISUAL ANALYTICS – ADDING A TREEMAP

**STEP 1:** From the **Objects** tab, drag and Drop a **Treemap** Graph object at the bottom of this report section.

![Treemap Graph](image)

💡 Note: you can always re-arrange the tiles afterwards if you prefer.

**STEP 2:** From the **Data** tab, drag and Drop the category **Product Line** over the Treemap. Then, Drag and Drop the measure **Order Total** as the New Size, and the Aggregated Measure **Gross Margin Ratio** as the New Color.

![Data tab](image)
REPORTING IN SAS VISUAL ANALYTICS – CREATING INTERACTION

STEP 1: To create an interaction between your various Tiles, click on the View menu and select Show Interactions.

STEP 2: From the Pie Chart, Drag and Drop to the Time Series Plot and then to the Treemap tiles.

When you’re done, go back to the layout view by clicking on Close button.
You’re almost done! Your report section is now fully functional. Try changing the **pull down** values, and also click on one **section of the pie chart**. See what happens.

Now all that’s left to do is to refine the look of the Report Section...
The Properties and Styles tab on the right allows you to change many parameters to improve the look of the various tiles.

The Display Rules tab is used to assign intervals when working with KPI gauges, or to assign a specific color to a data segment (such as product line ‘xyz’).

These can also be leveraged in the Alerts tab.
Here are two more sections of the same sample report.

You can have a ‘Button Bar’ Across the top. The user can simply pick a Product line, and the report automatically adjusts.

The midsection is a “stack container” which is actually 4 different objects… users can pick the visualization they prefer.

Here we are looking at our average vendors satisfaction & rating score per region effectiveness by regions. We also see the sales representative targets for each country.
<table>
<thead>
<tr>
<th>Field</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Facility Country/Region Code</td>
<td>Category</td>
<td>2-letter unique code for each country</td>
</tr>
<tr>
<td>Facility Date Closed</td>
<td>Category/Date</td>
<td>If a facility were ever to be closed. None are in this dataset.</td>
</tr>
<tr>
<td>Facility Date Opened</td>
<td>Category/Date</td>
<td>Date the manufacturing facility was opened. Varies from 1980 to 2010.</td>
</tr>
<tr>
<td>Manufacturing Batch</td>
<td>Category</td>
<td>Manufacturing batch corresponding to each transaction. All unique – one per row.</td>
</tr>
<tr>
<td>Manufacturing Batch SKU</td>
<td>Category</td>
<td>Stock Keeping Unit of various Manufacturing Batches.</td>
</tr>
<tr>
<td>Order note</td>
<td>Category/Document Collection</td>
<td>Free form text – notes taken at the moment the vendor ordered items. This will be used in Text Analytics.</td>
</tr>
<tr>
<td>Product Brand</td>
<td>Category</td>
<td>2 brands of products: Novelty and Toys.</td>
</tr>
<tr>
<td>Product Line</td>
<td>Category</td>
<td>8 lines of products, falling in the two product brands.</td>
</tr>
<tr>
<td>Product Make</td>
<td>Category</td>
<td>77 product make, falling into the 8 product lines.</td>
</tr>
<tr>
<td>Product SKU</td>
<td>Category</td>
<td>779 product SKUs produced, falling into the various product styles.</td>
</tr>
<tr>
<td>Product Style</td>
<td>Category</td>
<td>355 product styles, falling into the various product makes.</td>
</tr>
<tr>
<td>Sales Rep</td>
<td>Category</td>
<td>Identification of the sales representative who made the sale.</td>
</tr>
<tr>
<td>Transaction date</td>
<td>Category/Date</td>
<td>Date of the sale.</td>
</tr>
<tr>
<td>Transaction Day Of Week</td>
<td>Category/Date</td>
<td>Day of the week of the sale.</td>
</tr>
<tr>
<td>Transaction Month Of year</td>
<td>Category/Date</td>
<td>Month of the sale</td>
</tr>
<tr>
<td>Transaction year</td>
<td>Category/Date</td>
<td>Year of the sale</td>
</tr>
<tr>
<td>Field</td>
<td>Type</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Vendor Date Ended</td>
<td>Category/Date</td>
<td>When the vendor stopped doing business with us</td>
</tr>
<tr>
<td>Vendor Date Started</td>
<td>Category/Date</td>
<td>When the vendor started doing business with us</td>
</tr>
<tr>
<td>Vendor Loyalty Program</td>
<td>Category</td>
<td>Binary field (Y/N) representing whether or not this vendor is in our loyalty program.</td>
</tr>
<tr>
<td>Vendor Type</td>
<td>Category</td>
<td>5 types of vendors: Convenience store, Discount store, Department store, Kiosk or Other.</td>
</tr>
<tr>
<td>Facility</td>
<td>Geography</td>
<td>Unique identifier of the selling facility</td>
</tr>
<tr>
<td>Facility City</td>
<td>Geography</td>
<td>City where the selling facility is located</td>
</tr>
<tr>
<td>Facility Continents</td>
<td>Geography</td>
<td>Continent where the selling facility is located</td>
</tr>
<tr>
<td>Facility Country/Region</td>
<td>Geography</td>
<td>Country where the selling facility is located</td>
</tr>
<tr>
<td>Facility State/Province</td>
<td>Geography</td>
<td>State or Province where the selling facility is located</td>
</tr>
<tr>
<td>Manufacturing Facility</td>
<td>Geography</td>
<td>Identifier and location of the manufacturing facility</td>
</tr>
<tr>
<td>Vendor</td>
<td>Geography</td>
<td>Identifier and location of the vendor (customer)</td>
</tr>
<tr>
<td>Geo Hierarchy</td>
<td>Hierarchy</td>
<td>A custom hierarchy made up of Facility City, State, Country, Continent</td>
</tr>
<tr>
<td>Product Hierarchy</td>
<td>Hierarchy</td>
<td>A custom hierarchy made up of Product SKU, Style, Make, Line and Brand</td>
</tr>
<tr>
<td>Gross Margin Ratio</td>
<td>Aggregated Measure</td>
<td>Sum of Gross Margins divided by Sum of Sales (‘Order Total’)</td>
</tr>
<tr>
<td>Gross Margin</td>
<td>Measure</td>
<td>Gross Margin for each sale = ‘Order Total’ – ‘Order product Cost’</td>
</tr>
<tr>
<td>Field</td>
<td>Type</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Market Penetration</td>
<td>Measure</td>
<td>For each transaction, the corresponding % of market share in that particular region at that time.</td>
</tr>
<tr>
<td>Order Distribution Cost</td>
<td>Measure</td>
<td>Distribution cost associated with that transaction</td>
</tr>
<tr>
<td>Order Marketing Cost</td>
<td>Measure</td>
<td>Marketing cost assigned to that transaction (through an activity-based costing exercise)</td>
</tr>
<tr>
<td>Order Product Cost</td>
<td>Measure</td>
<td>Direct manufacturing costs associated with that transaction. Included in the calculation of gross Margin.</td>
</tr>
<tr>
<td>Order Sales Cost</td>
<td>Measure</td>
<td>Sales-related costs assigned to that transaction (through an activity-based costing exercise)</td>
</tr>
<tr>
<td>Order Total</td>
<td>Measure</td>
<td>Revenue from that sale</td>
</tr>
<tr>
<td>Sales Rep % of Target</td>
<td>Measure</td>
<td>A ratio of Sales Rep Actual sales divided by Sales Rep target. Calculated DAILY</td>
</tr>
<tr>
<td>Sales Rep Actual</td>
<td>Measure</td>
<td>Cumulative DAILY sales for each sales representative. This value should not be summed across the transactions (since it has already been aggregated).</td>
</tr>
<tr>
<td>Sales Rep Target</td>
<td>Measure</td>
<td>Daily sales Target (goal) for each sales representative. This value should not be summed across the transactions (since it has already been aggregated).</td>
</tr>
<tr>
<td>Sales Rep Vendor Base</td>
<td>Measure</td>
<td>Potential revenue (funnel) from all the vendors (customers) assigned to a sales representative. This value should not be summed across the transactions (since it has already been aggregated).</td>
</tr>
<tr>
<td>Sales Rep Vendors</td>
<td>Measure</td>
<td>Number of customers (vendors) assigned to a sales representative. This value should not be summed across the transactions (since it has already been aggregated).</td>
</tr>
<tr>
<td>Vendor Distance</td>
<td>Measure</td>
<td>Distance from the vendor location to our selling facility.</td>
</tr>
<tr>
<td>Vendor Rating</td>
<td>Measure</td>
<td>Subjective evaluation, from 0% to 100%, representing the potential value of a customer (vendor) for insight Toy.</td>
</tr>
<tr>
<td>Vendor Satisfaction</td>
<td>Measure</td>
<td>Satisfaction of the customer (vendor) based on a marketing survey. From 0% to 100%.</td>
</tr>
</tbody>
</table>

Return to Table of Content