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SAS Enterprise Guide Projects 

SAS Enterprise Guide organizes all 
your work into projects. You can 
work on only one project at a time, 
and each project is stored in a single 
file. A project will contain all the 
reports that you produce, plus 
shortcuts to all the data files that 
you use. 

A Getting Started with SAS Enterprise Guide 
This first tutorial will give you a basic understanding of how SAS Enterprise Guide works 
and how quickly tasks can be accomplished. The following topics will be covered: 

• Starting SAS Enterprise Guide

• A quick tour of SAS Enterprise Guide windows

• Data types

• Entering data into the Data Grid

• Using SAS Enterprise Guide tasks

• Making changes to tasks

The data for this tutorial come from Fire and Ice Tours, a fictional company that arranges 
tours of volcanoes around the world. For each tour, the company keeps track of the name 
of the volcano, the city from which the tour departs, the number of days of the tour, and 
the price. Because the tours can require some physical exertion, the company gives each 
tour a difficulty rating: easy, moderate, or challenging.  

Starting SAS Enterprise Guide  
Start SAS Enterprise Guide by either 
double-clicking the SAS Enterprise Guide 
icon on your desktop, or selecting SAS 
Enterprise Guide from the Windows Start 
menu. Starting SAS Enterprise Guide 
brings up the SAS Enterprise Guide 
window in the background, with the 
Welcome window in the foreground.  The 
Welcome window allows you to choose 
between opening an existing project or 
starting a new project.  Click New Project.  

The Little SAS® Enterprise Guide® Book. Full 
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Resetting SAS Enterprise Guide Options 

There are many options in SAS Enterprise Guide 
that affect how it works. For example, you can turn 
off the Welcome window, or change the default 
format and appearance of results. If someone has 
already used SAS Enterprise Guide on your 
computer, they may have made some changes to the 
initial settings. To reset all options to their original 
settings, select Tools ► Options from the menu bar. 
Then click Reset All. 

SAS Enterprise Guide  
window  When you first 
start SAS Enterprise Guide, 
your screen should look 
something like the 
following. There are several 
parts to the SAS Enterprise 
Guide window: some are 
visible, while others may be 
hidden or temporarily 
closed.  

 

 

 

 

 

 

 

 

 

 

 

 

Basic elements of SAS Enterprise Guide  

Project Tree: This window displays your project in a hierarchical tree diagram. 

Workspace: This is a container for the Process Flow, results from tasks that you run, Data  
                      Grids, SAS code, SAS logs, and Notes.  

Process Flow: This window displays a graphical representation of your project. 

Project 
Tree 

Workspace showing 
the Process Flow 

 Resources 
pane showing 

Servers 
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Resources pane: This pane shows either the Servers, Tasks, SAS Folders, Prompt 
Manager, or Data Exploration History windows. The Servers window displays all the SAS 
servers that you can access during your SAS Enterprise Guide session. A SAS server is 
any computer on which SAS software is installed. The Tasks window displays all 
available tasks. The SAS Folders contain links to your stored processes, information maps, 
and projects. The Prompt Manager displays all available prompts. The Data Exploration 
History provides links to any data exploration done in the project. To switch between the 

windows, click their icons at the top of the pane:  for Servers,  for Tasks,  for 

SAS Folders, for the Prompt Manager, or  for Data Exploration History.  

Task Status (not shown): When you are running a task, messages about the progress of 
the task appear in the Task Status window. To open the Task Status window, select View 
► Task Status from the menu bar.  

Entering data  There are many ways to get data into SAS Enterprise Guide, and SAS 
Enterprise Guide can use data from a variety of sources including SAS data sets, 
Microsoft Excel files, and plain text files. For this example, you are simply going to type 
the data directly into SAS Enterprise Guide. To bring up the Data Grid so you can enter 
the data, select File ► New ► Data from the menu bar.  
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SAS Data Sets or SAS Data Tables? 

A SAS data set and a SAS data table are the same 
thing. The two terms are used interchangeably, and 
you will see both terms used in this book. 

Data Table Member Names 

You can give your data tables almost any names you want, but the 
names must be 32 characters or fewer in length and not start with a 
period or a space. While it is possible to have special characters 
(including spaces) in your names, you may want to stick with just 
letters, numerals, and underscores. These characters are all that are 
allowed under the default naming rules for SAS programs. In 
addition, names must start with a letter or underscore. Using these 
rules will make it easier if you ever want to refer to your data in SAS 
programs that you or someone else writes. 

This opens the New Data wizard.  In the first window of the wizard, SAS Enterprise 
Guide asks what you want to name the data table and where you want to save the data. 
The name for the data table is initially set to Data. 
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Libraries 

SAS Enterprise Guide and SAS organize SAS data tables into 
libraries. Libraries are locations, or folders, where data tables are 
stored. Instead of referring to the folders by their full path, SAS 
Enterprise Guide gives the folders short nicknames, called librefs. 
The WORK library points to a temporary storage location that is 
automatically erased when you exit SAS Enterprise Guide. The 
SASUSER library is a permanent storage location. If the EGTASK 
library is defined for your site, then data tables produced by tasks 
will be stored in the EGTASK library. If the EGTASK library is not 
defined, then data tables produced by tasks will be stored in the 
SASUSER library. Libraries can be created using the Assign Project 
Library wizard available from the Tools menu. 

Give the new data table the name Tours by typing Tours in the Name box. To see all the 
SAS libraries (storage locations) available to you, click the plus signs next to the words 
Local and then Libraries. For this example, save the data in the SASUSER library. Click 
SASUSER to select the SASUSER library. The SAS Enterprise Guide administrator at your 
site may have set up the SASUSER library so that you cannot save files there. If this is the 
case for you, choose an alternate library that is available to you (but do not choose WORK 
since that is a temporary storage location).  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click Next to open the second window of the New Data wizard. 
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Column Names 

You can give your columns almost any names you 
want, but the names must be 32 characters or fewer in 
length. While it is possible to have special characters 
(including spaces) in your names, you may want to stick 
with just letters, numerals, and underscores. These 
characters are all that are allowed under the default 
naming rules for SAS programs. In addition, names 
must start with a letter or underscore. Using these rules 
will make it easier if you ever want to refer to your data 
in SAS programs that you or someone else writes. 

The second window of the New Data wizard is where you assign names and properties to 
the columns in your data table. As a starting point, the New Data wizard sets up six 
columns with one-letter names from A to F. All these initial columns have the same 
properties.   
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Lengths of Character Columns 

The New Data wizard in SAS Enterprise Guide gives character 
columns a length of 12. If your character data are longer than 12 
characters, you need to change the length of the column to be at least 
as long as the longest data value. If all your data values are shorter 
than 12 characters, you can shorten the length for the column. Using 
shorter lengths for character data decreases the storage space needed 
for the data table.  

In the Column Properties box, you can assign each column a name, label, type, group, 
length, display format, and read-in format. The first column will contain the names of the 
volcanoes, so type Volcano in the box next to Name. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When you press Enter, the name you typed in the Name box will replace the name, in this 
case A, in the Columns box on the left. Because the names of the volcanoes contain 
characters, as opposed to numbers, leave the Type and Group properties as Character, 
and because none of the volcano names are longer than 12 characters, leave the Length set 
to 12. 
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Now click the column named B in the Columns box on the left. This column will contain 
the name of the departure city for the tour, so type the word Departs next to Name in the 
Column Properties box on the right. Leave the other settings as they are.  
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The third column contains the number of days the tour lasts. Give it the name Days, and 
because the values in this column are numbers, use the pull-down list to select Numeric 
for the Type property.  
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Character versus Numeric 

How do you decide if a column should be character 
or numeric? If the values for the column have letters 
or special characters in them, then the column must 
be character. If the column contains only numerals, 
then it could be either character or numeric. 
Generally, if it does not make sense to add or subtract 
the values, then the column should be character. 

Notice that when you set the column type to numeric, the icon next to the column name 
changes from the red pyramid  (character) to the blue ball  (numeric). The length of 
8 is the default for all numeric columns and means that the numbers will be stored with 
maximum precision. Generally, there is no need to change the length of numeric columns. 
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Numeric Groups 

By choosing a group for your numeric column, what you are 
doing is assigning a format to your column. A format is a 
way of displaying the values in the column. If you choose 
currency, then when you type a number like 1200, SAS 
Enterprise Guide will automatically display the number as 
$1,200. SAS Enterprise Guide has made it easy for you to 
assign some of the frequently used formats to your columns. 

Name the fourth column Price and give it the type Numeric. When you choose the 
numeric type, you have several options for Group: numeric, date, time, and currency.  
Because Price will contain currency values, select the group Currency. 
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Notice that when you do this, the icon changes from the blue ball to the currency icon . 
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The final column will contain the difficulty ratings of each tour. The most challenging 
tours have values of c, the moderately challenging tours have values of m, while the 
easiest tours have values of e. Give the column the name Difficulty and because the 
values for the column are single characters, change the length to 1. You could leave the 
column as length 12, but then the column would take more storeage space than it really 
needs. 
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Now the properties for all the columns have been set. However, there is one extra column: 
column F. Delete the unnecessary column by clicking it in the Columns box and then 

clicking the delete button  to the right of the Columns box.  
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Now all the columns have been given names and properties, and there are no extra 
columns.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click Finish to create the new data table. The Tours data table appears in a Data Grid in 
the workspace with all the columns that you just defined. There is also an icon for the 
Tours data table in the Project Tree under the words Process Flow. 
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Notice that the numeric columns, Days and Price, have periods in the data cells. This is 
because in SAS Enterprise Guide missing numeric values are represented by a single 
period, whereas missing character values are represented by blanks. Because no data have 
been entered into the Data Grid, all the values are missing. 
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You can now start entering the data into the Data Grid. To enter data into the Data Grid, 
simply click a cell and start typing the data. Click the first cell in the Volcano  
column and type the volcano name Etna. 

 

 

 

 

 

 

 

 

 

To move over to the next column, press the Tab key. To move down to the cell below, 
press the Enter key. You can also use the arrow keys to move around in the Data Grid, or 
you can simply click the cell where you want to type. Enter all the data for the volcano 
tours so that your Data Grid looks like the following. Notice that when you enter the data 
for the Price column, you do not need to enter the dollar signs and commas. Simply enter 
the numerals that make up the number, and then when you move on to another cell, SAS 
Enterprise Guide will give your number the proper formatting. 

 

  

 

 

 

 

 

 

 

If you need to go back and make any changes, just click the cell and type the new data 
value.
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By default, SAS Enterprise Guide provides 12 rows for data entry. If you have more than 
12 rows of data, then you can press the Enter key from any cell in the last row and SAS 
Enterprise Guide will automatically generate a new blank row for you. Because there are 
only 10 tours in this data file, you will need to delete the two extra blank rows. If you 
don’t delete the blank rows, then all the values for those rows will be missing, and these 
missing values will appear in any report or analysis that you perform. Highlight both 
blank rows by clicking row 11 and dragging the cursor to row 12. Then right-click one of 
the rows and select Delete rows.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Confirm that you want to delete the rows by clicking Yes in the pop-up dialog box. 
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Now the Data Grid is completely filled without any extra rows or columns.  
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Opening Tasks and Wizards 

You can open tasks by selecting them from the workspace 
toolbar of a Data Grid, the Tasks item on the menu bar, or the 
Task List window. Use whichever method feels more 
comfortable for you. In the tutorials, we describe how to open 
tasks using the workspace toolbar.  

Some tasks have wizards in addition to the regular task 
window. A wizard guides you through the task one window 
at a time and gives access to some of the features of the task. 
Not all tasks have wizards, but if a task does have a wizard, it 
will be listed next to the task in the pull-down list. 

Creating a frequency report To create a simple frequency report that will show 
the number of easy, moderate, and challenging tours, use the One-Way Frequencies task. 
Select Describe ► One-Way Frequencies from the workspace toolbar located just above 
the data. 
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Because the data have just been entered into the Data Grid, the following dialog box 
appears. 

  

Data must be protected before you can perform any task on your data. Protecting the 
data ensures that the data cannot be accidentally changed. If your data are not 
protected, SAS Enterprise Guide will prompt you. Click Yes.  

This opens the One-Way Frequencies task window, which has six pages: Data, Statistics, 
Plots, Results, Titles, and Properties. When you first open the task, the Data page will be 
displayed. All six pages for the task are listed in the selection pane on the left, with the 
displayed page highlighted. 
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Columns or Variables? 

A column and a variable are the same thing. 
The two terms are used interchangeably, and 
you will see both terms used in SAS 
Enterprise Guide. For example, the One-Way 
Frequencies task uses the term “variable,” 
while the Scatter Plot task uses the term 
“column.” Just remember, a variable is a 
column, and a column is a variable. 

For most tasks that you perform in SAS Enterprise Guide, you will need to assign 
variables to roles. To produce a report with the number of tours in each category of the 
variable Difficulty, click the variable Difficulty and drag it to the Analysis variables 
role. 

  

 

Click Run to run the task and produce your report. 
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Workspace Toolbar 

The workspace toolbar gives you quick access to 
many features you might want when viewing a 
particular item in the workspace. For example, the 
Modify Task button appears on the toolbar when 
you are viewing the results, log, or code for a task. 

The results from the task appear in the workspace on the Results tab. Along with the 
Results tab, the task has also generated an Input Data tab, a Code tab, and a Log tab. The 
Input Data tab contains the data used in the task. The Code tab shows the SAS code 
generated by the task, and the Log tab shows the code along with any messages SAS 
produced while running the task. The results show that two tours are challenging, five are 
easy, and three are moderate.  

 

 

 

 

  

To make changes to the task and modify the results, click Modify Task on the workspace 
toolbar to reopen the task. This reopens the One-Way Frequencies task.  
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Notice that when you reopen the task, all the choices you made are still there. For this 
example, we are going to remove the cumulative statistics from the table, so click 
Statistics in the selection pane on the left to open the Statistics page.  
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There are many options in the Statistics page. In the area labeled Frequency table options, 
you can choose which frequencies and percentages will appear in the table. By default, 
frequencies, percentages, cumulative frequencies, and cumulative percentages will appear 
in the table. To exclude the cumulative statistics, check Frequencies and percentages.  

 

Rerun the task by clicking the Run button at the bottom of the window. When you do this, 
SAS Enterprise Guide gives you a choice. You can either replace the results that you 
generated the last time you ran the task, or you can create new results. 

 

 

 

 

 

 

 

In this case, there is no reason to keep the old results, so click Yes.  
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Here are the results that will appear in the workspace showing just the frequencies and 
percentages without the cumulative statistics. 

 

 

 

 

 

 

 

Creating a scatter plot  To generate a scatter plot of the data, you will need to use a 
different task. First reopen the Tours data table to display the data. Right-click the TOURS 
data table icon in the Project Tree and select Open TOURS. 
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Opening Data Tables in the Workspace 

There are several ways to display data tables in the workspace. 
You can right-click the data table icon in the Project Tree or 
Process Flow and select Open. You can double-click the data 
table icon in the Project Tree or Process Flow. Or, if you have 
run a task using the data, you can click the Input Data tab in 
the workspace to view the input data for the task. 

With the Tours data table open in the workspace, the workspace toolbar now shows menu 
items that apply to data. Select Graph ► Scatter Plot. 
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This opens the Scatter Plot window. Before assigning roles to columns, you need to choose  
the type of scatter plot to produce. A simple two-dimensional scatter plot is appropriate  
for this report, so click 2D Scatter Plot.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Next, click Data in the selection pane on the left to assign columns to roles. 
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For this plot, the column Days should be on the horizontal axis, and the column Price 
should be on the vertical axis. So, click Days and drag it to the Horizontal task role, and 
click Price and drag it to the Vertical task role. 

 

  
  
  
  
  

 

 

 

 

 

The Scatter Plot task has many groups of options, but to produce a simple plot, there is no 
need to change anything else. Click Run. 



32    The Little SAS Enterprise Guide Book 
 
 

Displaying the Process Flow 

There are several ways to display the Process Flow in 
the workspace. You can select it from the Process Flow 
drop-down list on the menu bar, double-click its name 
in the Project Tree, select it from the View menu, select 
it from the drop-down list located above the workspace 
but below the main toolbar, or press F4. 

Here are the results of the Scatter Plot task that appear in the workspace. 

 

Now click Process Flow on the menu bar and take a look at the Process Flow.



Tutorial A: Getting Started with SAS Enterprise Guide     33 
 
 

Both the Project Tree and the Process Flow show the various parts of your project and 
how they are related. In the Process Flow, you can see that there are two arrows coming 
from the Tours data table. There is an arrow for the One-Way Frequencies task and one 
for the Scatter Plot task. Each task produces a report. The Process Flow makes it easy to 
see how the different parts of the project are related.   

 

An alternate view of your project can be found in the Project Tree. The Project Tree 
displays the same elements as the Process Flow, except they are arranged in a hierarchical 
tree diagram. The Project Tree is always visible, but since the Process Flow is in the 
workspace, it sometimes gets hidden by other items.  
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Adding a note to the project  A nice feature of SAS Enterprise Guide is that you 
can add notes to your projects to document them. To add a note to the project, click the 
words Process Flow in the Project Tree so that the note will be associated with the entire 
process flow instead of a particular item. Then select File ► New ► Note from the menu 
bar.   
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Enter a brief description of the project in the Note text box that appears in the workspace.  

 

You can collapse the note into an icon by clicking the x in the upper right corner of the text 
box, or you can enlarge the text box by clicking the down-arrow in the upper left corner 
and selecting Open from the pop-up menu. You can also drag the note to another location 
in the Process Flow. 
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Saving the project  SAS Enterprise Guide will always ask if you want to save any 
changes before allowing you to exit. Of course, you can save your work at any time before 
exiting. All the tasks created in your project, along with the results and any notes, are 
saved in the project. The data files are saved outside the project file—only the shortcuts to 
the data files are saved in the project. To save the project, select File ► Save Project As 
from the menu bar.  
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Navigate to the location where you want to save the project. Give the project the filename 
TutorialA and click Save. 

  

 

 

 

 

 

 

 

 

 

 

 

 

Now you can exit SAS Enterprise Guide and all your work and data will be saved. From 
the menu bar, select File ► Exit to exit SAS Enterprise Guide and complete the first 
tutorial. 
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1.1 SAS Enterprise Guide Windows 
SAS Enterprise Guide has many windows. You can customize the appearance of SAS Enterprise 
Guide—closing some windows, opening others, and resizing them all—until it looks just the 
way you want. Then SAS Enterprise Guide will remember those settings so the next time you 
open it, everything will be just where you left it.  

Here is SAS Enterprise Guide with its windows in their default positions.  

  

Some windows are open by default while some are closed or hidden behind other windows. You 
can open or unhide the major windows using the View menu.  

Docked windows  Some of the windows in SAS Enterprise Guide are docked. Most of the 
docked windows can appear on the left or right side of the SAS Enterprise Guide window. To 
change a window from one side to the other, click the down-arrow in the upper-right corner of 
the window and select Dock Left or Dock Right from the pop-up menu. From this menu, you 
can also select Auto Hide. If you hide a window, it will be reduced to a tab along the side. To 
view a hidden window, position your cursor over the window’s tab. When you move the cursor 
out of the window, it will be reduced to a tab again. To unhide a window, click its tab or select it 
from the View menu. These windows are docked: 

Project Tree  The Project Tree window displays the items in a project in a 
hierarchical tree diagram. This window is open by default.  

Servers  The Servers window lists all available SAS servers, and the files and SAS 
data libraries on those servers. A SAS server is any computer on which SAS software is 
installed. The computer on which you run SAS Enterprise Guide may or may not be a 
SAS server. This window appears in the Resources pane, and is open by default. 

  

Workspace showing  
the Process Flow 

Resources pane 
showing the 

Servers 

Project Tree 
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Tasks  The Tasks window lists all available tasks. You can open a task by double-
clicking its name in this window. This window appears in the Resources pane, and is 
closed by default. To open this window, click its icon in the Resources pane. 

SAS Folders  The SAS Folders window lists any SAS folders that have been defined 
on the SAS server. This window appears in the Resources pane, and is closed by 
default. To open this window, click its icon in the Resources pane. 

Data Exploration History  The Data Exploration History window displays a list 
of SAS data tables you have viewed in the Data Explorer. This window appears in the 
Resources pane, and is closed by default. To open this window, click its icon in the 
Resources pane. 

Prompt Manager  The Prompt Manager window lists any prompts defined for the 
current project. This window appears in the Resources pane, and is closed by default. 
To open this window, click its icon in the Resources pane. 

Task Status  The Task Status window displays notes about tasks that are currently 
running. This window is different from other docked windows because it is docked to 
the bottom, and you cannot move it or reduce it to a tab. This window is closed by 
default. To open the Task Status window, select it from the View menu.  

Workspace  The workspace is not itself a window, but it is very important. This is where the 
Process Flow window and other items appear including data, results, programs, logs, and notes. 
The workspace is always there and cannot be closed. However, you can open and close 
individual items inside the workspace.  

Process Flow  The Process Flow window displays the items in a project and their 
relationship using a schematic diagram. You can create as many process flows as you 
want inside a single project. There are several ways to open a process flow. You can 
select it from the View menu, double-click its name in the Project Tree, select it from the 
drop-down list at the top of the workspace, select the  drop-down list 
on the menu bar, or press F4.  

Menus and tools  The menus and tools across the top of SAS Enterprise Guide (also called 
the menu bar) are always the same. However, the menus and tools inside the workspace (also 
called the workspace toolbar) change. For example, the options above a Process Flow are 
different from the options above a data table. You can also right-click many objects to open a 
pop-up menu for that object. So you can see that there are often several ways to do the same 
thing. This book cannot list all the ways to do every action, but with a little exploration you can 
find them.  

Restoring windows  Once you have rearranged your windows, you may decide you want 
them back where they started. To restore them to their original locations, select Tools ► Options
from the menu bar. Then in the General page of the Options window, click Restore Window 
Layout. 
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1.2     Projects 
In SAS Enterprise Guide, all the work you do is organized into projects. A project is a collection 
of related data, tasks, results, programs, and notes. Projects help you by keeping track of 
everything, even if your data are scattered in many directories or on more than one computer. 
That way, when you come back to an old project six months or a year later, you won’t be left 
wondering which data tables you used or what reports you ran.  

You can have as many projects as you like, and you can use a data table over and over again in 
different projects, so there is a lot of flexibility. In a single SAS Enterprise Guide session, you can 
open only one project at a time. However, you can open more than one SAS Enterprise Guide 
session, each displaying a different project. Also, keep in mind that if you share a project with 
someone else, that person must have access to your data files and any other items you reference. 

To create a new project, select File ► New ► Project from the menu bar. To open an existing 
project, select File ► Open ► Project and navigate to your project. 

Project Tree and Process Flow  The Project Tree window displays projects in a 
hierarchical tree diagram, while the Process Flow window displays projects using a schematic 
diagram. In either window, the items in your project are represented by icons, and connected to 
show the relationship between items. Here are examples of a Project Tree and a Process Flow 
showing the same project. This project contains several types of items: data, tasks, results, a 
program, and a note.  

          

Data  Data files in a project may be SAS data tables, raw data files, or files from other 
databases or applications, such as Microsoft Excel spreadsheets. Projects contain 
shortcuts to data files, not the actual data. If you delete a project, your data files will still 
exist. This icon represents a SAS data table. 

Tasks  Tasks are specific analyses or reports that you run, such as List Data or Bar 
Chart. Every time you run a task, SAS Enterprise Guide adds an icon representing that 
task. This icon represents the Bar Chart task. 
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Results  Results are the reports or graphs produced by tasks you run. Results are 
represented by icons labeled with the type of output (SAS Report, HTML, PDF, RTF, 
text, PowerPoint, or Excel) and the name of the task. This icon represents output in SAS 
Report format. 

Notes  Notes are optional text files you can use to document your work, or record 
comments or instructions for later use.  

Programs  Programs are files that contain SAS code. You can open existing programs 
in SAS Enterprise Guide, or you can write new programs. 

Showing properties and opening items  You can display the properties for any item by 
right-clicking its icon in the Project Tree or Process Flow and selecting Properties from the pop-
up menu. You can open any item by double-clicking its icon, or by right-clicking its icon and 
selecting Open from the pop-up menu.  

Renaming and deleting items  You can rename most items by right-clicking the item and 
selecting Rename from the pop-up menu. You can delete an item from a project by right-clicking 
and selecting Delete. Note that if you delete data from a project, only the shortcut is deleted, not 
the actual data file.  

Saving a project  To save a project, select File ► Save project-name or File ► Save project-
name As from the menu bar. Each project is saved as a single file and has a file extension of .egp. 
You can save data, programs, and results in separate files by right-clicking the icon for that item 
and selecting Export from the pop-up menu. 
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1.3 Maximizing and Splitting the Workspace 
The workspace is a busy place. In addition to the process flow diagram, it is home to your data, 
results, program, log, and notes. By default, you can see only one of these items at a time, but 
you can see two if you split the workspace.  

Maximizing the workspace  If 
your screen is small, you may want to 
make the workspace as large as possible 
before you split it. To do this, select View 
► Maximize Workspace from the menu 
bar. When you maximize the workspace, 
the Project Tree and Resources pane 
become tabs pinned to the edge. You can 
temporarily expand those windows by 
moving the cursor over a tab. When you 
move the cursor away, the window will 
be reduced to a tab again. To return the workspace to its  
normal size, select View ► Maximize Workspace again. 

Splitting the workspace  You can split the workspace into two pieces. To do this, click the 

Workspace Layout icon  on the menu bar, and select either Stacked or Side By Side from 
the pull-down list. You can also do this by selecting View ► Workspace Layout from the menu 
bar. 
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You can click the down-arrow at the top of the workspace to view a pull-down list of recently 
viewed items in your project. To display an item, select it from the list. In this example, the 
workspace has been split side by side. The left side shows a Process Flow window while the 
right shows a Data Grid. 

 

To unsplit the workspace, click the Workspace Layout icon again, and select Single from the 
pull-down list. You can also click one of the Xs in the upper-right corners to close that section of 
the workspace. 
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1.4 Managing Process Flows 
SAS Enterprise Guide projects can contain an unlimited number of process flows. So, if you have 
a complex project, you may want to divide it into several process flows.  

Adding new process flows  To add a new process flow to a project, select File ► New ► 
Process Flow from the menu bar, or right-click the current process flow and select New ► 
Process Flow from the pop-up menu. No matter how many process flows you create, the Project 
Tree will show all of them in a single tree diagram. 

 

To view a process flow, double-click its name in the Project Tree, select it from the 
 drop-down list on the menu bar, or click the down-arrow above the workspace 

to open a pull-down list of recently viewed items. 

Customizing process flows  When you right-click a process flow, the pop-up menu 
displays options for customizing the appearance of that process flow. Options include Grid, 
Layout, Auto Arrange, Zoom, and Background 
Color. 

Renaming and deleting process flows  
When you add a new process flow, it is named 
Process Flow (n). To give a process flow a more 
descriptive name, right-click its name in the 
Project Tree and select Rename from the pop-up 
menu. To delete a process flow, right-click its 
name in the Project Tree and select Delete from 
the pop-up menu.   
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Moving and copying items  To move items from one process flow to another, hold down 
the control key (CTRL), and click all the items you want to move. Then right-click, and select 
Move to ► process-flow-name from the pop-up menu. In this example, three items are being
moved to a process flow named TourReports.  

Copying items is similar to moving items except that you must also paste the items. Select the 
items to be copied using control-click. Then right-click the items and select Copy from the pop-
up menu, and right-click the target process flow and select Paste.  

Printing process flows  You can 
print a copy of your process flow. To 
control the page size and orientation, 
click the process flow and select File ►
Page setup for Process Flow from the 
menu bar. To preview a printout, select 
File ► Print preview for Process Flow.
To print the process flow, select File ►
Print Process Flow. Here is the Print 
preview window for the new process 
flow named TourReports. 
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1.5 Running Projects and Process Flows 
Projects have a lot of different parts. When you use a project, you may want to run the entire 
project, or one process flow, or a branch of a process flow, or even just one item. You can run any 
part of your project, but the way you do that depends on which part you want to run.   

Running a project  To run a complete project, select File ► Run project-name from the menu 
bar, or click Run on the workspace toolbar above a Process Flow and select Run Project from the 
pull-down menu.  

 

If you have more than one process flow in your project, then they will run in the order in which 
they appear in the Project Tree. To change that order, click the name of a process flow in the 
Project Tree and drag it to the place where you want it to be.  

Running a process flow  To run a 
particular process flow, right-click the name of 
the process flow in the Project Tree and select 
Run process-flow-name  from the pop-up 
menu, or click Run on the workspace toolbar 
above that Process Flow and select Run 
process-flow-name from the pull-down menu. 
The branches in the process flow will run from 
top left to bottom right. In this example, a 
process flow named VolcanoReports is being 
run from the Project Tree.  
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Running part of a process 
flow  To run one branch of a 
process flow or an individual 
item, right-click the icon for that 
item or branch, and select Run 
or Run Branch from item-name  
from the pop-up menu. You can 
also click that icon (to make it 
active) and then click Run on 
the workspace toolbar and select 
Run item-name or Run Branch 
from item-name from the pull-down menu. In this example, a branch starting with a List Data 
task is being run from the process flow.  

Creating an Autoexec process flow  Sometimes you have items in a project that must 
run first. For example, you might have an Assign Library or Create Format task that must run 
before anything else in your project. Dragging these items to the top left corner of your process 
flow will make them run first if you run the entire process flow, but that doesn't help if you run 
some other part of your process flow. For situations like this, you can create a special process 
flow called an Autoexec process flow. When SAS Enterprise Guide sees a process flow with the 
name Autoexec, it knows to run it whenever you open that project. To create an Autoexec 
process flow, simply add a new process flow as described in the preceding section, and give it 
the name Autoexec. Then, by default, every time you open that project, a box will open asking if 
you want to run the Autoexec process flow. 

You can tell SAS Enterprise Guide to run the Autoexec process flow automatically without 
prompting you. To do that, select Tools ► Options from the menu bar to open the Options 
window. In the General page, check Automatically run "Autoexec" process flow when project 
opens, and click OK.  
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1.6 Linking Items in Process Flows 
When you run a process flow, items are executed from top left to bottom right, following the 
branches created by links between items. If you want to change the order in which items run, 
you can click and drag icons to a new place in the process flow, or you can add links. For 
example, if you create a format that is used by a report, you might want to add a link to make 
sure that the task creating the format runs before the task creating the report. Adding links is 
also a good way to show relationships that may not be clear. Note that adding links does not 
change which data tables are used or how tasks are run. It only changes the order and shows 
relationships. 

This process flow contains a program that uses the Volcanoes data table. By default, the data 
table and program icons are not connected. Adding a link would make the relationships between 
items more clear.   

 
Adding links  To add a link, hover your cursor 
to one side of the first item. When the cursor 

changes from a cross with four arrows  to 

crosshairs , then you can click and drag the 
cursor to the second item to link them. You can 
also right-click the initial item and select Link 
item-name to from the pop-up menu. In this 
window, a link is being added from the Volcanoes 
data table to the Program icon.  
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Now the Volcanoes data icon has been linked to the program icon. If you look closely, you will 
see that the new link uses a dashed line instead of a solid line.  

Deleting links  To delete a link that you 
previously added, right-click the dashed line of 
the link and select Delete from the pop-up menu. 
A Delete Items window will open asking you to 
confirm whether you want to delete the link.  
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1.7 SAS Data Tables 
SAS Enterprise Guide can read and write many kinds of data files (see Chapter 2 for more on this 
topic), but for most purposes, you will want to have your data in a special form called a SAS data 
table. When you open a SAS data table, it is displayed in the workspace in a Data Grid. The 
following Data Grid shows the Tours data table that was created in Tutorial A. A new tour has 
been added for the volcano Lassen.  

 

 

  

Terminology  In SAS Enterprise Guide, rows are also called observations, columns are also 
called variables, and data tables are also called data sets. SAS Enterprise Guide uses all these 
terms. Some tasks use the term columns and others refer to variables, depending on the context.  

Data types and data groups  In SAS Enterprise Guide, there are two basic types of data: 
numeric and character. Numeric data are divided into four data groups: numeric, currency, time, and 
date. For each of these, SAS Enterprise Guide has special tools including functions for manipulating 
that type of data, and formats for displaying that type of data. SAS Enterprise Guide uses a different 
icon to identify each kind of data. 

Character data may contain numerals, letters, or special characters (such as $ and !) and 
can be up to 32,767 characters long. Character data are represented by a red pyramid 
with the letter A on it. 

Currency data are numeric values for money and are represented by a picture of 
banknotes. 

Date data are numeric values equal to the number of days since January 1, 1960. The 
table below lists four dates, and their corresponding SAS date and formatted values: 

Date                            SAS date value      MMDDYY10. formatted value 
January 1, 1959          -365                           01/01/1959 
January 1, 1960          0                                01/01/1960 
January 1, 1961          366                            01/01/1961 
January 1, 2020          21915                        01/01/2020 

Columns 
(also called Variables) 

Rows  
(also called Observations) 

Data Table  
(also called a Data Set) 
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You will rarely see unformatted SAS date values in SAS Enterprise Guide. However, 
because dates are numeric, you can use them in arithmetic expressions to find, for 
example, the number of days between two dates. Datetime values are included in this 
data group, and are the number of seconds since January 1, 1960. Date data are 
represented by a picture of a calendar. 

Time data are numeric values equal to the number of seconds since midnight. Time data 
are represented by a picture of a clock.  

Other numeric data, that are not dates, times, or currency, are simply called numeric. 
They may contain only numerals, decimal places (.), plus signs (+), minus signs (-), and 
E for scientific notation. Numeric data are represented by a blue ball with the numbers 
1, 2, and 3 on it. 

Numeric versus character  If the values of a column contain letters or special characters, 
they must be character data. However, if the values contain only numerals, then they may be either 
numeric or character. You should base your decision on how you will use the data. Sometimes data 
that consist solely of numerals make more sense as character data than as numeric. Zip codes, for 
example, are made up of numerals, but it just doesn’t make sense to add or subtract zip codes. Such 
values work better as character data. 

Names  By default, the names of data tables and columns in SAS Enterprise Guide may be up to 
32 characters in length, and can contain any character, including blanks. Table names cannot start 
with a blank or period. 

Moving data between SAS Enterprise Guide and Base SAS  Any data created in 
SAS Enterprise Guide can be used in Base SAS, but the default rules for names are different. Base 
SAS uses the VALIDMEMNAME=COMPATIBLE SAS system option for tables and 
VALIDVARNAME=V7 for columns. SAS Enterprise Guide uses VALIDMEMNAME=EXTEND for 
tables, and VALIDVARNAME=ANY for columns. For the sake of compatibility, you may want to 
follow these rules: choose names that are 32 characters or fewer in length, start with a letter or 
underscore, and contain only letters, numerals, and underscores.  

To tell SAS Enterprise Guide to use the same rules for names as Base SAS, select Tools ► Options
from the menu bar to open the Options window, and select Data General in the selection pane on 
the left. In the section labeled Naming Options, click the down-arrow for Valid variable names, 
and select Basic variable names (V7). Then click the down-arrow for Valid member names, and 
select Basic member names (COMPATIBLE).  

Missing data  Sometimes, despite your best efforts, your data may be incomplete. The data 
values in a particular column may be missing for some rows. In those cases, missing character data 
are represented by blanks, and missing numeric data are represented by a single period (.). In the 
preceding Data Grid, the value of Price is missing for the tour of Lassen, and its place is marked by 
a period. The value of Difficulty is missing for the same tour and is left blank.  

Documentation stored in SAS data tables  In addition to your actual data, SAS data 
tables contain information about the data table, such as its name, the date that you created it, and 
the version of SAS that you used to create it. SAS also stores information about each column in the 
data table, including its name, type, and length. This information is called the descriptor portion of 
the data table, and it makes SAS data tables self-documenting. This information is what you see in 
the Properties windows for data tables and columns. These Properties windows are described in 
more detail in the next two sections. 
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1.8 Viewing Properties of Data Tables and Columns 
The Properties window for a data table displays general information about the data table, such 
as the date the table was created, along with information about each column in the table. You 
cannot make any changes in this window, but it is a handy way to find out more about your 
data. 

Opening the Properties window  To display information about a data table, first open it 
in a Data Grid by double-clicking the data icon in the Project Tree or Process Flow. Then click the 

Properties icon  on the workspace toolbar to open the table Properties window. In this 
example, the Properties window is being opened for the Volcanoes data table.   

You can also right-click a data icon in the Project Tree or Process Flow, and select Properties from 
the pop-up menu. 
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General page  When the table Properties window opens, it displays the General page. The 
General page lists basic information about the table: its name, when it was created and last 
modified, and whether it is a SAS data table or some other type of file.  

Columns page  If you click Columns in the selection pane on the left, the Columns page will 
open. Here, SAS Enterprise Guide displays information about each column: its name, type, 
length, format, informat, and label. You cannot change the properties of columns in the 
Properties window for a data table. To make changes, use the Properties window for an 
individual column as described in the next section.  
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1.9 Changing Properties of Columns 
The column Properties window displays properties for an individual column. You can use this 
window inside a task to change labels and display formats, but those changes will apply only to 
the results of that task rather than to the original data table. However, if you open the column 
Properties window inside a Data Grid, then any changes you make will be saved with the data 
table. 

Setting the update mode  The Data Grid opens in read-only mode. In this mode you 
cannot edit the data, and you cannot change column properties. To switch to update mode, select 
Edit ► Protect Data from the menu bar. This toggles the data table from read-only to update
mode. To return to read-only 
mode, select Edit ► Protect Data
again. 

Opening the Properties 
window  To open the column 
Properties window, right-click 
the header of a column and 
select Properties from the pop-
up menu. In this Data Grid, 
Properties is being selected for 
the column Height. 

General page  The 
Properties window has 
several pages. If there 
is no selection pane on 
the left, then the data 
table is in read-only 
mode and you need to 
switch to update 
mode. 

The General page 
displays basic 
information for the 
column: its name, 
label, type, group, and 
length. You can change 
any of these properties. 
In this example, the 
column name has been 
changed to 
HeightMeters, and the 
label to Height in 
Meters. This column is 
numeric and has a 
length of 8.  
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Formats page  Click 
Formats in the 
selection pane on the 
left to open the 
Formats page. Formats 
(also called display 
formats) tell SAS 
Enterprise Guide how 
data should look in 
Data Grids or reports. 
There are different 
formats for character, 
numeric, date, time, 
and currency data. In 
this example, the 
format COMMAw.d 
with a width of 6 and 
no decimal places 
(COMMA6.0) has been 
selected. See the next 
section for a table of 
commonly used 
formats. To apply your 
changes, click OK. 

 

Informats page  If you click Informats in the selection pane on the left, the Informats page 
will open (not shown). Informats (also called input formats or read-in formats) tell SAS how to 
interpret input data. In SAS Enterprise Guide, you can use informats when you import certain 
types of data files, and when you write SAS programs. However, informats are not used when 
you type data values into a Data Grid. Instead, the Data Grid uses the data type and data group 
that you specify to determine how to interpret any data values you enter. So, informats are rarely 
used in SAS Enterprise Guide.  

Results  Here is the 
Data Grid showing the 
new name, HeightMeters, 
and the formatted data 
values with commas.  
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1.10 Selected Standard Formats 
SAS formats (also called display formats) tell SAS Enterprise Guide how to display or print data. 
You can apply formats in a column Properties window in a Data Grid, a task, or a query. Here are a 
few of the many formats that are available in SAS Enterprise Guide. 

Format Definition Width 
range  

Default width 

Character 
$UPCASEw. Converts character data to uppercase 1–32767 Length of column or 8 
$w. Writes standard character data—default for 

character data 
1–32767 Length of column or 1 

Date, Time, and Datetime1 
DATEw. Writes SAS date values in the form ddmonyy 

or ddmonyyyy 
5–11 7 

DATETIMEw.d Writes SAS datetime values in the form 
ddmmmyy:hh:mm:ss.ss 

7–40 16 

DTDATEw. Writes SAS datetime values in the form 
ddmonyy or ddmonyyyy 

5–9 7 

EURDFDDw. Writes SAS date values in the form dd.mm.yy 
or dd.mm.yyyy 

2–10 8 

JULIANw. Writes SAS date values in the Julian date 
form yyddd or yyyyddd 

5–7 5 

MMDDYYw. Writes SAS date values in the form mm/dd/yy 
or mm/dd/yyyy—default for dates 

2–10 8 

TIMEw.d Writes SAS time values in the form 
hh:mm:ss.ss—default for times 

2–20 8 

WEEKDATEw. Writes SAS date values in the form 
day-of-week, month-name dd, yy or yyyy 

3–37 29 

WORDDATEw. Writes SAS date values in the form 
month-name dd, yyyy 

3–32 18 

Numeric 
BESTw. The SAS System chooses the best format—

default format for numeric data 
1–32 12 

COMMAw.d Writes numbers with commas 2–32 6 
DOLLARw.d Writes numbers with a leading $ and commas 

separating every three digits—default for 
currency 

2–32 6 

Ew. Writes numbers in scientific notation 7–32 12 
EUROXw.d Writes numbers with a leading € and periods 

separating every three digits 
2–32 6 

PERCENTw.d Writes proportions as percentages 4–32 6 
w.d Writes standard numeric data 1–32 none 

1 SAS date values are the number of days since January 1, 1960.  Time values are the number of seconds past midnight, and 
  datetime values are the number of seconds past midnight on January 1, 1960. 
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The examples below show unformatted data values and formatted results for each display format. 

Format Data value Results Data value Results 

Character 
$UPCASE10. Lassen LASSEN St. Helens ST. HELENS 
$6. Lassen Lassen St. Helens St. He 

Date, Time, and Datetime 
DATE9. 366 01JAN1961 396 31JAN1961 

DATETIME16. 37800 01JAN60:10:30 2629800 31JAN60:10:30 

DTDATE9. 37800 01JAN1960 2629800 31JAN1960 

EURDFDD10. 366 01.01.1961 396 31.01.1961 

JULIAN7. 366 1961001 396 1961031 

MMDDYY10. 366 01/01/1961 396 01/31/1961 

TIME8. 37800 10:30:00 37815 10:30:15 

WEEKDATE15. 366 Sun, Jan 1, 61 396 Tue, Jan 31, 61 

WORDDATE12. 366 Jan 1, 1961 396 Jan 31, 1961 

Numeric 
BEST10. 
BEST6. 

1000001 
1000001 

1000001 
1E6 

-12.34 
100001 

-12.34 
100001 

COMMA12.2 1000001 1,000,001.00 -12.34 -12.34 

DOLLAR13.2 1000001 $1,000,001.00 -12.34 $-12.34 

E10. 1000001 1.000E+06 -12.34 -1.234E+01 

EUROX13.2 1000001 €1.000.001,00 -12.34 €-12,34 

PERCENT9.2 0.05 5.00% -1.20 (120.00%) 

10.2 1000001 1000001.00 -12.34 -12.34 
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1.11 Documenting Projects with Notes 
In many ways, projects in SAS Enterprise Guide are self-documenting. You can look at the 
Project Tree and Process Flow and see the parts of a project and how they fit together. However, 
unless your project is very simple, it is good practice to document your work. You do this with 
notes.  

Adding a note for a process flow  To add a note for an entire process flow, right-click the 
process flow background and select New ► Note from the pop-up menu. You can also add a note 
for a process flow by clicking the name of the process flow in the Project Tree, and selecting File 
► New ► Note from the menu bar. A small text box, which looks like a sticky note, will open.  

 

In this text box, you can type anything you want. You could type your favorite cookie recipe, but 
generally it makes more sense to record information about your work such as the purpose of the 
project and the date it was last updated. If you need more space, you can resize the text box by 
clicking and dragging the edges. If you click the down-arrow at the top of the text box and select 
Open from the pop-up menu, then this small text box will open in a Note window.  
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The Note window fills the 
workspace giving you more 
room to type. This example 
contains a brief description 
of the project.  

To close the Note window, 
click the X in the upper-right 
corner. If you click the X in 
the upper-right corner of the 
small text box, it will close 

and a note icon will 
appear in your process flow.  
To reopen the small text box, 
right-click the note icon and 
select Expand from the pop-
up menu.  To reopen the 
Note window, right-click the icon and select Open from the pop-up menu. 

Attaching a note to an item  You can also attach notes to individual items in a process 
flow. To do this, click that item and select File ► New ► Note from the menu bar. A Note
window will open. This process flow includes three notes: one for the entire process flow, one 
attached to a Bar Chart task, and one attached to a data table named Active. Notice that the note 
icon for the process flow is not linked to any other icons, but the note icons for the task and 
program are linked to their items.  



 

About This Book 
 
This book is divided into two distinct but complementary sections: a tutorials section and a 
reference section. Each tutorial is designed to give you a quick introduction to a general subject. 
The reference section, on the other hand, gives you focused information on specific topics. 
 

Tutorials section  If you are new to SAS Enterprise Guide, you’ll probably want to start with 
the tutorials. Each of the four tutorials leads you step-by-step through a complete project, from 
starting SAS Enterprise Guide to documenting what you’ve done before you exit. The tutorials 
are self-contained so you can do them in any order. People who know nothing about SAS or SAS 
Enterprise Guide should be able to complete a tutorial in 30 to 45 minutes. 
 

Reference section  Once you feel comfortable with SAS Enterprise Guide, you’ll be ready to 
use the reference section. This is where you’ll turn when you need a quick refresher on how to 
join data tables, or a detailed explanation of filtering data in a query. With 8 chapters and 67 
topics, the reference section covers more information than the tutorials, but each topic is covered 
in just two pages so you can read it in a few minutes. 
 

The data for this book  The data used for the examples in this book revolve around a 
theme: the Fire and Ice Tours company, a fictional company offering tours to volcanoes around 
the world. Using a small number of data sets over and over saves you from having to learn new 
data for every example. The data sets are small enough that you can type them in if you want to 
run the examples, but to make it even easier, the data are also available for downloading via the 
Internet. Appendix A contains both the data and instructions on how to download the data files. 
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