Contents

About SAS Enterprise Guide  ix
About This Book  i
Acknowledgments  xiii

Tutorials Section  1

Tutorial A Getting Started with SAS Enterprise Guide  3
  Starting SAS Enterprise Guide  3
  SAS Enterprise Guide windows  4
  Basic elements of SAS Enterprise Guide  4
  Entering data  5
  Creating a frequency report  22
  Creating a scatter plot  28
  Adding a note to the project  34
  Saving the project  36

Tutorial B Creating Reports  39
  Before beginning this tutorial  39
  Starting SAS Enterprise Guide  39
  Opening the Tours data set  40
  Creating a simple report  43
  Changing titles and footnotes  46
  Changing column labels and formatting values  51
  Defining your own formats  57
  Selecting a style for the report  66
  Changing the output format for the report  68
  Completing the tutorial  71

Tutorial C Working with Data in the Query Builder  73
  Before beginning this tutorial  73
  Starting SAS Enterprise Guide  73
  Opening the Volcanoes SAS data table  75
Opening the Query Builder  76
Selecting columns  78
Creating a new column  80
Ordering and removing columns  90
Filtering data  92
Sorting the data rows  100
Completing the tutorial  103

Tutorial D  Joining Two Data Tables Together  105
Before beginning this tutorial  105
Starting SAS Enterprise Guide  105
Opening the two data files to be joined  106
Joining tables  109
Filtering the data  118
Selecting which rows to keep  123
Completing the tutorial  129

Reference Section  131

Chapter 1  SAS Enterprise Guide Basics  133
  1.1  SAS Enterprise Guide Windows  134
  1.2  Splitting the Resources Pane and Workspace  136
  1.3  Projects  138
  1.4  Managing Process Flows  140
  1.5  Running and Rerunning Tasks  142
  1.6  Creating and Exporting Task Templates  144
  1.7  SAS Data Tables  146
  1.8  Properties of Data Tables  148
  1.9  Properties of Columns  150
  1.10  Selected Informats  152
  1.11  Selected Standard Formats  154
  1.12  Scheduling Projects to Run at Specific Times  156
  1.13  Editing SAS Programs Generated by a Task  158
  1.14  Writing and Running Custom SAS Programs  160
  1.15  Viewing Program and Project Logs  162
  1.16  Using the Options Window  164
<table>
<thead>
<tr>
<th>Chapter 2</th>
<th>Bringing Data into a Project</th>
<th>167</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.1</td>
<td>Sources of Data</td>
<td>168</td>
</tr>
<tr>
<td>2.2</td>
<td>Locations for Data</td>
<td>170</td>
</tr>
<tr>
<td>2.3</td>
<td>Assigning Libraries with the Assign Project Library Task</td>
<td>172</td>
</tr>
<tr>
<td>2.4</td>
<td>Creating New SAS Data Tables in a Data Grid</td>
<td>174</td>
</tr>
<tr>
<td>2.5</td>
<td>Editing SAS Data Tables in a Data Grid</td>
<td>176</td>
</tr>
<tr>
<td>2.6</td>
<td>Inserting Computed Columns in a Data Grid</td>
<td>178</td>
</tr>
<tr>
<td>2.7</td>
<td>Importing Microsoft Excel Spreadsheets</td>
<td>180</td>
</tr>
<tr>
<td>2.8</td>
<td>Importing Delimited Raw Data</td>
<td>182</td>
</tr>
<tr>
<td>2.9</td>
<td>Importing Fixed-Column Raw Data</td>
<td>184</td>
</tr>
<tr>
<td>2.10</td>
<td>Exporting Data</td>
<td>186</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 3</th>
<th>Changing the Way Data Values Are Displayed</th>
<th>189</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.1</td>
<td>Applying Standard Formats in a Data Grid</td>
<td>190</td>
</tr>
<tr>
<td>3.2</td>
<td>Applying Standard Formats in a Task</td>
<td>192</td>
</tr>
<tr>
<td>3.3</td>
<td>Defining Your Own Character Formats</td>
<td>194</td>
</tr>
<tr>
<td>3.4</td>
<td>Defining Your Own Numeric Formats</td>
<td>196</td>
</tr>
<tr>
<td>3.5</td>
<td>Applying User-Defined Formats</td>
<td>198</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 4</th>
<th>Modifying Data Using the Query Builder</th>
<th>201</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.1</td>
<td>Introducing the Query Builder</td>
<td>202</td>
</tr>
<tr>
<td>4.2</td>
<td>Selecting Columns in a Query</td>
<td>204</td>
</tr>
<tr>
<td>4.3</td>
<td>Creating Columns Using Mathematical Operators</td>
<td>206</td>
</tr>
<tr>
<td>4.4</td>
<td>Creating Columns Using Functions</td>
<td>208</td>
</tr>
<tr>
<td>4.5</td>
<td>Selected Functions</td>
<td>210</td>
</tr>
<tr>
<td>4.6</td>
<td>Adding a Grand Total to a Data Table</td>
<td>212</td>
</tr>
<tr>
<td>4.7</td>
<td>Adding Subtotals to a Data Table</td>
<td>214</td>
</tr>
<tr>
<td>4.8</td>
<td>Creating Summary Data Tables in a Query</td>
<td>216</td>
</tr>
<tr>
<td>4.9</td>
<td>Recoding Values in a Query</td>
<td>218</td>
</tr>
<tr>
<td>4.10</td>
<td>Changing the Result Type of Queries</td>
<td>220</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 5</th>
<th>Sorting and Filtering Data</th>
<th>223</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.1</td>
<td>Filtering Data in a Task</td>
<td>224</td>
</tr>
<tr>
<td>5.2</td>
<td>Using the Filter and Sort Task</td>
<td>226</td>
</tr>
<tr>
<td>5.3</td>
<td>Sorting Using the Sort Task</td>
<td>228</td>
</tr>
<tr>
<td>5.4</td>
<td>Sorting Data in a Query</td>
<td>230</td>
</tr>
<tr>
<td>5.5</td>
<td>Filtering Data in a Query</td>
<td>232</td>
</tr>
<tr>
<td>5.6</td>
<td>Creating Compound Filters in a Query</td>
<td>234</td>
</tr>
<tr>
<td>5.7</td>
<td>Creating a Filter with Advanced Expressions</td>
<td>236</td>
</tr>
</tbody>
</table>
Chapter 6 Combining Data Tables 239
  6.1 Methods for Combining Tables 240
  6.2 Appending Tables 242
  6.3 Joining Tables 244
  6.4 Setting the Properties of a Join 246

Chapter 7 Producing Simple List and Summary Reports 249
  7.1 Creating Simple List Reports 250
  7.2 Customizing Titles and Footnotes 252
  7.3 Adding Groups to List Reports 254
  7.4 Adding Totals to List Reports 256
  7.5 Creating Frequency Reports 258
  7.6 Creating Crosstabulations 260
  7.7 Creating Simple Summary Reports 262
  7.8 Creating Summary Data Sets in a Task 264
  7.9 Creating Grouped Reports with User-Defined Formats 266

Chapter 8 Producing Complex Reports in Summary Tables 269
  8.1 Creating Summary Tables with Frequencies 270
  8.2 Adding Statistics to Summary Tables 272
  8.3 Changing Heading Properties in Summary Tables 274
  8.4 Changing Class Level Headings and Properties in Summary Tables 276
  8.5 Changing Table Properties in Summary Tables 278
  8.6 Changing Data Value Properties in Summary Tables 280

Chapter 9 Basic Statistical Analysis 283
  9.1 Distribution Analysis 284
  9.2 Summary Statistics 286
  9.3 Table Analysis 288
  9.4 Correlations 290
  9.5 Linear Regression 292
  9.6 Analysis of Variance 294

Chapter 10 Producing Graphs 297
  10.1 Bar Charts 298
  10.2 Pie Charts 300
  10.3 Simple Line Plots 302
CHAPTER 1

SAS Enterprise Guide Basics

1.1 SAS Enterprise Guide Windows 134
1.2 Splitting the Resources Pane and Workspace 136
1.3 Projects 138
1.4 Managing Process Flows 140
1.5 Running and Rerunning Tasks 142
1.6 Creating and Exporting Task Templates 144
1.7 SAS Data Tables 146
1.8 Properties of Data Tables 148
1.9 Properties of Columns 150
1.10 Selected Informatns 152
1.11 Selected Standard Formats 154
1.12 Scheduling Projects to Run at Specific Times 156
1.13 Editing SAS Programs Generated by a Task 158
1.14 Writing and Running Custom SAS Programs 160
1.15 Viewing Program and Project Logs 162
1.16 Using the Options Window 164
1.1 SAS Enterprise Guide Windows

SAS Enterprise Guide has many windows. You can customize the appearance of SAS Enterprise Guide—closing some windows, opening others, and resizing them all—until it looks just the way you want. Then SAS Enterprise Guide will remember those settings so the next time you open it, everything will be just where you left it.

Here is SAS Enterprise Guide with its windows in their default positions.

Some windows are open by default while some are closed or hidden behind other windows. You can open or unhide the major windows using the View menu.

**Docked windows** Some of the windows in SAS Enterprise Guide are docked. Most of the docked windows can appear on the left or right side of the application. To change a window from one side to the other, click the down arrow (▼) in the upper-right corner of the window and select **Dock Left** or **Dock Right** from the pop-up menu. From this menu, you can also select **Auto Hide**. If you hide a window, it will be reduced to a tab along the side. To view a hidden window, position your cursor over the window’s tab. When you move the cursor out of the window, it will be reduced to a tab again. To unhide a window, click its tab or select it from the View menu. These windows are docked:

- **Project Tree** The Project Tree window displays the items in a project in a hierarchical tree diagram. This window is open by default.
Chapter 1: SAS Enterprise Guide Basics

Server List  The Server List window lists available SAS servers, and the files and SAS data libraries on those servers. A SAS server is any computer on which SAS software is installed. The computer on which you run SAS Enterprise Guide may or may not be a SAS server. This window appears in the Resources pane, and is open by default.

Task List  The Task List window lists all available tasks and task templates. Using the drop-down list at the top of this window, you can choose to display tasks by category, tasks by name, or task templates. You can open a task by double-clicking its name in this window. This window appears in the Resources pane, and is closed by default. To open this window, click its icon in the Resources pane.

SAS Folders  The SAS Folders window lists any folders that have been defined in metadata. This window appears in the Resources pane, and is closed by default. To open this window, click its icon in the Resources pane.

Prompt Manager  The Prompt Manager window lists any prompts defined for the current project. This window appears in the Resources pane, and is closed by default. To open this window, click its icon in the Resources pane.

Task Status  The Task Status window displays notes about tasks that are currently running. This window is different from other docked windows because it is docked to the bottom of the application, and you cannot move it or reduce it to a tab. This window is closed by default. To open the Task Status window, select it from the View menu.

Workspace  The workspace is not itself a window, but it is very important. This is where the Process Flow and document windows appear. The workspace is always there and cannot be closed. However, you can open and close individual items inside the workspace.

Process Flow  The Process Flow window displays the items in a project and their relationship using a process flow diagram. You can open only one project at a time, but you can create as many process flows as you wish inside a single project. You can open the Process Flow by selecting it from the View menu, by double-clicking its name in the Project Tree, by selecting it from the drop-down list at the top of the workspace, by selecting the Process Flow drop-down list on the menu bar, or by pressing F4.

Document windows  The document windows display your data, results, programs, logs, and notes. There is a different type of icon for every kind of document. This icon represents a SAS data table.

Menus and tools  The menus and tools across the top of SAS Enterprise Guide (also called the menu bar) are always the same. However, the menus and tools inside the workspace (also called the workspace toolbar) change. For example, the options above a Process Flow are different from the options above a data table. You can also right-click many objects to open a pop-up menu for that object. So you can see that there are often several ways to do the same thing. This book cannot list all the ways to do every action, but with a little exploration you can find them.

Restoring windows  Once you have rearranged your windows, you may decide you want them back where they started. To restore them to their original locations, select Tools ➤ Options from the menu bar. Then in the General page of the Options window, click Restore Window Layout.
1.2 Splitting the Resources Pane and Workspace

The Resources pane and the workspace are busy places. The Resources pane is home to four windows, while the workspace accommodates even more. By default, you can see only one item at a time, but you can see more if you split the Resources pane or workspace.

Splitting the Resources pane

To split the Resources pane, click the down-arrow (▼) at the top of the pane, and select Show Multiple from the pull-down list. At first, you will only see one window because only one window is open.

To open other windows, click their icons: Task List, SAS Folders, Server List, or Prompt Manager. You can open all four windows at once in the Resources pane if you wish. In this example, two windows are open, the Task List and the Server List.

To return the Resources pane to normal, click the down-arrow and select Show One.
Maximizing the workspace  It may be helpful to make the workspace as large as possible before you split it. To do this, select View ➤ Maximize Workspace from the menu bar. When you maximize the workspace, the Project Tree and Resources pane become tabs pinned to the edge of SAS Enterprise Guide. You can temporarily expand those windows by moving the cursor over a tab. When you move the cursor away, the window will be reduced to a tab again. To return the workspace to its normal size, select View ➤ Maximize Workspace again.

Splitting the workspace  You can split the workspace into two pieces. First, open any items you wish to view. Then click the Workspace Layout icon on the menu bar, and select either Stacked or Side By Side from the pull-down list. You can also do this by selecting View ➤ Workspace Layout from the menu bar.

You can click the down-arrow at the top of the workspace to view a drop-down list of all items that are currently open. To display an item, select it from the list.

To unsplit the workspace, click the Workspace Layout icon again, and select Single from the pull-down list. You can also click one of the Xs in the upper-right corners to close that section of the workspace.
1.3 Projects

In SAS Enterprise Guide, all the work you do is organized into projects. A project is a collection of related data, tasks, results, programs, and notes. Projects help you by keeping track of everything, even if your data are scattered in many directories or on more than one computer. That way, when you come back to an old project six months or a year later, you won’t be left wondering which data sets you used or what reports you ran.

You can have as many projects as you like, and you can use a data set over and over again in different projects, so there is a lot of flexibility. However, you can have only one project open at a time. Also, if you share a project file with someone else, that person must have access to your data files and any other items you reference.

To create a new project, select File ▶ New ▶ Project from the menu bar. To open an existing project, select File ▶ Open ▶ Project and navigate to your project.

Project Tree and Process Flow  The Project Tree window displays projects in a hierarchical tree diagram, while the Process Flow window displays projects using a process flow diagram. In either window, the items in your project are represented by icons, and connected to show the relationship between items. Here are examples of a Project Tree and a Process Flow showing the same project. This project contains several types of items: data, tasks, results, a program, and a note.

Data  Data files in a project may be SAS data tables, raw data files, or files from other databases or applications, such as Microsoft Excel spreadsheets. Projects contain shortcuts to data files, not the actual data. If you delete a project, your data files will still exist. This icon represents a SAS data table.

Tasks Tasks are specific analyses or reports that you run, such as List Data or Bar Chart. Every time you run a task, SAS Enterprise Guide adds an icon representing that task. This icon represents the Bar Chart task.

Results Results are the reports or graphs produced by tasks you run. Results are represented by icons labeled with the type of output (SAS Report, HTML, PDF, RTF, or text) and the name of the task. This icon represents output in SAS Report format.
Notes  Notes are optional text files you can use to document your work, or record comments or instructions for later use. To create a note, select File ► New ► Note from the menu bar. A text window will open, allowing you to type whatever you wish.

Programs  Programs are files that contain SAS code. You can open existing programs in SAS Enterprise Guide, or you can write new programs.

Showing properties and opening items  You can display the properties for any item by right-clicking its icon in the Project Tree or Process Flow and selecting Properties from the pop-up menu. You can open any item by double-clicking its icon, or by right-clicking its icon and selecting Open from the pop-up menu.

Renaming and deleting items  You can rename most items by right-clicking the item and selecting Rename from the pop-up menu. You can delete an item in a project by right-clicking and selecting Delete. Note that if you delete data from a project, only the shortcut to that data is deleted, not the actual data file.

Saving a project  To save a project, select File ► Save project-name or File ► Save project-name As from the menu bar. Each project is saved as a single file and has a file extension of .egp. You can save data, programs, and results in separate files by right-clicking the icon for that item and selecting Export from the pop-up menu.
1.4 Managing Process Flows

In SAS Enterprise Guide, you can have only one project open at a time. However, you can have an unlimited number of process flows within a single project. So, if you have a complex project, you may want to divide it into several process flows.

Adding new process flows  To add a new process flow to a project, select File ▶ New ▶ Process Flow from the menu bar, or right-click the current process flow and select New ▶ Process Flow from the pop-up menu. No matter how many process flows you create, the Project Tree will show all of them in a single tree diagram.

When you right-click a process flow, the pop-up menu displays options for customizing the appearance of that process flow. Options include Grid, Layout, Auto Arrange, Zoom, and Background Color.

To view a process flow, double-click its name in the Project Tree, or click the down-arrow (▼) above the workspace to open a pull-down list.

When you add a new process flow, it is named Process Flow n. To give a process flow a more descriptive name, right-click its name in the Project Tree and select Rename from the pop-up menu. To delete a process flow, right-click its name in the Project Tree and select Delete from the pop-up menu.

Moving and copying items  To move items from one process flow to another, hold down the control key (CTRL), and click all the items you want to move. Then right-click, and select Move to ▶ process-flow-name from the pop-up menu. In this example, three items are being moved to the process flow named TourReports.
Copying items is similar to moving items except that you cannot copy results. Select the items to be copied using control-click. Then right-click the items and select Copy from the pop-up menu, and right-click the target process flow and select Paste.

Linking items When you run a process flow, items are executed from top left to bottom right, following the branches created by links between items. You can add links between items to show relationships that may not be clear, or to force items to run in a particular order. For example, if you create a format that is used by a task, you might want to add a link indicating that the task follows the format. To add a link, right-click the initial item and select Link item-name to from the pop-up menu. A Link window will open showing all the other items to which you can link. Select the item to which you want to link, and click OK.

In this process flow, the Volcanoes data icon has been linked to a program icon to show that this program uses the Volcanoes data table. Notice that when you add links they use a dashed line instead of a solid line.

To delete a link that you previously added, right-click the icon for that link ➔ in the Project Tree and select Delete from the pop-up menu.

Printing process flows You can print a copy of your process flow. To control page size and orientation, click the process flow and select File ➤ Page setup for Process Flow from the menu bar. To preview a printout, select File ➤ Print preview for Process Flow. To print the process flow, select File ➤ Print Process Flow. Here is the Print preview window for the VolcanoReports process flow.
1.5 Running and Rerunning Tasks

Running tasks is, of course, what SAS Enterprise Guide is all about. Regardless of which task you choose to run, the basic steps are the same: open the task, select the data, and then run the task.

**Opening a task** To open a task, select it from the **Tasks** menu, or click its name in the Task List window, or open a Data Grid and then select the task from the workspace toolbar. The window for that task will open. In this example, the List Data task is being selected in the Task List window.

**Selecting the data table** When you open a task, it will use the data table that is currently active. If a Data Grid is open, then that data table will be active. You can also make a data table active by simply clicking its icon in the Project Tree or Process Flow before you open a task.

After you open a task, you can change the data table by clicking the **Edit** button in the Data page of the task window. The Edit Data and Filter window (not shown) will open where you can choose an alternate data table for the task. See section 5.1 for details about the Edit Data and Filter window.
Running a task  Every task includes a Data page where you assign variables to task roles. Using the selection pane on the left, you can open other pages. The preceding image shows the List Data task, which has four pages: Data, Options, Titles, and Properties. When you are satisfied with all the settings, click the Run button. If you have more than one SAS server, your task will run on the same server where the data table is stored. If you decide you want to stop a task while it’s running, select Program ▶ Stop from the menu bar, or click the Stop button on the workspace toolbar above the Process Flow. When the task has finished running, the results will be displayed in the workspace.

Rerunning a task  
To make changes to a task and run it again, first reopen the task window. You can do this by clicking Modify Task on the workspace toolbar for the Results tab. You can also reopen a task by right-clicking the task icon in the Project Tree or Process Flow, and selecting Modify task-name from the pop-up menu.

Once the task window is open, you can make changes. Then click the Run button to rerun the task.

If you just want to rerun a task without reopening the task window, click Refresh on the workspace toolbar for the Results tab. You can also right-click the task icon in the Project Tree or Process Flow, and select Run from the pop-up menu.
1.6 Creating and Exporting Task Templates

Even with the simplest tasks, there are many ways to customize your results. Once you have spent a lot of time changing titles, choosing options, and specifying a style; you might wish you could save all those settings and use them to create new results. With task templates, you can.

Task templates allow you to save tasks in a form that is independent of data. In other words, task templates save all your settings except the assignment of variables to task roles and certain data-dependent options. Most tasks can create templates, but a few of the more data-driven tasks (including Summary Tables and Append Table) cannot. SAS programmers will be interested to know that task templates are unrelated to the various kinds of templates created by the Output Delivery System.

Creating a task template To create a task template from a task that you have already run, select Tasks ▶ Task Templates ▶ Task Template Manager from the menu bar. This opens the Task Template Manager. Click New to open the New Task Template window.

In the New Task Template window, type a name for the new template in the Name box. You can type an optional description in the Description box if you wish. The area labeled Create template from task lists all the tasks currently in the project. Choose a task by clicking its name. Then click Create. The new task template will be listed in the Task Template Manager. Click Close.

You can also create task templates directly from tasks. If the task window is open, then you can click the down-arrow (▼) on the Run button, and select Create Template from the pull-down list.

To delete a task template, simply open the Task Template Manager, click the task template name, and click Delete.
Using a task template  Once you create a task template, unless you delete it, it will be available to you every time you open SAS Enterprise Guide. There are two ways to open a task template. You can select Tasks ▶ Task Templates ▶ task-template-name from the menu bar, or you can open the Task List window, select Task Templates from the drop-down list, and click the name of your task template.

By default, when you open a task template, it uses the active data table. After you open a task template, you can choose a different data table by clicking the Edit button in the Data page.

Exporting a task template  When you create a task template, it will be saved in a default location. This location is associated with your Windows user account. To share task templates with other people (including anyone who uses the same computer, but a different Windows account), you must export the templates. To do this, open the Task Template Manager, and click Export. SAS Enterprise Guide will prompt you to select the templates you wish to export, and to specify a location for saving them.

To import task templates, open the Task Template Manager and click Import. Then navigate to the location of the task templates you wish to import.
1.7 SAS Data Tables

SAS Enterprise Guide can read and write many kinds of data files (see Chapter 2 for more on this topic), but for most purposes, you will want to have your data in a special form called a SAS data table. When you open a SAS data table, it is displayed in the workspace in a Data Grid. The following Data Grid shows the Tours data table that was created in Tutorial A. A new tour has been added for the volcano Lassen.

| 1 | Etna | Catania | 7 | $1.075 | m |
| 2 | Fuji | Tokyo | 2 | $225 | c |
| 3 | Kenya | Nairobi | 5 | $830 | m |
| 4 | Kilauea | Hilo | 1 | $55 | e |
| 5 | Kilimanjaro | Nairobi | 9 | $1,010 | c |
| 6 | Krakatau | Jakarta | 7 | $895 | e |
| 7 | Lassen | Sacramento | 3 | . |
| 8 | Poas | SanJose | 1 | $65 | e |
| 9 | Reventador | Guibo | 4 | $575 | m |
| 10 | St. Helens | Portland | 2 | $167 | e |
| 11 | Vesuvius | Rome | 5 | $385 | e |

Terminology  In SAS Enterprise Guide, rows are also called observations, columns are also called variables, and data tables are also called data sets. SAS Enterprise Guide uses all these terms. Some tasks use the term columns and others refer to variables, depending on the context.

Data types and data groups  In SAS Enterprise Guide, there are two basic types of data: numeric and character. Numeric data are divided into four data groups: numeric, currency, time, and date. For each of these, SAS Enterprise Guide has special tools: informats for reading that type of data, functions for manipulating that type of data, and formats for displaying that type of data. SAS Enterprise Guide uses a different icon to identify each kind of data.

Character data may contain numerals, letters, or special characters (such as $ and !) and can be up to 32,767 characters long. Character data are represented by a red pyramid with the letter A on it.

Currency data are numeric values for money and are represented by a picture of the dollar, euro, and yen symbols.

Date data are numeric values equal to the number of days since January 1, 1960. The table below lists four dates, and their corresponding SAS date and formatted values:

<table>
<thead>
<tr>
<th>Date</th>
<th>SAS date value</th>
<th>MMDDYY10. formatted value</th>
</tr>
</thead>
<tbody>
<tr>
<td>January 1, 1959</td>
<td>-365</td>
<td>01/01/1959</td>
</tr>
<tr>
<td>January 1, 1960</td>
<td>0</td>
<td>01/01/1960</td>
</tr>
<tr>
<td>January 1, 1961</td>
<td>366</td>
<td>01/01/1961</td>
</tr>
<tr>
<td>January 1, 2010</td>
<td>18263</td>
<td>01/01/2010</td>
</tr>
</tbody>
</table>
You will rarely see unformatted SAS date values in SAS Enterprise Guide. However, because dates are numeric, you can use them in arithmetic expressions to find, for example, the number of days between two dates. Datetime values are included in this data group, and are the number of seconds since January 1, 1960. Date data are represented by a picture of a calendar.

Time data are numeric values equal to the number of seconds since midnight. Time data are represented by a picture of a clock.

Other numeric data, that are not dates, times, or currency, are simply called numeric. They may contain numerals, decimal places (.), plus signs (+), minus signs (-), and E for scientific notation. Numeric data are represented by a blue ball with the numbers 1, 2, and 3 on it.

**Numeric versus character** If the values of a column contain letters or special characters, they must be character data. However, if the values contain only numerals, then they may be either numeric or character. You should base your decision on how you will use the data. Sometimes data that consist solely of numerals make more sense as character data than as numeric. Zip codes, for example, are made up of numerals, but it just doesn’t make sense to add or subtract zip codes. Such values work better as character data.

**Column names** Column names in SAS Enterprise Guide may be up to 32 characters in length, and can begin with or contain any character, including blanks.

**Moving data between SAS Enterprise Guide and Base SAS** Any data created in SAS Enterprise Guide can be used in Base SAS, but the default rules for naming variables are different. Base SAS uses the VALIDVARNAME=V7 SAS system option, while SAS Enterprise Guide uses VALIDVARNAME=ANY. For the sake of compatibility, you may want to follow these rules when naming columns: choose column names that are 32 characters or fewer in length, start with a letter or underscore, and contain only letters, numerals, and underscores.

**Missing data** Sometimes, despite your best efforts, your data may be incomplete. The value of a particular column may be missing for some rows. In those cases, missing character data are represented by blanks, and missing numeric data are represented by a single period (.). In the preceding Data Grid, the value of Price is missing for the tour of Lassen, and its place is marked by a period. The value of Difficulty is missing for the same tour and is left blank.

**Documentation stored in SAS data tables** In addition to your actual data, SAS data tables contain information about the data table, such as its name, the date that you created it, and the version of SAS you used to create it. SAS also stores information about each column in the data table, including its name, type, and length. This information is sometimes called the descriptor portion of the data table, and it makes SAS data tables self-documenting. This information is what you see in the Properties windows for data tables and columns. These Properties windows are described in more detail in the next two sections.
Properties of Data Tables

Someday you may be given a SAS Enterprise Guide project that was created by someone else. If you are unsure what the project does, then it would be a good idea to start by checking the properties of the data tables.

**Opening the Properties window** To display information about a data table, first open it in a Data Grid by double-clicking the data icon in the Project Tree or Process Flow. Then click the Properties icon on the workspace toolbar to open the table Properties window.

You can also right-click a data icon in the Project Tree or Process Flow, and select Properties from the pop-up menu.
**General page**

When the table Properties window opens, it displays the General page. The General page lists basic information about the table: its name, when it was created and last modified, and whether it is a SAS data table or some other type of file.

**Columns page**

If you click Columns in the selection pane on the left, the Columns page will open. Here, SAS Enterprise Guide displays information about each column: its name, type, length, format, informat, and label. You cannot change the properties of columns in the Properties window for a data table. To make changes, use the Properties window for an individual column as described in the next section.
1.9 Properties of Columns

The column Properties window displays properties for an individual column. You can use this window inside a task to change labels and display formats, but those changes will apply only to the results of that task rather than the original data table. However, if you open the column Properties window inside a Data Grid, then any changes you make will be saved with the data table.

Setting the update mode The Data Grid opens in read-only mode. In this mode you cannot edit the data, and you cannot change column properties. To switch to update mode, select Edit &gt; Protect Data from the menu bar. This toggles the data table from read-only to update mode. To return to read-only mode, select Edit &gt; Protect Data again.

Opening the Properties window To open the column Properties window, right-click the header of a column and select Properties from the pop-up menu. In this Data Grid, Properties is being selected for the column Height.

General page The Properties window has several pages. If there is no selection pane on the left, then the data table is in read-only mode and you need to switch to update mode.

The General page displays basic information for the column: its name, label, type, group, and length. You can change any of these properties. In this example, the column name has been changed to **HeightMeters**, and the label to **Height in Meters**. This column is **numeric** and has a length of **8**.
Informs page  Click Informs in the selection pane on the left to open the Informs page. Informs (also called input formats or read-in formats) tell SAS Enterprise Guide how to interpret input data. There are different inforats for character, numeric, date, time, and currency data. In this example, the column uses the default numeric informat, \( w.d \), with a width of 6 and no decimal places. This informat can be written as 6.0. See the next section for a table of commonly used inforats.

In SAS Enterprise Guide 4.2, you can use inforats when you import data files, and when you write SAS programs. However, inforats are not used when you type data values into a Data Grid. Instead, the Data Grid uses the data type and data group that you specify to determine how to interpret any data values you enter.

Formats page  Click Formats in the selection pane on the left to open the Formats page. Formats (also called display formats) tell SAS Enterprise Guide how data should look in Data Grids or reports. There are different formats for character, numeric, date, time, and currency data. In this example, the format \( \text{COMMA}w.d \) with a width of 6 and no decimal places has been selected. This format can be written as COMMA6.0. See section 1.11 for a table of commonly used formats.

Results Here is the Data Grid showing the new name, HeightMeters, and the format with commas.
1.10 Selected Informats

SAS informats (also called input formats or read-in formats) tell SAS Enterprise Guide how to interpret input data. You can specify informats when you import data, in a SAS program, or in a Data Grid. However, in SAS Enterprise Guide 4.2, informats are not used to interpret data that you type into a Data Grid. Here are a few of the many informats available in SAS Enterprise Guide.

<table>
<thead>
<tr>
<th>Informat</th>
<th>Definition</th>
<th>Width range</th>
<th>Default width</th>
</tr>
</thead>
<tbody>
<tr>
<td>Character</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$w.</td>
<td>Reads character data—trims leading blanks</td>
<td>1–32,767</td>
<td>none</td>
</tr>
<tr>
<td>$UPCASEw.</td>
<td>Converts character data to uppercase</td>
<td>1–32,767</td>
<td>8</td>
</tr>
</tbody>
</table>

**Date, Time, and Datetime**

<table>
<thead>
<tr>
<th>Informat</th>
<th>Definition</th>
<th>Width range</th>
<th>Default width</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANYDTDTEw.</td>
<td>Reads dates in any form—when dates are ambiguous, uses the DATESTYLE system option to determine</td>
<td>5–32</td>
<td>9</td>
</tr>
<tr>
<td>DATEw.</td>
<td>Reads dates in the form: <code>ddmonyy</code> or <code>ddmmyyy</code></td>
<td>7–32</td>
<td>7</td>
</tr>
<tr>
<td>DATETIMEw.</td>
<td>Reads datetime values in the form: <code>ddmonyy hh:mm:ss.ss</code></td>
<td>13–40</td>
<td>18</td>
</tr>
<tr>
<td>DDMMYYw.</td>
<td>Reads dates in the form: <code>ddmmyy</code> or <code>ddmmyyyy</code></td>
<td>6–32</td>
<td>6</td>
</tr>
<tr>
<td>JULIANw.</td>
<td>Reads Julian dates in the form: <code>yyddd</code> or <code>yyyyddd</code></td>
<td>5–32</td>
<td>5</td>
</tr>
<tr>
<td>MMDDYYw.</td>
<td>Reads dates in the form: <code>mmddyy</code> or <code>mmddyyyy</code></td>
<td>6–32</td>
<td>6</td>
</tr>
<tr>
<td>TIMEw.</td>
<td>Reads time in the form: <code>hh:mm:ss.ss</code> (hours:minutes:seconds—24-hour clock)</td>
<td>5–32</td>
<td>8</td>
</tr>
</tbody>
</table>

**Numeric**

<table>
<thead>
<tr>
<th>Informat</th>
<th>Definition</th>
<th>Width range</th>
<th>Default width</th>
</tr>
</thead>
<tbody>
<tr>
<td>w.d</td>
<td>Reads standard numeric data</td>
<td>1–32</td>
<td>none</td>
</tr>
<tr>
<td>COMMAw.d</td>
<td>Removes embedded commas and $, converts left parentheses to minus sign</td>
<td>1–32</td>
<td>1</td>
</tr>
<tr>
<td>PERCENTw.</td>
<td>Converts percentages to proportions</td>
<td>1–32</td>
<td>6</td>
</tr>
</tbody>
</table>

---

1. SAS date values are the number of days since January 1, 1960. Time values are the number of seconds past midnight, and datetime values are the number of seconds past midnight on January 1, 1960.
The examples below show input data and resulting data values for each informat. The results shown are unformatted data values. See sections 3.1 and 3.2 for information about assigning display formats.

<table>
<thead>
<tr>
<th>Informat</th>
<th>Input data</th>
<th>Results</th>
<th>Input data</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Character</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$10.</td>
<td>Lassen</td>
<td>Lassen</td>
<td>St. Helens</td>
<td>St. Helens</td>
</tr>
<tr>
<td>$UPCASE10.</td>
<td>Lassen</td>
<td>Lassen</td>
<td>St. Helens</td>
<td>ST. HELENS</td>
</tr>
<tr>
<td><strong>Date, Time, and Datetime</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ANYDTE10.</td>
<td>01jan1961</td>
<td>366</td>
<td>31.01.1961</td>
<td>396</td>
</tr>
<tr>
<td></td>
<td>1961001</td>
<td>366</td>
<td>01/31/61</td>
<td>396</td>
</tr>
<tr>
<td>DATE9.</td>
<td>1jan1961</td>
<td>366</td>
<td>31 jan 61</td>
<td>396</td>
</tr>
<tr>
<td>DATETIME14.</td>
<td>1jan1960</td>
<td>37800</td>
<td>1jan1961</td>
<td>31660200</td>
</tr>
<tr>
<td></td>
<td>10:30</td>
<td></td>
<td>10:30:15</td>
<td>37815</td>
</tr>
<tr>
<td>DDMMYY10.</td>
<td>01.01.1961</td>
<td>366</td>
<td>31/01/61</td>
<td>396</td>
</tr>
<tr>
<td>JULIAN7.</td>
<td>1961001</td>
<td>366</td>
<td>61031</td>
<td>396</td>
</tr>
<tr>
<td>MMDDYY10.</td>
<td>01-01-1961</td>
<td>366</td>
<td>01/31/61</td>
<td>396</td>
</tr>
<tr>
<td>TIME8.</td>
<td>10:30</td>
<td>37800</td>
<td>10:30:15</td>
<td>37815</td>
</tr>
<tr>
<td><strong>Numeric</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5.1</td>
<td>1234</td>
<td>123.4</td>
<td>-12.3</td>
<td>-12.3</td>
</tr>
<tr>
<td>COMMA10.0</td>
<td>$1,000,001</td>
<td>10000001</td>
<td>(1,234)</td>
<td>-1234</td>
</tr>
<tr>
<td>PERCENT5.</td>
<td>5%</td>
<td>0.05</td>
<td>(20%)</td>
<td>-0.2</td>
</tr>
</tbody>
</table>
## 1.11 Selected Standard Formats

SAS formats (also called display formats) tell SAS Enterprise Guide how to display or print data. You can apply formats in a column Properties window in a Data Grid, a task, or a query. Here are a few of the many formats available in SAS Enterprise Guide.

<table>
<thead>
<tr>
<th>Format</th>
<th>Definition</th>
<th>Width range</th>
<th>Default width</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Character</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$UPCASEw.</td>
<td>Converts character data to uppercase</td>
<td>1–32767</td>
<td>Length of variable or 8</td>
</tr>
<tr>
<td>$w.</td>
<td>Writes standard character data—default for character data</td>
<td>1–32767</td>
<td>Length of variable or 1</td>
</tr>
<tr>
<td><strong>Date, Time, and Datetime</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DATEw.</td>
<td>Writes SAS date values in form <em>ddmonyy</em> or <em>ddmonyyyy</em></td>
<td>5–11</td>
<td>7</td>
</tr>
<tr>
<td>DATETIMEw.d</td>
<td>Writes SAS datetime values in form <em>ddmmnnyyhh:mm:ss.ss</em></td>
<td>7–40</td>
<td>16</td>
</tr>
<tr>
<td>DTDATEw.</td>
<td>Writes SAS datetime values in form <em>ddmony</em> or <em>ddmonyyyy</em></td>
<td>5–9</td>
<td>7</td>
</tr>
<tr>
<td>EURDFDDw.</td>
<td>Writes SAS date values in form <em>dd.mm.yy</em> or <em>dd.mm.yyyy</em></td>
<td>2–10</td>
<td>8</td>
</tr>
<tr>
<td>JULIANw.</td>
<td>Writes SAS date values in Julian date form <em>yyddd</em> or <em>yyyyddd</em></td>
<td>5–7</td>
<td>5</td>
</tr>
<tr>
<td>MMDDYYw.</td>
<td>Writes SAS date values in form <em>mm/dd/yy</em> or <em>mm/dd/yyyy</em>—default for dates</td>
<td>2–10</td>
<td>8</td>
</tr>
<tr>
<td>TIMEw.d</td>
<td>Writes SAS time values in form <em>hh:mm:ss.ss</em>—default for times</td>
<td>2–20</td>
<td>8</td>
</tr>
<tr>
<td>WEEKDATEw.</td>
<td>Writes SAS date values in form <em>day-of-week, month-name dd, yy</em> or <em>yy</em></td>
<td>3–37</td>
<td>29</td>
</tr>
<tr>
<td>WORDDATEw.</td>
<td>Writes SAS date values in form <em>month-name dd, yyyy</em></td>
<td>3–32</td>
<td>18</td>
</tr>
<tr>
<td><strong>Numeric</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BESTw.</td>
<td>SAS System chooses best format—default format for numeric data</td>
<td>1–32</td>
<td>12</td>
</tr>
<tr>
<td>COMMAw.d</td>
<td>Writes numbers with commas</td>
<td>2–32</td>
<td>6</td>
</tr>
<tr>
<td>DOLLARw.d</td>
<td>Writes numbers with a leading $ and commas separating every three digits—default for currency</td>
<td>2–32</td>
<td>6</td>
</tr>
<tr>
<td>Ew.</td>
<td>Writes numbers in scientific notation</td>
<td>7–32</td>
<td>12</td>
</tr>
<tr>
<td>EUROXw.d</td>
<td>Writes numbers with a leading € and periods separating every three digits</td>
<td>2–32</td>
<td>6</td>
</tr>
<tr>
<td>PERCENTw.d</td>
<td>Writes numeric data as percentages</td>
<td>4–32</td>
<td>6</td>
</tr>
<tr>
<td>wd</td>
<td>Writes standard numeric data</td>
<td>1–32</td>
<td>none</td>
</tr>
</tbody>
</table>

---

1. SAS date values are the number of days since January 1, 1960. Time values are the number of seconds past midnight, and datetime values are the number of seconds past midnight on January 1, 1960.
The examples below show unformatted data values and formatted results for each display format.

<table>
<thead>
<tr>
<th>Format</th>
<th>Data value</th>
<th>Results</th>
<th>Data value</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Character</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$UPCASE10.</td>
<td>Lassen</td>
<td>LASSEN</td>
<td>St. Helens</td>
<td>ST. HELENS</td>
</tr>
<tr>
<td>$6.</td>
<td>Lassen</td>
<td>Lassen</td>
<td>St. Helens</td>
<td>St. He</td>
</tr>
<tr>
<td><strong>Date, Time, and Datetime</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DATE9.</td>
<td>366</td>
<td>01JAN1961</td>
<td>396</td>
<td>31JAN1961</td>
</tr>
<tr>
<td>DATETIME16.</td>
<td>37800</td>
<td>01JAN60:10:30</td>
<td>2629800</td>
<td>31JAN60:10:30</td>
</tr>
<tr>
<td>DTDATE9.</td>
<td>37800</td>
<td>01JAN1960</td>
<td>2629800</td>
<td>31JAN1960</td>
</tr>
<tr>
<td>EURDFDD10.</td>
<td>366</td>
<td>01.01.1961</td>
<td>396</td>
<td>31.01.1961</td>
</tr>
<tr>
<td>JULIAN7.</td>
<td>366</td>
<td>1961001</td>
<td>396</td>
<td>1961031</td>
</tr>
<tr>
<td>MMDDYY10.</td>
<td>366</td>
<td>01/01/1961</td>
<td>396</td>
<td>01/31/1961</td>
</tr>
<tr>
<td>TIME8.</td>
<td>37800</td>
<td>10:30:00</td>
<td>37815</td>
<td>10:30:15</td>
</tr>
<tr>
<td>WEEKDATE15.</td>
<td>366</td>
<td>Sun, Jan 1, 61</td>
<td>396</td>
<td>Tue, Jan 31, 61</td>
</tr>
<tr>
<td>WORDDATE12.</td>
<td>366</td>
<td>Jan 1, 1961</td>
<td>396</td>
<td>Jan 31, 1961</td>
</tr>
<tr>
<td><strong>Numeric</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BEST10.</td>
<td>1000001</td>
<td>1000001</td>
<td>-12.34</td>
<td>-12.34</td>
</tr>
<tr>
<td>BEST6.</td>
<td>1000001</td>
<td>186</td>
<td>100001</td>
<td>100001</td>
</tr>
<tr>
<td>COMMA12.2</td>
<td>1000001</td>
<td>1,000,001.00</td>
<td>-12.34</td>
<td>-12.34</td>
</tr>
<tr>
<td>DOLLAR13.2</td>
<td>1000001</td>
<td>$1,000,001.00</td>
<td>-12.34</td>
<td>$-12.34</td>
</tr>
<tr>
<td>E10.</td>
<td>1000001</td>
<td>1.000E+06</td>
<td>-12.34</td>
<td>-1.234E+01</td>
</tr>
<tr>
<td>EUROX13.2</td>
<td>1000001</td>
<td>€1.000.001,00</td>
<td>-12.34</td>
<td>€-12,34</td>
</tr>
<tr>
<td>PERCENT9.2</td>
<td>0.05</td>
<td>5.00%</td>
<td>-1.20</td>
<td>(120.00%)</td>
</tr>
<tr>
<td>10.2</td>
<td>1000001</td>
<td>1000001.00</td>
<td>-12.34</td>
<td>-12.34</td>
</tr>
</tbody>
</table>
1.12 Scheduling Projects to Run at Specific Times

Sometimes you may want to create a project now, but run it later. For example, if you have data files that are updated on a regular basis, you might want to automatically rerun the project once a week using the new data. Or, if your data files are very large, you might want to run your projects at night so that SAS Enterprise Guide is not using valuable resources during work hours.

**Opening the Schedule window** You can schedule a complete project or just a process flow. To schedule a project, select **File ➤ Schedule** from the menu bar. To schedule a process flow, right-click the name of the process flow in the Project Tree and select **Schedule process-flow-name** from the pop-up menu. This opens the Microsoft Windows Task Scheduler with the Task tab on top. When you schedule a project, SAS Enterprise Guide creates a script that is saved in a file on your computer. The name and path of this script is displayed in the **Run** box. The **Start in** box displays the folder in which the script will run. Your computer and user name are displayed in the **Run as** box.

If you will not be logged on at the time the project runs, then make sure the box next to **Run only if logged on** is unchecked, and click the **Set password** button to open the Set Password window. Enter the password for your user name (the same password you use when you log on to your computer), and click **OK**.

**Setting the run frequency** To tell SAS Enterprise Guide when to run the project, click the **Schedule** tab. Click the **New** button. Then select the frequency to run the project from the drop-down list under **Schedule Task**. You can schedule your project to run just once at a specified time as shown here, or you can schedule your project to run on a regular basis.
Chapter 1: SAS Enterprise Guide Basics

Setting the date and time  To set the time the project will start running, click the up and down arrows on the Start time box, or simply click the time and type a new value. To choose a date other than today, click the down-arrow in the Run on box and select a date from the pull-down calendar.

Other settings  If you click the Settings tab, you will see other options, including the maximum length of time a project will be allowed to run, and whether it will run if your computer has gone into sleep mode.

When you are satisfied with all the settings, click OK to schedule the project.

Running the project  The project will not run if it is open or if the computer is turned off at the time the project is scheduled to run. However, if you have a different project open, the scheduled project will still run.

Viewing the results  To see the results of your scheduled run, open the project after it has completed running. If you are not sure whether a project ran, you can confirm this by opening the Properties window for that project. To open the Properties window for a project, select File ➤ Project Properties from the menu bar. The Last modified field shows the date and time that the project last ran.
1.13 Editing SAS Programs Generated by a Task

If you are a SAS programmer, you may want to make a few changes to the programs generated by SAS Enterprise Guide. There is more than one way to do this. You can insert your own SAS code into the program associated with a task, or you can save the code generated by a task in a separate file which you can then edit and run.

Previewing code generated by a task

Many task windows have a Preview code button in the lower-left corner. If you click this button, SAS Enterprise Guide will open a Code Preview window displaying the code that SAS Enterprise Guide has written for that task.

Inserting code in a task

Here is a Code Preview window for a List Data task. You can see that it uses PROC PRINT. If you want to add code to the task, click the Insert Code button. This opens a User Code window. You cannot edit the existing code generated by a task, but the User Code window allows you to add code at specific points in the program.
In the User Code window, double-click `<double-click to insert code>` at the point where you wish to add your own custom code. An Enter User Code window will open. Type the custom code you wish to add. When you are done, click OK. Your new code will appear in the User Code window. Click OK in the User Code window. When you run the task, SAS Enterprise Guide will run the code you inserted along with the code generated by the task.

**Editing code generated by a task** If you want to be able to edit the entire program generated by a task, or code from tasks that do not have a Preview code button, you can make a copy of the program, and then edit it. To do this, run the task, and then right-click the task icon in the Project Tree or Process Flow, and select **Add As Code Template**. SAS Enterprise Guide will open a Program window containing the code generated by the task.

You can edit this code in any way you wish. Because this code is a copy of the code generated by the task, any changes you make here will not affect the task, nor will any changes you make to the task be reflected in this code.

When you have made all the changes you wish and are ready to run the program, click **Run** on the workspace toolbar for the Program window. Your program will run on the server that has been set as your default. To choose a different server, click **Select Server**. If you decide you want to stop a program while it’s running, click the Stop button on the workspace toolbar for the Program window. You can also use the Program menu on the menu bar to control execution of your program.

Programs created in this way are embedded in your project, and are not saved as separate files. For more information on embedding programs, see the next section.
1.14 Writing and Running Custom SAS Programs

You can accomplish a lot using tasks in SAS Enterprise Guide, but sometimes you may need to do something for which there is no predefined task. At those times, you can run a SAS program that was written outside SAS Enterprise Guide, or you can write a new one.

Writing a new SAS program
To create a new SAS program, open an empty Program window by selecting File ► New ► Program from the menu bar. A Program window will open in the workspace. The program editor in SAS Enterprise Guide is syntax-sensitive, which means that SAS keywords are displayed in blue, comments are green, quoted strings are magenta, and so forth.

Opening an existing SAS program
If you have existing SAS programs that you want to include in your project, you can open them by selecting File ► Open ► Program from the menu bar. Navigate to the existing SAS program and click Open. This opens a Program window in the workspace, where you can edit the program.

Saving a program in a file
Any new programs you write are automatically embedded in your project. This means that the program’s code does not exist in a file outside of the project. To save a SAS program outside its project, click Save on the workspace toolbar for the Program window, or right-click the program icon in the Project Tree or Process Flow and select Save program-name As from the pop-up menu. You can also save a program from the Properties for program-name window. To view the properties of a program, click Properties on the workspace toolbar for the Program window, or right-click the program icon in the Project Tree or Process Flow and select Properties from the pop-up menu. Then in the General page, click Save As. If you save the
program in a file, then it is not embedded, and any changes you make to it in SAS Enterprise Guide will be saved in the file rather than as part of your project. The icon for a program saved in a file includes a little arrow indicating that the project contains a shortcut to the program rather than the actual program.

**Embedding a program in a project** When you open a SAS program that has been saved in a separate file, it is not automatically embedded in your project. If you want to embed the program in your project, then open the Properties window for the program and click **Embed**. After you embed the program, any changes you make to it in SAS Enterprise Guide will be saved as part of your project rather than in the separate file. The icon for embedded code looks like this.

**Running your program** When you are ready to run your program, click **Run** on the workspace toolbar for the Program window. Your program will run on the server that has been set as your default. To choose a different server, click **Select Server**. If you decide you want to stop a program while it’s running, click the **Stop** button on the workspace toolbar for the Program window. You can also use the Program menu on the main menu bar to control your program.
1.15 Viewing Program and Project Logs

A SAS log is a record of what SAS did. Just about everything you do in SAS Enterprise Guide generates a SAS log. Logs contain the actual code that SAS ran, plus any error messages, warnings, or notes.

**Different types of logs** A program log is the log that is generated when you run a SAS program. Tasks generate logs too, but when you run tasks, you have little need to view the task log. That is because tasks rarely produce errors or warnings. Every time you rerun a program or task, the old log is replaced with a new one.

The Project Log, on the other hand, is a single cumulative record of everything that has been run in a particular project. By default, the Project Log is turned off. Once you turn the Project Log on, nothing disappears from it unless you clear the log.

**Viewing a program log** After a program runs, the results are displayed in the workspace. To open the program log, click the tab labeled Log. Here is a portion of the program log generated by the SAS program in the preceding section.

One of the first things you will notice when you look at a log is that it contains more lines of SAS code than were in your original program. That is because SAS Enterprise Guide adds housekeeping statements to the beginning and end of your program to make sure that it runs properly when it is passed to your SAS server.

If your program contains any errors, its icon will include a red X. Programs that contain warnings (but no errors) have icons with yellow triangles. Even if there are no errors or warnings, it is a good habit to check the program log when you write your own SAS programs. Just because a program runs without errors or warnings does not mean that it produced the correct results.
Viewing the Project Log  To turn on the Project Log, first open it by clicking Project Log on the workspace toolbar for the Process Flow or selecting View ➤ Project Log from the menu bar. Then on the workspace toolbar for the Project Log, click Turn On. Once the Project Log is turned on, it will keep a continuous history of everything that runs in that project.

The Project Log includes the date and time when each action occurred. Click the plus sign (+) to expand a section, or the minus sign (-) to collapse it. You can also split the Project Log into two pieces by clicking and dragging the top border (the line just below the workspace toolbar) of the Project Log window.

To clear the Project Log, click Clear Log on the workspace toolbar for the Project Log. To turn it off, click Turn Off.
1.16 Using the Options Window

The Options window allows you to change many default behaviors in SAS Enterprise Guide. To open the Options window, select Tools ▶ Options from the menu bar.

**Changing the way data are handled** To see options for data, click Data General in the selection pane on the left. If you have large data tables, columns might be easier to find if they are arranged in alphabetical order. To list columns alphabetically in task windows, check the box in front of **Display columns in alphabetical order**. By default, the Data Grid uses column names, not labels, for column headers. To change this, check the box in front of **Use labels for column names**. If you have large data tables on remote servers, you may be able to improve performance by unchecking **Automatically open data when added to project**.

**Changing the default titles and footnotes** To change the default titles and footnotes, click Tasks General in the selection pane on the left. In this page, you can specify new default titles and footnotes, or set them to blank. Some tasks include in the results the name of the SAS procedure used by that task. In these results you will see titles like “The FREQ Procedure” or “The ANOVA Procedure.” You can eliminate these titles by unchecking the box labeled **Include SAS procedure titles in results**.
Changing the default result format and style  To change the default format for results, click Results General in the selection pane on the left to open the Results General page (not shown). Then check all the formats you want to use: SAS Report, HTML, PDF, RTF, or text output. To change the default style for results, click the name of the format (such as PDF) in the selection pane on the left to open a page for that format (not shown), and then select a style. See Tutorial B or Chapter 11 for more about changing result formats and styles.

Running code automatically  If you have SAS code that you would like to run automatically, click SAS Programs in the selection pane on the left to open the SAS Programs page (not shown). Select an option under the heading Additional SAS code. Then click Edit, type your code in the Edit window, and click Save. The option Submit SAS code when server is connected is particularly useful for submitting LIBNAME statements. You can also click Custom Code in the selection pane on the left, and specify code to be run before or after tasks.

Restoring the window layout  To restore windows to their default layout, click General in the selection pane on the left to open the General page (not shown). Then click the Restore Window Layout button.

Saving and resetting options  To close the Options window and save the changes you have made, click OK. Once you set options, they stay in effect for future SAS Enterprise Guide sessions. If at a later time, you decide you want to restore everything in the Options window to the default settings, simply click the Reset All button in the lower left corner.
Index

A
Access files 169, 186-187
active data table 142
addition in expression editor 178-179, 206-207
advanced expression 81-85, 179, 206-207
advanced filters 236-237
ALL universal class variable 271
analysis of variance 294-295
AND logic in filters 99, 234-235
ANOVA procedure (One-Way ANOVA task) 294-295
ANYDTDTEw. informat 152-153
Append Table task 242-243
appending
   data tables 240, 242-243
   rows in Data Grid 177
arguments in functions 208-209
arranging items in a process flow 140
ascending sort order 101, 227-228, 231
ASCII sort order 229
Assign Project Library task 172-173
assignment of values in a query 218-219
associations, measures of 288-289
Auto Arrange option for process flows 140
Auto Hide 134
automatically running SAS code 165
axes 308-309

B
Background Color option for process flows 140
Bar Chart task 298-299
batch programs, running 156-157
BESTw. format 154-155
box area in Summary Tables 275

C
character data
   definition 12, 146-147
   formats 154-155
   functions 210-211
   informats 152-153
   labels for 194-195
   user-defined formats 194-195
charts
   bar 298-299
   pie 300-301
   result format 313
chi-square test 288-289
Cochran-Mantel-Haenszel statistics 288-289
code files, SAS
   code template 159
   editing 158-159
   embedding in project 161
   inserting code in task 158-159
   item in project 139
log 162
options 165
prompts in 334-335
properties 160-161, 334-335
running 158-161
server for 159
stopping 161
viewing 137, 158-159
writing 160-161
collating sequence 229
colors
   in styles 314-317
   in Summary Tables 274-281
columns
   attributes when importing 181, 183, 185
   computing in Data Grid 178-179
   computing in query 80-86, 206-209
   definition 24, 146
   deleting from Data Grid 16, 177
   deleting in a query 90, 204
   inserting in Data Grid 176-179
   labels 51-56, 150-151
   list of 149
   names 8-9, 147
   order of 90-91, 164-165
   properties 8-17, 87-89, 150-151, 174-177, 190-193, 198-199, 205, 217, 266-267
   recoding 81, 218-219
   selecting in a query 78-79, 204-205
   sorting data values 226-231
combining data tables 109-117, 123-128, 240-247
   filters 234-235
   results 318-321
comma-delimited files
   exporting 186-187
   reading 168-169, 182-183
COMMAw.d
format 154-155
informat 152-153
compound filters 234-235
computing columns
  in Data Grid 178-179
  in query 80-86, 206-209, 212-217
concatenating data tables 240, 242-243
conditional selection of rows 92-99, 224-227, 232-237, 328-329
conditions for projects 338-341
confidence limits 284-287, 293
contents of data tables 148-149
copying
  data tables 176
  items in process flows 141
Correlations task (CORR procedure) 290-291
COUNT statistic in query 212-217
counts
  in Summary Tables 270-271
  one-way 258-259
  two-way 260-261
Create Format task 57-62, 194-197
cross-tabulations
  in Summary Tables 270-271
  in Table Analysis 260-261, 288-289
CSV files
  exporting 186-187
  reading 168-169, 182-183
currency data
  definition 13, 146
  formats 154-155
  informats 152-153
D
data engines, SAS 173
data files
  exporting 186-187
  options 164-165
  reading 168-171, 180-185
  types 168-169
Data Grid
  appending rows 177
  computing columns 178-179
  creating 5-21, 174-175
  definition 146
  deleting columns 16, 177
  deleting rows 20, 177
  editing 19, 176-177
  formats, applying 190-191
  inserting columns 176-179
  inserting rows 177
data sets, definition 6, 146
data tables
  active 142
  appending 240, 242-243
  compared to data sets 6
  copying 176
  creating summary 264-265
  creating with a query 220-221
  definition 6, 146
  editing 19, 150, 176-177
  exporting 186-187
  filtering 92-99, 118-123, 224-227, 232-237, 328-329
  joining 109-117, 123-128, 240-241, 244-247
  locations 170-171
  merging 109-117, 123-128, 240-241, 244-247
  names 6-7, 174
  new 5-21, 174-175
  opening 29, 40-43, 75-76, 170
  opening large 164-165
  options 164-165
  properties 148-149
  sorting 100-102, 226-231
  subsetting 92-99, 118-123, 224-227, 232-237, 328-329
data values
  appearance of 51-56, 190-193
  groups 13, 146-147, 150-151
  labels for 57-62, 194-199
  length of 9, 12
  missing 18, 147
  options 164-165
  recoding in a query 218-219
  sorting 100-102, 226-231
  summarizing 212-217, 264-265
  types 9-14, 146-147, 150-151
data views 220-221
date data
  computations with 206-207
  definition 146-147
  formats 154-155, 190-193
  functions 210-211
  informats 152-153
DATEPART function 210-211
datetime data
  definition 146-147
  functions 210-211
DATETIMEw.d
  format 154-155
  informat 152-153
DATEw.
  format 154-155
  informat 152-153
DAY function 208-211
DB2 169
dBASE files 169, 186-187
DDMMYYw. informat 152-153
delimiting
  columns from Data Grid 16, 177
  columns in a query 90, 204
  duplicate rows 229
  items from a project 139
  process flows 140
  rows from Data Grid 20, 177
  task templates 144
delimited files
  exporting 186-187
  reading 182-183
  types 168-169
descending sort order 101, 227-228, 231
descriptive statistics
  in Distribution Analysis 284-285
  in query 212-217
  in Summary Statistics 262-263, 286-287
  in Summary Tables 272-273
display formats
  applying standard 151
  applying user-defined 63-65, 198-199
  creating user-defined 57-62, 194-197
  grouping with 266-267
  in Data Grid 176-177, 190-191
  in query 204-205, 217
  in tasks 51-56, 192-193
  names 58
  table of 154-155
Distribution Analysis task 284-285
division in expression editor 178-179, 206-207
docked windows 135
document windows 135
documenting
  data tables 147-149
  projects 34-35
DOLLARw.d format 154-155
DTDATEw. format 154-155
duplicate rows, deleting 229

E
EBCDIC sort order 229
Edit button in task window 142, 224-225
editing
  data tables 19, 150, 176-177
  reports 318-321
  SAS programs 158-159
  styles 316-317
EGTASK library 7, 170
embedding program in project 161
engines, SAS data 173
errors 162
EURDFDDw. format 154-155
EUROXw.d format 154-155
Ew. format 154-155
Excel files 169
  exporting 186-187
  importing 180-181
Exchange files 169
Export wizard 186-187
exporting
  data 186-187
  items from a project 139
  results 322-323
  task templates 145
expression editor
  in a filter 236-237
  in a query 82-86, 206-209
  in Data Grid 179

F
filename of data table 149
files, data
  exporting 186-187
  options 164-165
  reading 168-171, 180-185
  types 168-169
filtering data
  compound filters 234-235
  dynamic 328-329
Filter and Sort task 226-227
  in a query 92-99, 118-123, 232-233
  in a task 224-225
  summarized data 232-233
  using expressions 236-237
Fisher’s Exact test 288-289
fixed columns raw data files 184-185
fonts
  in graphs 308
  in reports 320-321
  in styles 316-317
  in Summary Tables 274-281
footers, adding to reports 320-321
footnotes
  changing 46-50, 252-253
  changing default 164-165
  default 48
FORMAT procedure (Create Format task) 57-62, 194-197
formats
  applying standard 151
  applying user-defined 63-65, 198-199
  creating user-defined 57-62, 194-197
  grouping with 266-267
  in Data Grid 176-177, 190-191
  in query 204-205, 217
  in tasks 51-56, 192-193
  names 58
  table of 154-155
FREQ procedure
  (One-Way Frequencies task) 22-28, 258-259
  (Table Analysis task) 260-261, 288-289
frequencies
  cross-tabulations 260-261
  in Summary Tables 270-271
  one-way 22-28, 258-259
  statistical analysis 288-289
full outer join 241, 246-247
functions
  definition 82
  in Data Grid 179
  in filter conditions 236-237
  in query 208-209
  table of 210-211
G
GCHART procedure
  (Bar Chart task) 298-299
  (Pie Chart task) 300-301
GPLOT procedure
  (Line Plot task) 302-305
  (Scatter Plot task) 28-32, 306-307
graphs
  bar charts 298-299
  controlling axes 308-309
  line plots 302-305
pie charts 300-301
regression plot 293
result format 313
scatter plots 28-32, 306-307
Grid option for process flows 140
grouping data
  cross-tabulations 260-261
  frequency reports 258-259
  in query 212-217
  list reports 254-257
  output data table 264-265
  recoding values 218-219
  summary reports 262-263, 270-273
  with user-defined formats 194-197, 266-267
H
headings
  adding to reports 320-321
  changing in a task 51-56
  in Summary Tables 274-277
help, SAS Technical Support x
hiding windows 135
histograms 298-299
Hoeffding correlation coefficients 290-291
HTML data files 169, 186-187
HTML results 68-69, 312-313
styles for 314-317
I
images
  adding to reports 320-321
  adding to style 316-317
Import Data wizard 180-185
importing data 171
  delimited raw data 182-183
  Excel files 180-181
  fixed columns raw data 184-185
  JMP files 169
  SPSS files 169
  Stata files 169
  types of data 168-169
importing, task templates 145
informats
  in Data Grid 150-151, 176-177
  table of 152-153
inner join 241, 246-247
inserting
  columns in Data Grid 176-179
  rows in Data Grid 177
  SAS code in a task 158-159
JMP files, importing 169
joining data tables 109-117, 240-241, 244-245
    join types 240-241
    modifying a join 123-128, 246-247
JUNIAN
    format 154-155
    informat 152-153

Kendall correlation coefficients 290-291
kurtosis 284-285

labels
    axes 308-309
    columns 51-56, 150-151
    data values 194-199
    headings in Summary Tables 274-275
Layout option for process flows 140
left join 241, 246-247
LENGTH function 210-211
length of data values 9, 12, 150-151
LIBNAME statement 165, 171
libraries
    for data 7, 41-42, 170-174
    for formats 57, 194
    temporary data 7, 170-171
libref 170, 172
Line Plot task 302-305
Linear Regression task 292-293
linking items in process flows 141
List Data task 43-56, 63-65, 250-251, 254-257
listing files (text output) 312-313
log files, SAS 162-163
LOG function 210-211
LOG10 function 210-211
Lotus 1-2-3 files 169, 186-187

macro variables
    creating for data values 326-327
    creating for text values 336-337
    creating for variable names 330-331
    using in filters 328-329
    using in programs 334-335
    using in project conditions 338-341
    using in tasks 332-333
many-to-many merge 240

mathematical
    functions 210-211
    operators 178-179, 206-207
MAX
    function 210-211
    in Distribution Analysis 284-285
    in query 212-217
    in Summary Statistics 263, 286-287
    in Summary Tables 272-273
maximizing workspace 137
MDY function 210-211
MEAN
    function 210-211
    in Distribution Analysis 284-285
    in query 212-217
    in Summary Statistics 263, 286-287
    in Summary Tables 272-273
MEANS procedure (Summary Statistics task) 262-265, 286-287
means, comparison of 294-295
median
    in Distribution Analysis 284-285
    in Summary Statistics 286-287
    in Summary Tables 272-273
menus 135
    compared to Task List window 22
merging data tables 109-117, 123-128, 240-241, 244-247
MIN
    function 210-211
    in Distribution Analysis 284-285
    in query 212-217
    in Summary Statistics 263, 286-287
    in Summary Tables 272-273
missing data values 18, 147
    number of 212-217, 263, 272-273, 286-287
MMDDYYW.
    format 154-155
    informat 152-153
mode statistic 284-285
modifying
    joins 123-128, 246-247
    tasks 25-26, 46, 143
moments 284-285
MONTH function 210-211
moving items in process flows 140
multiple comparison 294-295
multiplication in expression editor 178-179, 206-207
My Styles, creating 316-317
N
N statistic
   in Distribution Analysis 284-285
   in query (COUNT) 212-217
   in Summary Statistics 263, 286-287
   in Summary Tables 270-273
names
   column 8-9, 147, 150-151, 181, 183, 185
   data tables 6-7, 174
   format 58
   library 172
   prompts 326, 329, 330
New Computed Column wizard 81-85, 206-209, 218-219
New Data wizard 5-17, 174-175
New Filter wizard 93-98, 119-121, 232-237
NMISS statistic
   in query 212-217
   in Summary Tables 272-273
normality, tests for 284-285
notes 34-35, 139
numeric data
   definition 12, 146-147
   formats 154-155
   groups 13, 146-147
   informats 152-153
   labels for 196-197
   user-defined formats 196-197

O
observations, definition 146
ODBC 169
one-to-many merge 240
one-to-one merge 240
One-Way ANOVA task 294-295
One-Way Frequencies task 22-28, 258-259
opening files 168-171
   delimited files 182-183
   Excel files 180-181
   fixed columns raw data 184-185
   SAS data tables 40-43, 75-76, 170
opening items in a project 139
opening tasks 22, 25-26, 142
operators
   computing new columns using 178-179, 206-207
   in filter conditions 224-227, 232-237, 328-329
options
   changing default footnote 48
data 164-165
   graph format 313
   query 220-221
   resetting 165
   restore window layout 4, 135, 165
   result format 68-70, 165, 312-313
   result style 69, 165, 314-315
   SAS programs 165
titles 164-165
   VALIDVARNAME= 147
OR logic in filters 99, 234-235
Oracle 169
ordering
   columns in a query 90-91
   columns in task windows 164-165
   rows with a query 100-102, 230-231
   rows with Filter and Sort task 226-227
   rows with Sort Data task 228-229
outer join 241, 246-247
output
   combining 318-321
   data tables 264-265
   graph format 313
   options 164-165
   report format 68-70, 165, 312-313
   report style 165
   saving 322-323
   style for 66-69, 314-317
P
Paradox files 169, 186-187
parameters 326
PDF
   results 68-70, 312-313
   styles for 314-315
Pearson correlation coefficients 290-291
Pearson tests of association 288-289
percentages
   in One-Way Frequencies 258-259
   in Summary Tables 272-273
   in Table Analysis 260-261
percentiles
   in Distribution Analysis 284-285
   in Summary Statistics 286-287
   in Summary Tables 272-273
   PERCENTw.d
   format 154-155
   informat 152-153
performance, improving 164-165
Pie Chart task 300-301
pivot table 270-273
plots
controlling axes 308-309
line 302-305
regression 293
result format 313
scatter 28-32, 306-307
previewing
query results 78
SAS code 158
PRINT procedure (List Data task) 43-56, 63-65, 250-251, 254-257
printing
process flows 141
reports 321
procedure titles in results 164-165, 321
procedures
ANOVA (One-Way ANOVA task) 294-295
CORR (Correlations task) 290-291
FORMAT (Create Format task) 57-62, 194-197
FREQ (One-Way Frequencies task) 22-28, 258-259
FREQ (Table Analysis task) 260-261, 288-289
GCHART (Bar Chart task) 298-299
GCHART (Pie Chart task) 300-301
GPLOT (Line Plot task) 302-305
GPLOT (Scatter Plot task) 28-32, 306-307
MEANS (Summary Statistics task) 262-265, 286-287
PRINT (List Data task) 43-56, 63-65, 250-251, 254-257
REG (Linear Regression task) 292-293
SORT 228-229
SQL (Append Table task) 242-243
SQL (Query Builder) 202-221, 230-237, 240-241, 244-247, 328-329
SUMMARY (Summary Statistics task) 262-265, 286-287
TABULATE (Summary Tables task) 270-281
UNIVARIATE (Distribution Analysis task) 284-285
process flows 4, 32-33, 134-135, 138-141
programs, SAS
code template 159
editing 158-159
embedding in project 161
inserting code in task 158-159
item in project 139
log 162
options 165
prompts in 334-335
properties 160-161, 334-335
running 158-161
server for 159
stopping 161
viewing 137, 158-159
writing 160-161
Project Log 162-163
Project Tree 4, 33, 134, 138-139
projects
conditions 338-341
definition 3, 138-139
documenting 34-35
saving 36-37, 139
scheduling 156-157
Prompt Manager window 135-136, 326-327, 330-331, 336-337
prompts
creating for data values 326-327
creating for text values 336-337
creating for variable names 330-331
using in filters 328-329
using in programs 334-335
using in project conditions 338-341
using in tasks 332-333
properties
of columns 8-17, 87-89, 150-151, 174-175, 190-193, 198-199, 205, 217, 266-267
of data tables 148-149
of items in project 139
of joins 124-126, 246-247
of projects 157
of SAS programs 160-161, 334-335
of tasks 66-69, 313
protecting data 150
Q
QTR function 210-211
quantiles
in Distribution Analysis 284-285
in Summary Statistics 286-287
in Summary Tables 272-273
queries
computing new columns 80-86, 206-209
filtering data 92-99, 118-123, 232-237, 328-329
joining data tables 109-117, 123-128, 240-241, 244-247
naming 203
options 220-221
queries (continued)
  order of columns 90-91, 204
  prompts in 328-329
  recoding values 218-219
  result name 203
  result type 102, 220-221
  selecting columns 78-79, 204-205
  sorting rows 100-102, 230-231
  summary groups 214-217

R
  range statistic
    in Distribution Analysis 284-285
    in query 212-217
    in Summary Statistics 263, 286-287
    in Summary Tables 272-273
  raw data files
    delimited 182-183
    fixed columns 184-185
    types 168
  read-in formats
    in Data Grid 150-151, 176-177
    table of 152-153
  read-only mode 150, 176
  reading
    delimited raw data 182-183
    Excel files 180-181
    fixed columns raw data 184-185
    SAS data tables 40-43, 75-76, 170
    types of data 168-169
  recoding values in a query 81, 218-219
  refreshing
    query preview 86
    Server List window 173
    tasks 143
  REG procedure (Linear Regression task) 292-293
  regression, linear 292-293
  renaming
    columns 150
    columns from Excel 181
    columns from raw data 183, 185
    items in a project 139
    process flows 140
    queries 202
  reopening tasks 25-26, 46, 143
  replacing values in a query 218-219
  reports
    creating custom 318-321
    creating with a query 220-221
    cross-tabulations 260-261
  footnotes 164-165, 252-253
  frequency 22-28, 258-259
  grouping with formats 266-267
  list 43-56, 250-251
  list by group 254-255
  list with totals 256-257
  SAS report result format 318-321
  summary statistics 262-263
  summary tables 270-281
  titles 164-165, 252-253
  titles of procedures in 164-165, 321
  resetting options 165
  Resources pane 4-5, 134-136, 170-171, 326-327, 330-331, 336-337
  restoring windows 4, 135, 165
  results 138
    combining 318-321
    footnotes 164-165, 252-253
    format 68-70, 165, 312-313
    graph format 313
    queries 102, 202-203, 220-221
    saving 322-323
    style of 66-69, 165, 314-317
    titles 164-165, 252-253
    titles of procedures in 164-165, 321
    viewing 137
  right join 241, 246-247
  row number in list reports 51, 251, 255
  rows
    appending in Data Grid 177
    definition 146
    deleting duplicates 229
    deleting from Data Grid 20, 177
    grouping in a report 254-255
    inserting in Data Grid 177
    selecting 92-99, 118-123, 224-227, 232-233, 236-237
  RTF
    results 68-69, 312-313
    styles for 314-315
  running
    projects 156-157
    projects with conditions 340-341
    SAS programs 158-161, 165
    tasks 143

S
  SAS data engines 173
  SAS Folders window 135-136
  SAS listing (text) output 312-313
SAS log, viewing 162-163
SAS names 8, 147, 172, 174, 181, 183, 185
SAS Report result format 45, 68-69, 312-313, 318-321
styles for 314-317
SAS/ACCESS 169
Excel files 181
SASUSER library 7, 41-42, 170
saving
data 186-187
items in a project 139
projects 36-37, 139
results 220-221, 322-323
SAS programs 160-161
Scatter Plot task 28-32, 306-307
scheduling projects 156-157
Scheffe’s multiple comparison procedure 294-295
scientific notation format 154-155
selecting
columns in a query 78-79, 204-205
rows in a query 92-99, 118-123, 232-235
Server List window 135-136, 170-171, 173
server, SAS
for data 41-42, 170
for program 159, 161
for task 143
Show Multiple 136
Show One 136
skewness 284-285
Sort Data task (SORT procedure) 228-229
sorting data values
in a query 100-102, 230-231
in Filter and Sort task 226-227
in Sort Data task 228-229
space-delimited files
exporting 186-187
reading 168-169, 182-183
Spearman correlation coefficients 290-291
splitting
Project Log 163
Resources pane 136
workspace 137
spreadsheets 180-181, 186-187
SPSS files, importing 169
SQL procedure
(Append Table task) 242-243
(Query Builder) 202-221, 230-237, 240-241, 244-247, 328-329
stacking workspace 137
standard deviation
in Distribution Analysis 284-285
in query 212-217
in Summary Statistics 263, 286-287
in Summary Tables 272-273
standard error
in Distribution Analysis 284-285
in query 212-217
in Summary Statistics 263, 286-287
in Summary Tables 272-273
starting SAS Enterprise Guide 3
Stata files, importing 169
statistics
analysis of variance 294-295
association 288-289
correlation 290-291
descriptive 212-217, 262-263, 272-273, 284-287
distribution 284-285
functions 210-211
multiple comparisons 294-295
regression 292-293
saving to a data table 264-265
stopping
SAS programs 159, 161
tasks 143
Style Manager 316-317
styles
changing 66-69, 165, 314-315
creating new 316-317
subsetting data tables 92-99, 118-123, 224-227, 232-237, 328-329
summarized columns
filtering 232-233
groups 212-217
in query 81-85, 212-215
Summary Statistics task (SUMMARY procedure)
262-265, 286-287
Summary Tables task 270-281
box area properties 275
class level properties 276-277
data value properties 280-281
heading properties 274-275
table properties 278-279
sums
function 210-211
in List Data 256-257
sums (continued)
  in query 212-217
  in Summary Statistics 263, 286-287
  in Summary Tables 272-273

T
  tab-delimited files
    exporting 186-187
    reading 168-169, 182-183
  Table Analysis task 260-261, 288-289
  TABULATE procedure (Summary Tables task)
    270-281
  Task List window 4-5, 135-136, 142
    compared to menu bar 22
  task roles, assigning 24, 250
  Task Status window 5, 135
  tasks 138
    Append Table 242-243
    Assign Project Library 172-173
    assigning formats 51-56, 192-193
    Bar Chart 298-299
    code generated by 158-159
    compared to wizards 22
    Correlations 290-291
    Create Format 57-62, 194-197
    data for 224-225
    Distribution Analysis 284-285
    dynamic 330-333
    Filter and Sort 226-227
    filtering in 224-225
    footnotes 46-50, 164-165, 252-253
    Line Plot 302-305
    Linear Regression 292-293
    List Data 43-56, 63-65, 250-251, 254-257
    log 162
    modifying 25-26, 46, 143
    One-Way ANOVA 294-295
    One-Way Frequencies 22-28, 258-259
    opening 22, 25-26, 46, 142-143
    options for 164-165
    Pie Chart 300-301
    prompts in 330-333
    properties 66-69, 313
    Query Builder 244-247
    refreshing 143
    result format 312-313
    running 143
    Scatter Plot 28-32, 306-307
    server for 143
    Sort Data 228-229
    stopping 143
  Summary Statistics 262-265, 286-287
  Summary Tables 270-281
  Table Analysis 260-261, 288-289
    templates 144-145
    titles 46-50, 164-165, 252-253
  Technical Support x
  templates
    code 159
    task 144-145
  temporary library 7, 170
  text
    adding to reports 320-321
    results files 68-69, 312-313
  text data files
    exporting 186-187
    reading delimited 182-183
    reading fixed columns 184-185
  tick marks 308-309
  time data
    definition 147
    formats 154-155
    informats 152-153
  TIMEw.d
    format 154-155
    informat 152-153
  titles
    changing 46-50, 252-253
    changing default 164-165
    of procedures in results 164-165, 321
    prompts in 332-333
  TODAY function 210-211
  toolbar, workspace 25, 135
  totals
    in List Data 256-257
    in query 212-215
    in Summary Statistics 262-265
    in Summary Tables 272-273
  TRANSLATE function 210-211

U
  UNIVARIATE procedure (Distribution Analysis
task) 284-285
  UPCASE function 210-211
  update mode 150, 176
  uppercase
    format 154-155
    informat 152-153
  user-defined formats
    applying 63-65, 198-199
creating character 57-62, 194-195
creating numeric 196-197
grouping with 266-267

V
VALIDVARNAME= option 147
variables, definition 24, 146
variance
  in Distribution Analysis 284-285
  in query 212-217
  in Summary Statistics 263, 286-287

W
w.d
  format 154-155
  informat 152-153
warnings 162-163
WEEKDATEw. format 154-155
windows 4-5, 134-135
document 135
hiding 135
maximizing workspace 137
Process Flow 4, 32-33, 134-135, 138-139
Project Tree 4, 33, 134, 138-139
Resources pane 134-135, 170-171, 326-327,
  330-331, 336-337
restore window layout 4, 135, 165
splitting workspace 137
wizards
  Assign Project Library 172-173
  compared to tasks 22
  Export 186-187, 322-323
  Import Data 180-185
  New Computed Column 81-85, 206-209,
    218-219
  New Data 5-17, 174-175
  New Filter 93-98, 119-121, 232-237
WORDDATEw. format 154-155
WORK library 7, 170
workspace 4, 134-135, 137
toolbar 25
Workspace Layout icon 137

Z
Zoom option for process flows 140

Special Characters
$UPCASEw.
  format 154-155
  informat 152-153
$w.
  format 154-155
About These Authors

With over 25 years of experience, Lora D. Delwiche enjoys teaching people about SAS software and likes solving challenging problems using SAS. She has spent most of her career at the University of California, Davis, using SAS in support of teaching and research.

Susan J. Slaughter discovered SAS software in graduate school over 25 years ago. Since then, she has used SAS in a variety of business and academic settings. She now works as a consultant through her company, Avocet Solutions.

Learn more about these authors by visiting their author pages, where you can download free chapters, access example code and data, read the latest reviews, get updates, and more:

http://support.sas.com/delwiche
http://support.sas.com/slaughter
Gain Greater Insight into Your SAS® Software with SAS Books.

Discover all that you need on your journey to knowledge and empowerment.

support.sas.com/bookstore for additional books and resources.