JMP® Essentials
An Illustrated Guide for New Users
Second Edition

Curt Hinrichs and Chuck Boiler
Preface ................................................................................................................................. ix
About the Authors ................................................................................................................ xv
Acknowledgements ............................................................................................................... xvii
Chapter 1 Getting Started ................................................................................................... 1
  1.1 Using JMP Essentials ..................................................................................................... 2
    Conventions ....................................................................................................................... 2
    Book Features .................................................................................................................... 3
  1.2 Launching JMP .............................................................................................................. 5
    Tip of the Day ..................................................................................................................... 6
    The JMP Home Window .................................................................................................... 7
  1.3 JMP Menus .................................................................................................................. 9
    The Help Menu ................................................................................................................ 10
    The Analyze and Graph Menus ....................................................................................... 11
  1.4 Elements of using JMP ............................................................................................. 14
  1.5 JMP Launch Dialog Windows ..................................................................................... 17
  1.6 The Excel Add-In (Optional) ...................................................................................... 19
  1.7 JMP Preferences ......................................................................................................... 21
  1.8 Summary ..................................................................................................................... 24
Chapter 2 Data .................................................................................................................... 25
  Example 2.1 Big Class ...................................................................................................... 25
  2.1 Getting Data into JMP .................................................................................................. 26
    Opening a JMP File ........................................................................................................... 27
    Importing Data into JMP ................................................................................................ 29
    Importing an Excel File ................................................................................................... 30
    The Excel Import Wizard ............................................................................................... 31
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Importing a Text File</td>
<td>33</td>
</tr>
<tr>
<td>Importing a Database File</td>
<td>34</td>
</tr>
<tr>
<td>Creating a JMP Data Table from Scratch</td>
<td>35</td>
</tr>
<tr>
<td>2.2 The JMP Data Table</td>
<td>36</td>
</tr>
<tr>
<td>2.3 Data and Modeling Types</td>
<td>39</td>
</tr>
<tr>
<td>2.4 Cleaning and Formatting Data</td>
<td>42</td>
</tr>
<tr>
<td>Example 2.2 Movies</td>
<td>42</td>
</tr>
<tr>
<td>Formatting Decimal Places</td>
<td>44</td>
</tr>
<tr>
<td>Formatting Dates, Time, and Duration</td>
<td>45</td>
</tr>
<tr>
<td>Example 2.3 TechStock</td>
<td>45</td>
</tr>
<tr>
<td>Column Properties Menu</td>
<td>47</td>
</tr>
<tr>
<td>Formula Editor</td>
<td>48</td>
</tr>
<tr>
<td>Value Ordering</td>
<td>50</td>
</tr>
<tr>
<td>Recode</td>
<td>52</td>
</tr>
<tr>
<td>2.5 Selecting, Highlighting, and Filtering Data: Row States</td>
<td>53</td>
</tr>
<tr>
<td>Hiding and Excluding Data: Using Data Filter</td>
<td>54</td>
</tr>
<tr>
<td>2.6 Adding Visual Dimension to Your Data</td>
<td>55</td>
</tr>
<tr>
<td>Adding Labels to Data</td>
<td>57</td>
</tr>
<tr>
<td>2.7 Shape Files and Background Maps</td>
<td>58</td>
</tr>
<tr>
<td>2.8 The Tables Menu</td>
<td>60</td>
</tr>
<tr>
<td>Sorting</td>
<td>61</td>
</tr>
<tr>
<td>Joining</td>
<td>62</td>
</tr>
<tr>
<td>Missing Data</td>
<td>64</td>
</tr>
<tr>
<td>2.9 Summary</td>
<td>67</td>
</tr>
<tr>
<td><strong>Chapter 3 Index of Graphs</strong></td>
<td>69</td>
</tr>
<tr>
<td>3.1 Basic Charts</td>
<td>70</td>
</tr>
<tr>
<td>Pie Chart</td>
<td>73</td>
</tr>
<tr>
<td>Bar Chart, Line Chart, and Scatter Chart</td>
<td>75</td>
</tr>
<tr>
<td>3.2 Thematic Maps</td>
<td>77</td>
</tr>
<tr>
<td>3.3 Control Charts, Pareto, Variability and Overlay Plots</td>
<td>79</td>
</tr>
<tr>
<td>Run Chart</td>
<td>80</td>
</tr>
<tr>
<td>Individual &amp; Moving Range Chart</td>
<td>82</td>
</tr>
<tr>
<td>X-Bar/R-Charts</td>
<td>84</td>
</tr>
</tbody>
</table>
Chapter 1 Getting Started

1.1 Using JMP Essentials
1.2 Launching JMP
1.3 JMP Menus
1.4 Elements of using JMP
1.5 JMP Launch Dialog Windows
1.6 The Excel Add-In (Optional)
1.7 JMP Preferences
1.8 Summary

JMP was developed to help people with questions about their data get the answers they need through the use of graphs and numerical results. For most people, memories of statistics can be a very unpleasant, if not forgotten, part of their education. If you see yourself as a new, occasional, or even reluctant user of data analysis, we want you to know that we have written this book for you.

It is important to note that throughout the historical development of statistics as a scientific discipline, people had real problems they needed to solve and developed statistical techniques to help solve them. Statistics can be thought of as sophisticated common sense, and JMP takes a practical, common sense approach to solving data-driven problems.

JMP was designed around the workflow of analyzing data rather than as a collection of tools only a statistician can understand. When you think about your data analysis problem, try to formulate the questions that might help you address it. For example, do you need to describe the variation in selling prices of homes in a city or understand the relationship of customer satisfaction with service waiting times? With this mindset, you will find the menus and navigation in JMP to be very compatible with the types of questions you are trying to answer.

Displaying graphs (or pictures) of data is one of JMP’s strengths. For most people, an effective graph can convey more information more quickly than a table of numbers or statistics. In any JMP analysis, graphs are presented first and then the appropriate numerical results follow. This is by design. JMP also provides a Graph menu that contains additional visualization tools that are independent of numerical results. The goal of this chapter is to introduce you to JMP and its basic
navigation. We cover the menus and windows and introduce you to the conventions used throughout the book.

1.1 Using JMP Essentials

All but one chapter in this book (Chapter 3, “Index of Graphs”) is laid out in a consistent manner to help you generate results quickly. The format of the book has been designed to be used alongside your computer where JMP is installed. After an introduction to the concept, we have designed each section to be self-contained. That is, with few exceptions, the steps required to produce a result begin and end without having to flip through several pages.

We provide numbered steps that generate the result illustrated in the figure that follows (see Figure 1.1).

Figure 1.1 Book Layout

```
Formatting Decimal Places
To change the number of decimal places displayed in a column of data, do the following:
1. Click on the column of interest. In our example, it is Domestic.
2. Select Cols ▶ Column Info. JMP will make a best guess on the format of the data in our example, Currency was correctly specified (see Figure 2.23). You can easily change this format by selecting another format from the menu.
```

Note: This edition of JMP Essentials was written with JMP 11 and pre-release versions of JMP 12. However, the methods covered in this book are mostly basic and have not substantially changed since the earliest releases of the software. Thus, you will find most instructions contained in this book compatible with earlier and future JMP releases.

Conventions

We are confident that, having made it this far, you know the basic terminology associated with operating a computer, including click, right-click, double-click, drag, select, copy, and paste. We use these terms and they appear in numbered steps (see Figure 1.2). When there is a single or self-evident step, these instructions are included in the body of the text. Each step or action appears in bold type.
Figure 1.2 Selection Path Example

1. Select File ► Open.  
The Big Class.xls file, which is illustrated here, can be found by selecting C: ► Program Files ► SAS ► JMP ► 11 ► Samples ► Import Data ► Big Class.xls.
2. From the Files of Type drop-down menu, select Excel Files.
3. Select the file that you want, then select Open which will launch the Excel Import Wizard dialog with a view of your data. If it looks correctly structured, select Import.

In writing this book, we have adopted the same conventions contained in JMP documentation to ease your transition to using the documentation.

Menu items such as **Graph** are associated with a JMP command such as **Chart**. We use the greater than (►) symbol to indicate the next step in an operation. Thus, **Graph ► Chart** indicates that you should select the **Chart** command (or platform) from the **Graph** menu (see Figure 1.3).

Figure 1.3 Menu Conventions

**Book Features**

Most chapters feature one or more examples to illustrate the procedures within that chapter (see Figure 1.4). All of the examples have corresponding data tables that are included in JMP’s built-in Sample Data directory (**Help ► Sample Data**).

Figure 1.4 Data Table Description

**Example 2.1 Big Class**

We will be using the Big Class.jmp data file to illustrate the steps in this chapter. This data set consists of 40 middle-school students and their name, height, weight, gender, and age. You can access this data set in the Sample Data folder that is installed with JMP:

File ► Open ► C: ► Program Files ► SAS ► JMP ► 11 ► Samples ► Data ► Big Class.jmp
Important definitions are in bold for easy reference (see Figure 1.5).

**Figure 1.5 Definitions**

<table>
<thead>
<tr>
<th>Definition</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Data</strong></td>
<td>refers to any values placed in the cell of a JMP data grid. Examples include numeric and/or text descriptions: 3.6, $2500, Female, Somewhat Likely, or 11/14/13.</td>
</tr>
<tr>
<td><strong>Data type</strong></td>
<td>refers to the nature of the data. The data type can be either numeric (numbers) or character (often words and letters but sometimes also numbers).</td>
</tr>
<tr>
<td><strong>Modeling type</strong></td>
<td>refers to how the data within a column should be used in an analysis or a graph. JMP uses three distinct modeling types: continuous, nominal, and ordinal.</td>
</tr>
</tbody>
</table>

We include notes, tips, and cautions where appropriate to point out relevant or important information (see Figure 1.6).

**Figure 1.6 Note and Tips**

**Note:** Once you’ve selected a new value, you can replace that value in the same column, create a new column with these values, or even create a formula column. Be careful! If you select **In Place**, these values cannot be changed because the Recode command replaces values in that column.

The appendices offer reference material including Appendix C (see Figure 1.7), a JMP 11 Quick Guide that provides essential menu steps to perform a specific analysis (if you know what you’re after), Appendix B, a glossary of terms used in this book, and Appendix A, an introduction to using JMP and SAS together.

**Figure 1.7 JMP Quick Guide**

<table>
<thead>
<tr>
<th>Task</th>
<th>Menu Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding Labels</td>
<td><strong>Click on column heading; Cols &gt; Label/ Unlabel</strong></td>
</tr>
<tr>
<td><strong>ANOVA</strong></td>
<td><strong>Analyze &gt; Fit Y by X; ▼ &gt; Means/ Anova</strong></td>
</tr>
<tr>
<td>-One Way</td>
<td></td>
</tr>
<tr>
<td>-Two or More Factors</td>
<td><strong>Analyze &gt; Fit Model</strong></td>
</tr>
<tr>
<td><strong>Bar Chart</strong></td>
<td><strong>Graph &gt; Chart</strong></td>
</tr>
</tbody>
</table>
1.2 Launching JMP

Let’s begin by launching JMP. To launch JMP from the Microsoft Windows Start menu:

1. Select the **Start** menu.
2. Select All Programs.
3. Select **JMP 11 ➤ JMP 11** (see Figure 1.8).

**Note:** Windows 8 users will begin with the Start Screen.

![Figure 1.8 Opening JMP in Windows](image)

**Note:** JMP is offered in two versions: JMP and JMP Pro. JMP Pro contains more advanced predictive modeling tools that are beyond the scope of this book. Thus, you will find the steps we cover in this book identical to both versions. The only minor exception is here: Select **Start ➤ All Programs ➤ JMP Pro 11 ➤ JMP Pro 11**.

Macintosh users can click on the JMP icon (see Figure 1.9) to launch JMP from the application dock. If the icon does not appear on the dock, select **Finder ➤ Applications ➤ JMP 11**.

![Figure 1.9 Accessing JMP on the Mac](image)
After JMP has launched, you might notice that two windows have also opened: Tip of the Day and JMP Home Window.

**Tip of the Day**
The Tip of the Day window is the first thing you see because it addresses the most common questions that new users ask, such as, “How do I do X?” Well, the X in these common questions is represented and answered in 52 different Tip of the Day windows. You can scroll through them by clicking Next Tip at the bottom of the window (Figure 1.10). Some of the Tip boxes contain important and basic navigational hints, while others only apply to more advanced features in JMP.

*Figure 1.10 Tip of the Day*

Note the Enter Beginner’s Tutorial button. This tutorial walks you through a basic analysis of data, from opening data tables to creating graphs and results. JMP contains several other tutorials that are directed toward more specific types of problems and are found in the Help menu.

**Note:** If you do not want to see the Tip of the Day window every time you launch JMP, you can simply uncheck the Show tips at startup box in the lower left corner of the window.
The JMP Home Window

When you launch JMP, the Home Window appears (Figure 1.11). The Home Window first appeared in Windows in JMP 9, but now also appears in a similar format in the Macintosh version, beginning in JMP 11. The Home Window organizes and helps you navigate data tables, documentation, and open files and any results that you’ve generated. If you tend to have several data tables and analyses running at the same time, the Home Window provides a convenient way to quickly navigate to what you want.

Figure 1.11 The JMP Home Window

The Home Window is divided into four panels, which are:

a. The upper left panel contains recent files that you’ve accessed, listed from the most recently opened. If you are opening JMP for the first time, this panel should be blank.

b. The upper right panel titled “Window” contains a list of open data tables files and their associated results. In JMP, you can have any number of data tables and results open, but only one active data file may be analyzed at any one time. You may double click on any item in this panel to activate it and bring it to the forefront.

c. The lower left panel contains Recent Help. JMP includes extensive documentation built right into the software. This panel lists the documentation you’ve accessed with the most recent at the top.
d. The lower right panel lists projects that are a special type of JMP file that allow you to package a number files, slide decks, and so forth within a single file.

While the Home Window allows you to navigate directly to a file or result, each data table and results window also provides shortcuts back to the Home Window. At the lower right of each window, select the icon that looks like a house to return to the Home Window (Figure 1.12).

**Figure 1.12 Shortcut Back to the Home Window**

![Shortcut Back to the Home Window](image)

A results window has a second icon, which is also the same icon used to denote “. jmp” formatted files which we call JMP Data Tables. Click on a Data Table icon and you will be taken to the corresponding data table for that results window (Figure 1.13). Note that if you are looking at a data table, you will not see this second icon because you are already in the data table window.

**Figure 1.13 Shortcut Back to the Data Table**

![Shortcut Back to the Data Table](image)

The check box with the down arrow button next to it allows you to combine multiple results windows or graphs into a single window or “dashboard”. We will discuss creating dashboards in Chapter 7.
1.3 JMP Menus

At the top of the Home Window, you see a series of menus (File, Edit, Tables, and so on). These are the menus we use to illustrate the concepts in this book. They are also the same menus we refer to as JMP’s native menus because they have been present in JMP since its first release.

These menus serve to open or import data, to edit or structure it, and to create graphs and analyses of your data. They are also a valuable source for assistance through the Help menu, which is discussed later. The menus are logically sequenced from left to right.

- **File** is where you go to open or import data and to save, print, or exit JMP. It is also where you can customize the appearance or settings within JMP through Preferences (explained in Section 1.5).
- **Edit** will appear when needed and provides the usual cut, clear, copy, paste, and select functions, as well as undo, redo, and special JMP functions.
- **Tables** provides the tools to manage, summarize, and structure your data (see Section 2.6).
- **DOE** contains the Design of Experiments tools, which we will not cover in this book. For more information, see Help ➤ Books ➤ JMP Design of Experiments Guide.
- **Analyze** contains the analysis tools that generate both graphs and statistics and serves as the home for all of JMP’s statistical tools from simple to advanced (Chapters 5 & 6).
- **Graph** contains graph tools that are independent of statistics (at least initially). Graphs in this menu include basic charts to advanced multivariable and animated visualization tools and maps (Chapters 3 & 4).
- **Tools** allows you to transform your cursor into a help tool, a brushing tool, a selection or scrolling tool, and much more (Section 7.2).
- **View** provides options to control which windows, menus and toolbars are visible including the JMP Starter (Section 8.3).
- **Window** helps you manage windows within JMP.
- **Help** provides resources for learning and using JMP. Let’s start with an introduction to the Help menu.

**Note:** Additional menu items including “Add-ins” and “SAS” may appear if and when you have tools of these types installed.
The Help Menu

The Help menu (see Figure 1.14) provides access to learning resources you can use as you expand your knowledge of JMP features, learn about statistics, and learn how to interpret results. These resources include searchable indexes, guided tutorials, tips of the day, and printable books including Using JMP. Data tables employed in this book and in all JMP documentation are included in the Sample Data directory. Chapter 8 covers the features of the Help menu in greater detail.

Figure 1.14 The Help Menu

JMP also features context-specific help, meaning that when you use the JMP Help Tool in any graph or statistical result, you are directed to the right spot in the documentation to assist you in understanding the result. For more information on the JMP Help Tool, see section 8.1. In statistical results, JMP provides Hover Help that reveals context-specific interpretation of statistical results. See Chapter 5 for more information.

Interpretation can be straightforward for descriptive graphs or basic summary statistics, but as you dig deeper into an analysis or employ more advanced methods, it is vitally important that you understand the meaning of the results, particularly when they are shared or presented. The documentation under Help ► Books includes over 4,300 pages of reference material in fourteen books that address the needs of professional statisticians and analysts. If you encounter results that you do not understand, however, we strongly recommend that you seek assistance from experienced data analysts.
The Analyze and Graph Menus

Because most graphs or statistical results begin with the Analyze and Graph menus, let’s explore the structure within these two menus a little bit more.

Click on the Analyze menu at the top of the window. Glance at the choices on the menu. Top-down, the platforms are organized from the basic to more advanced tools. Next, click on the Graph menu at the top of the window. Glance at the graph choices. The menus in JMP—specifically the Analyze and Graph menus (see Figures 1.15a and 1.15b)—are designed to provide both a description and visual cues for analyzing, graphing, and exploring data.

Figure 1.15a The Analyze Menu

Figure 1.15b The Graph Menu
Note that each entry under these menus has both a name and an icon (on the Mac, the icons will not appear). The icons next to the Graph menu options give you a preview of each graph. From the Analyze menu, the icons depict the description or relationships you will see in graphs and statistical results (Figure 1.16).

**Figure 1.16 Visual Cues Provided for Basic Analysis**

![Menu Options](image)

**Note:** The Analyze menu items produce both graphs and statistical results, while the Graph menu items produce only graphs.
Framework of the Analyze Menu

There is a problem-solving framework to the Analyze menu that we will discuss in detail in Chapter 5. As mentioned in the introduction, your exploratory objective will translate to these menu items. This structure streamlines the analysis process; in order to select the correct menu item, you only need to count how many columns you are interested in and know whether you are trying to describe, compare, or understand their relationship (see Figure 1.17).

Figure 1.17 Framework of the Analyze Menu

This framework cues you to the correct analysis choice on the menu without exposing you to many statistical terms until you need them. Make no mistake; you still get the statistics when you want them, but you do not have to know all the statistical terms or assumptions in order to access them.

Note: JMP’s Analyze menu contains terms such as Distribution and Fit Y by X that might be unfamiliar, but the ideas behind them are very straightforward. We describe them in simple terms as needed throughout the book. Many items under the Analyze and Graph menus are referred to as platforms or commands through this book. For example, Distribution and Fit Y by X are referred to as platforms.
1.4 Elements of using JMP

Before we launch JMP for the first time, let’s look at the four common elements of a JMP analysis. All JMP analyses contain these and they follow a consistent process.

1. The first is the **JMP Home Window**, where you begin a JMP session (Figure 1.18). This is your mission control center. As described earlier in this chapter, from here you can open or create a data table or easily navigate between data tables, results, and help.

*Figure 1.18 The JMP Home Window*
2. The second element is a **Data Table** where your data reside, which you may have imported or opened through the Home Window (Figure 1.19). The data table is also where you will usually initiate an analysis or graph described next. We will cover the Data Table in Chapter 2.

**Figure 1.19 A JMP Data Table**
3. Once you have a data table open in JMP, you’ll want to select a task through the JMP menus. These tasks (or commands as we call them in JMP) generate a **Launch Window** to execute your desired command (Figure 1.20). You will notice that the columns or variables from your data table are pre-populated in the Launch window. Chapters 3 through 6 will explore these tasks and their results.

**Figure 1.20 A Launch Window**

![Distribution - JMP](image)

4. The result of any executed command is called the **Report Window**, which contains the graphs and statistics you’ve asked JMP to glean from your data (Figure 1.21). We will be seeing Report Windows throughout this book as we illustrate JMP’s features, but Chapter 7 will focus on how to share these graphs and reports with others.

**Figure 1.21 A Report Window**

![Distributions](image)
1.5 JMP Launch Dialog Windows

Throughout this book, each set of instructions used to create a graph or an analysis is prompted by a launch window that follows a consistent format and execution. To launch a window, however, you must first open a data table.

For purposes of illustration, we will open the Equity.jmp data table:

1. Select Help ➤ Sample Data ➤ Open the Sample Data Directory ➤ Equity.jmp.
2. Select Analyze ➤ Distribution (see Figure 1.22).

**Figure 1.22 Selecting the Distribution Platform**

![Selecting the Distribution Platform](image)

3. This generates the Distribution window with the columns (variables) from the Equity.jmp data table populated under the Select Columns window (see Figure 1.23).

**Figure 1.23 The Distribution Launch Window**

![The Distribution Launch Window](image)
Most JMP launch windows consist of three main elements, organized from left to right (see Figure 1.24):

**Figure 1.24 Launch Window Basics**

1. **Available columns** (or variables) of data to analyze from your data table. These appear on the left under **Select Columns**.
2. **Roles** that you want to place (or cast) on the column(s). In this area, you see buttons and empty areas under **Cast Selected Columns into Roles**. Within these empty areas, you are given a hint in italics about which columns are required and which are optional to run the analysis.
3. **Action buttons** to execute commands.

To use this Distribution window or almost any other in JMP, click on a column and select the role (or click and drag the column into that role’s empty space). Once you are satisfied with your selections, select **OK**.

Almost every analysis and graph window in JMP appears in this way. Now that you’ve learned this format, you are ready to handle just about any command window in JMP.

**Note:** The **Y, Columns** role refers to what column you want to place on the vertical, or y, axis. In other windows, such as Fit Y by X, you also have an **X** role to select that corresponds to the horizontal, or x, axis. The Weight, Freq, and By roles are more specialized, but can streamline your analyses often without the requirement of reshaping your data (For more information, see Help ▶ Books ▶ Using JMP ▶ Launch Windows).
1.6 The Excel Add-In (Optional)

We find that many new users of JMP are often Microsoft Excel users too. JMP can easily import Excel data, which we will describe in greater detail in Chapter 2, but one feature that Excel power users may appreciate is the JMP add-in for Excel. The Excel add-in is a convenient Windows-only way to launch JMP platforms from within the Excel environment. If Excel is installed on your Windows computer and you then install JMP, the add-in should appear as a new tab along the top of your Excel window (see Figure 1.25). If it does not, go to ‘Add-ins” within Excel and select the check box next to the JMP add-in item.

**Figure 1.25 The JMP Add-In Tab in Excel**

Selecting the JMP tab will reveal a JMP ribbon providing a good selection (but not all) of the commonly used JMP platforms (see Figure 1.26).

**Figure 1.26 The JMP Ribbon In Excel**

Because the JMP environment offers dynamic and visual exploration of your data, each JMP platform option will launch JMP, convert your Excel worksheet into a JMP data table, and set up the corresponding Launch window within the JMP environment. Let’s briefly summarize their functions.

1. **Preferences** help to bring your data to JMP in the right format. Here, you can specify the number of header rows in your Excel worksheet and whether to bring over hidden rows or columns.
2. **Data Table** automatically converts your Excel worksheet into a JMP Data Table. Note that it will utilize the preferences you’ve set. If your data does not transfer correctly, change your preferences accordingly or utilize the Excel Import Wizard discussed in Chapter 2.
3. **Graph Builder** is an easy-to-use data visualization platform. Selecting this option will convert your worksheet into a JMP data table, launch the Graph Builder platform, and populate the dialog with your variables or columns so that you are ready to visualize your data.
4. **Distribution, Fit Y by X, Fit Model, Time Series, and Control Chart** will again, convert your worksheet into a JMP data table and launch the corresponding platform with your variables ready to be assigned into roles.

5. **Create/Edit Model** and **Run Model** allow you to visualize your spreadsheet models using JMP’s profiler. If you are interested in performing “what-if” analysis on your spreadsheet models, the profiler allows you to do so visually. This is a great tool for presenting models because you can interact with the model and immediately visualize the effect of change. It also contains Monte Carlo simulation to explore how uncertainty will affect your model and fine-tune it to achieve desired results (see Figure 1.27).

**Figure 1.27 The Excel Profiler**

![Excel Profiler](image-url)
1.7 JMP Preferences

JMP’s Preferences determine the way JMP appears or behaves on your machine. JMP has been carefully crafted to support the workflow of the data analyst. Its defaults have been selected to reflect common use, which we use in this book. However, JMP also provides options to tailor the software to corporate standards or individual tastes. In this section, we will explore how one can customize the look, feel, and options that appear in JMP. Preferences (File ➤ Preferences) are the primary means of setting or changing the defaults in JMP that you will see each time you operate the software—think global settings here. Virtually any function in JMP can be set as a default, including specific tests within any platform, the look of graphs, color schemes, font sizes and styles, and how JMP works with other products such as SAS.

To view the preferences, choose File ➤ Preferences (see Figure 1.28).

Figure 1.28 Accessing Preferences from the File Menu

This opens the Preferences window (see Figure 1.29), containing 17 main categories on the left and options within those categories on the right. You can change preferences by checking or unchecking the boxes within the categories on the right or by selecting items from drop-down menus. Changing preferences may affect such things as the graph or result format, the font, the location of a file, and much more, each and every time you use those features in JMP. If you are unsure about making a change to the preferences, we recommend that you wait until you have a need to do so.
Note: If you need to make a change within a single graph or result, note that JMP also provides many of these formatting options within the graphs themselves.

Let’s see how this works. New users often prefer to “turn-off” the menu auto-hide option (which by design, provides a little more window real estate for graphics and statistics power users), making it a little easier to find the menu options described in this book.

Below we have an illustration of the menu hidden and un-hidden (Figure 1.30). Notice the “File”, “Edit”, etc menus appear when they are not hidden.

Figure 1.30 Illustration of Menu Hidden and Unhidden
To change this “auto-hide” default to always show the menus, select File ▶ Preferences ▶ Windows Specific ▶ Autohide menus and toolbar ▶ Never (Figure 1.31).

**Figure 1.31 Removing Menu Auto-Hide**

If you wish to change the default marker size, style, or color themes employed in graphs, select File ▶ Preferences ▶ Graphs. Included is a handy preview to see how your selections will appear (Figure 1.32).

**Figure 1.32 Graph Preferences**
1.8 Summary

JMP was developed to help the business professional, scientist, or engineer get answers to the questions and problems they encounter. The navigation and menus within JMP provide a natural extension of your problem-solving and a direct means to explore your data and generate the results you need. This book uncovers the structure of JMP’s menus and provides easy steps for producing results. The standardized format of the windows in JMP prompts you through most analysis and graphing. Results can be customized using global detailed preferences.

Index

A

adding
   labels 57, 321
   visual dimension to data 55–57
add-ins (SAS) 308
Adobe Flash 269–271
Age variable 40
alternative overlay plots 98
analysis
   framing 205–213
   one column 171–182
Analyze menu 9, 11–13
animated graphs
   creating 269–272
   defined 256
   placing into PowerPoints 273–277
   sharing 269–272
Annotate tool 259, 260
attribute data 39
Automatic Recalc 238, 247
axis, changing for graphs 263
B

background color, changing for graphs 261
background maps, shaping 58–59
Bar charts 75–76, 321
Big Class.jmp 25, 40, 41, 55–57, 60
Bivariate plot 315, 321
Books (Help menu) 291
Box and Whisker plot 315, 321
box plot
   See Box and Whisker plot
Bubble plot 126–127, 269, 321

C

C charts 90–91, 321
changing
   axis of graphs 263
   background color for graphs 261
   color for graphs 261
modeling type 41
preferences 21
Chart command 3
charts
   about 70–72
   Bar 75–76, 321
   C 90–91, 321
   individual range 82–83
   Line 75–76, 323
   moving range 82–83, 323
   NP 88–89
   P 86–87, 324
   Pie 73–74, 324
   R 84–85, 324
   run 80–81, 324
   scatter 75–76
   U 92–93, 327
   Variability 79, 94–95, 327
Chi-Square, shortcuts for 321
cleaning data 42–52
color
   changing for graphs 261
   for columns 321
Column Info Dialog 321
Column Properties menu 47
columns
   See also problem solving
coloring 321
   comparing 183–192, 197–213
   marking 321
   one-column graphs 99–107
   two-column graphs 108–120
Columns panel (data table) 37
comma (,) 319
comparing columns 183–192, 197–213
concatenate 321
certainty curves 235
Confidence Interval 315
Contingency Platform 321
Contingency Table 315–316
continuous data 39
contour 122-123, 153
Control Chart Builder method
  C charts 91
  individual/moving range charts 83
NP charts 88
P chart 86
run charts 81
U charts 93
X-Bar/R-charts 84
Control Charts
  about 76, 79
  C charts 91
  Excel add-in 20
  individual/moving range charts 83
Legend 125, 127, 142
NP charts 89
P chart 87
run charts 81
shortcuts for 321
Tree Map 124–125
U charts 93
Variability charts 94
X-Bar/R-charts 84
conventions, explained 2–3
correlation 316, 321
count 316
count data 39
covariance 321
Create Model Excel add-in 20
creating
  animated graphs 269–272
dynamic dashboards 278–280
exportable animated graphs 269–272
JMP data tables 35
Profiler for use with Flash files 131
Profiler from Fit Model 131
thematic maps 77
customizing graphs 70, 257–263
CUSUM 321

D
data
  about 25
adding labels to 57
adding visual dimension to 55–57
attribute 39
Big Class.jmp 25
cleaning 42–52
continuous 39
count 39
defined 39
distribution analysis for columns of 175–182
dynamic linking of 178
excluding 54
filtering 53–54, 214–231
formatting 42–52
getting into JMP 26–35
hiding 54
highlighting 53–54
importing into JMP 29
mapping 323
mining shortcuts 321
mining using Partition platform 203–205
preparing using Recode command 199–203
selecting 53–54
Data Filter
  about 54
  command 216–228
  shortcuts for 321
  using 54
data sets (SAS), file extensions for 26
Data Table
  about 3–4, 36–38
  creating JMP 35
  as element of JMP 15
  Excel add-in 19
  file extensions for 26
data types 39–40
database files, importing 34
dates, formatting 45
deciles 318
decimal places, formatting 44
degrees of freedom (DF) 316
Delwiche, Lora
  The Little SAS Book: A Primer 310
density ellipses 321
descriptive statistics, shortcuts for 322
design of experiments, shortcuts for 322
dialog windows, launching 17–18
Discovering JMP 291
discrete data 39
displaying multiple columns in graphs 121–131
distribution
  defined 316
  Excel add-in 20
  shortcuts for 322, 327
distribution analysis, for columns of data 175–182
distribution fitting, shortcuts for 322
Distribution plot 100–101, 196
DOE menu 9
Drop Zone 70–76
duration, formatting 45
dynamic dashboards, creating 278–280
dynamic graphs 256, 268
dynamic linking 104, 178
E
Edit menu 9
Edit Model Excel add-in 20
Effect Leverage 242
Element Type icons 137, 140
Enter Beginner’s Tutorial button 6
Equity.jmp data table 17–18
Excel
  add-in 19–20
  file extensions for 26
  Import Wizard 31–32
  importing files 30
  shortcuts for files 322
excluding data 54
experimental design, shortcuts for 322
exponential smoothing, shortcuts for 322
external resources 300–301
extracting subsets with Table command 214–216

F
F ratio 316
FACS files, file extensions for 26
File Exchange 292
file extensions 26
File menu 9
files, shaping 58–59
filtering data 53–54, 214–231
Financial.jmp 172–175, 197–198
Fit Line, shortcuts for 322
Fit Model platform
  about 195, 196
  creating Profiler from 131
  Excel add-in 20
Fit Polynomial, shortcuts for 322
Fit Y by X platform 20, 183–192, 196, 322
Flash files, creating Profiler for use with 131
forecasting, shortcuts for 322
formatting
  data 42–52
  dates 45
  decimal places 44
  duration 45
  time 45
Formula Editor 48–49, 322
framing analysis 205–213
frequency 316
frequency distribution, shortcuts for 322
Frequently Asked Questions (FAQs) 300
full factorial design, shortcuts for 322
G
Gauge chart, shortcuts for 322
goodness-of-fit, shortcuts for 322
Graph Builder platform
  about 70–72, 133, 167
  accessing 70
  Distribution plot 101
  Excel add-in 19
  Mosaic plot 105, 119
  Oneway plots 116
  Outlier Box plot 102
  producing graphs using 133–143
producing maps using 144–153
Scatterplot 110
Scatterplot (with Polynomial Fit) 112
Scatterplot (with Spline Fit) 114
shortcuts for 323
thematic maps 77–78
Tree Map 125
variability charts 94
Graph menu 1, 3, 9, 11–12, 70
graphs
See also sharing graphs
about 69–70
basic charts 70–76
Bubble plot 126–127, 269, 321
control charts 79–99
displaying multiple columns 121–130, 121–131
dynamic linking of 178
one column 99–107
Overlay plots 79–98, 324
Pareto plots 79–99, 324
producing using Graph Builder 133–143
Profiler 130–131, 324
Scatterplot 3D 122–123
Scatterplot Matrix 128–129
shortcuts for 323
Tabulate 154–167
TechStock.jmp 134–143
thematic maps 77–78
Tree Map 124–125, 327
two column 108–120
Variability plots 79–99, 327

H
Height variable 40
help
about 287
external resources 300–301
Help menu 289–298
Help tool 288
JMP Starter window 299
Help Contents (Help menu) 289–290
Help Index (Help menu) 289–290
Help menu 9, 10, 289–298
Help tool 288
Hemedinger, Chris
SAS For Dummies 310
hiding data 54
highlighting data 53–54
histograms
shortcuts for 323
stacking 262
Holt-Winters 323
Home Window 7–8, 14
horizontal bar chart, shortcuts for 323
horizontal layout, for graphs 262
HTML 5, sharing dynamic graphs with 268
HTML files, file extensions for 26
I
IF statements 42
Import Wizard (Excel) 31–32
importing
data into JMP 29
database files 34
Excel files 30
text files 33
individual range chart 82–83
input 45, 52, 107, 197–198, 209
inputs 204
integrating JMP with SAS 303–313
Interactive HTML 5 269
interquartile range 269
interval scale data 39
IR chart, shortcuts for 323
J
JMP
See also specific topics
about 1–2
Data Tables 36–38
Discussion Forum 292
elements of using 14–16
Excel add-in 19–20
file extensions for 26
files, opening 27–28
getting data into  26–35
Home Window  7–8
importing data into  29
integrating with SAS  303–313
JMP 12 xi, 2, 30, 34, 264, 269
launching  5–8
launching dialog windows  17–18
menus  9–13, 320
Preferences  21–23
reasons for using  313
SAS training for  301
shortcuts  319–326
Starter window  299
technical support  300
Toolbar  259, 260
User Community (Help menu)  292
versions 11/12  2, 5
webcasts  300
website  38, 300
JMP/JMP Pro  5
Join option (Tables menu)  62–63
joining shortcuts for  323

K
Knowledge Base  292
Kruskal-Wallis Test, shortcuts for  323

L
labels, adding  57, 321
Lasso tool, selecting individual points with  229–231
Launch Window, as element of JMP  16
Layout option, sharing results with  281–284
least squares regression, shortcuts for  323
Likert scales  39
Line chart  75–76, 323
Lines tool  259, 260
The Little SAS Book: A Primer (Delwiche and Slaughter)  310
Logistic Fit  117
logistic regression  316, 323, 324
logit models  316

M
Mac, accessing JMP on  5–6
Make Into Data Table  162
mapping data  323
maps, producing using Graph Builder  144–153
marking columns  321
MATLAB code, file extensions for  26
maximum  316
McDaniel, Stephen
SAS For Dummies  310
mean  317
median  317
memory capacity  38
menus (JMP)  9–13, 320
metadata  36
minimum  317
mining data using Partition platform  203–205
Minitab Worksheets, file extensions for  26
missing data  64–66
Missing Data Pattern window (Tables menu)  64–66
model fitting  232–252
Modeling tool  196
modeling type  39–41
Mosaic plot  104–105, 118–119, 323
Movies.jmp  42–43, 50–51, 52, 154–167
moving averages  323
moving range chart  82–83, 323
multiple comparisons, shortcuts for  324
multiple regression  317, 324
Multivariate platform, shortcuts for  324
Multivariate window  65

N
Name variable  40
95% confidence curves  235
nominal data  39
Normal Quantile plot  103
NP chart  88–89

O
one-column graphs
about  99
Index

Distribution plot 100–101
Mosaic plot 104–105
Normal Quantile plot 103
Outlier Box plot 102
Time Series 106–107
one-way analysis of variance (one-way ANOVA) 171–182, 317, 321, 324
Oneway plots 115–116
Open DataBase Connectivity standard (ODBC) 26
opening
dialog windows 17–18
Graph Builder platform 70
JMP 5–8
JMP files 27–28
SAS programs 307–308
OpenStreet Maps 59
ordinal data 39
outlier 317
Outlier Box plot 102, 324
See also Box and Whisker plot
Outputs 204
Overlay plots 79, 97, 98, 324

P

P chart 86–87, 324
Parallel plot 120, 324
Pareto plot 79, 96, 324
Partition platform
data mining using 203–205
defined 317
shortcuts for 324
Partition Trees 209–210
paste functions 266–267
Paste special 266–267
Percentile 190, 316, 318
Phase chart, shortcuts for 324
Pie chart 73–74, 324
Pivot-Table, shortcuts for 324
Point chart, shortcuts for 324
Polygon tool 259
power calculations, shortcuts for 324
PowerPoint

Q

qualitative data 39
Quantile plot 103
quantiles 318
quantitative data 39
quartiles 318
Quick Guide 4

R

R chart 84–85, 324
R code, file extensions for 26
ratio data 39
Recode command 42, 52, 199–203
recursive partitioning, shortcuts for 324
red triangle 55, 65
regression
defined 318
logistic 316, 323, 324
multiple 317, 324
shortcuts for 324
simple 324, 325
regression trees 324

SAS programs 307–308
shortcuts for 324
Phase chart, shortcuts for 324
Pie chart 73–74, 324
Pivot-Table, shortcuts for 324
Point chart, shortcuts for 324
Polygon tool 259
power calculations, shortcuts for 324
PowerPoint

Prob > F 317
Prob > t 317–318
problem solving
about 169–170, 195–196
analyzing one column 171–182
comparing columns 183–192, 197–213
model fitting 232–252
visualization 232–252
what-if analysis 232–252
Process Control, shortcuts for 324
Profiler 130–131, 324
program files (SAS), file extensions for 26

Q

qualitative data 39
Quantile plot 103
quantiles 318
quantitative data 39
quartiles 318
Quick Guide 4

R

R chart 84–85, 324
R code, file extensions for 26
ratio data 39
Recode command 42, 52, 199–203
recursive partitioning, shortcuts for 324
red triangle 55, 65
regression
defined 318
logistic 316, 323, 324
multiple 317, 324
shortcuts for 324
simple 324, 325
regression trees 324

SAS programs 307–308
shortcuts for 324
Phase chart, shortcuts for 324
Pie chart 73–74, 324
Pivot-Table, shortcuts for 324
Point chart, shortcuts for 324
Polygon tool 259
power calculations, shortcuts for 324
PowerPoint

Prob > F 317
Prob > t 317–318
problem solving
about 169–170, 195–196
analyzing one column 171–182
comparing columns 183–192, 197–213
model fitting 232–252
visualization 232–252
what-if analysis 232–252
Process Control, shortcuts for 324
Profiler 130–131, 324
program files (SAS), file extensions for 26

Q

qualitative data 39
Quantile plot 103
quantiles 318
quantitative data 39
quartiles 318
Quick Guide 4

R

R chart 84–85, 324
R code, file extensions for 26
ratio data 39
Recode command 42, 52, 199–203
recursive partitioning, shortcuts for 324
red triangle 55, 65
regression
defined 318
logistic 316, 323, 324
multiple 317, 324
shortcuts for 324
simple 324, 325
regression trees 324
Report Window 16
residual analysis 324
resources, external 300–301
response surface, shortcuts for 324
results, understanding 315–318
row labels, producing 120
row states 53–54
Rows menu, adding visual dimension to data 55–57
Rows panel (data table) 37
RSquare 318
Run charts 80–81, 324
Run Model Excel add-in 20

S
S chart, shortcuts for 325
sample data directory, shortcuts for 325
Sample Data Index (Help menu) 294–295
sample size calculations, shortcuts for 324
San Francisco Crime.jmp 144–153
SAS
add-ins 308
integrating with JMP 303–313
Libraries 306
Metadata 304-307
reasons for using 313
training in for JMP 301
working with data 303–307
SAS For Dummies (McDaniel and Hemedinger) 310
SAS programs 307–313
SATByYear.jmp 257–258
Save Script to Data Table 223, 285
saving graphs with scripts 285–286
scatter charts 75–76
Scatterplot
See also bivariate plot
about 109–110
with Polynomial Fit 111–112
shortcuts for 325
with Spline Fit 113–114
Scatterplot 3D 122–123
Scatterplot Matrix 128–129
screening design, shortcuts for 325
scripts, sharing graphs with 285–286
Search the Help (Help menu) 289–290
selecting
data 53–54
individual points with Lasso tool 229–231
selection path, example of 2
Selection tool 259
semicolon (;) 319
Set Format 161
Shapefiles, file extensions for 26
shaping background maps and files 58–59
sharing graphs
about 255–256
animated graphs 269–272
changing axis 263
changing background color 261
changing color 261
creating dynamic dashboards 278–280
customizing 257–263
horizontal layout 262
JMP Toolbar 259–260
with Layout option 281–284
placing animated graphs into PowerPoints
273–277
placing into PowerPoint or Word 264–267
presenting effectively 256
with scripts 285–286
sharing dynamic graphs with HTML 5 268
SHIFT key 72
shortcuts (JMP) 319–326
Show and Include 220, 237, 247
simple regression, shortcuts for 324, 325
Simple Shape tool 259
Slaughter, Susan
The Little SAS Book: A Primer 310
sort, shortcuts for 325
Sort option (Tables menu) 61
Spearman's Rho, shortcuts for 325
special paste functions 266–267
Split 207-209, 213
Split Prob 209
SPSS data files, file extensions for 26
Index

stacking histograms 262
standard deviation 318
standard least squares 318
static graphs 256
statistical modeling 197
Statistics Index (Help menu) 297–298
Stepwise regression, shortcuts for 325
subsets
  extracting with Table command 214–216
  shortcuts for 325
sum of squares 318
Summary option (Tables menu) 60
Summary Statistics, shortcuts for 325

T
Table command, extracting subsets with 214–216
Table panel (data table) 36–37
tables, shortcuts for 325
Tables menu
  about 9, 60
  joining 62–63
  missing data 64–66
  sorting 61
Tabulate platform
  about 133, 154, 167
  Movies.jmp 154–167
  shortcuts for 325
technical support (JMP) 300
TechStock data table 45–46
TechStock.jmp 134–143
Teradata Database, file extensions for 26
Test for Equal/Unequal Variances, shortcuts for 327
Test for Normality, shortcuts for 327
Test for Proportions, shortcuts for 327
text files
  file extensions for 26
  importing 33
thematic maps 77–78
time, formatting 45
Time Series plot
  about 106–107
  Excel add-in 20
  shortcuts for 322, 327
Tip of the Day (Help menu) 6, 295–296
Toolbar (JMP) 259–260
Tools menu 9
Tree Map 124–125, 327
t-Test, shortcuts for 325
Tukey Box Plot 102, 327
Tutorials (Help menu) 293
two or more factor ANOVA, shortcuts for 327
two-column graphs
  about 108
  Logistic Fit 117
  Mosaic plot 118–119
  Oneway plots 115–116
  Parallel plot 120
  Scatterplot 109–110
  Scatterplot (with Polynomial Fit) 111–112
  Scatterplot (with Spline Fit) 113–114

U
  U charts 92–93, 327
  Univariate platform, shortcuts for 322, 327
user groups 301
Using JMP (SAS) 47, 67

V
  value ordering 50–51
  Variability chart 79, 94–95, 327
variables
  See columns
versions (JMP) 2, 5
View menu 9
viewing preferences 21
visual dimension, adding to data 55–57
visualization 232–252

W
Web Resources 292
webcasts (JMP) 300
websites
  JMP 38, 300
PowerPoint Help  273
user groups  301
Weight variable  40
Wilcoxon Rank Sum Test, shortcuts for  327
Wilcoxon Signed Rank Test, shortcuts for  327
Window menu  9
Windows PCs, accessing JMP on  5
Word, placing graphs into  264–267
writing SAS programs  309–310

X

X-Bar charts  84–85, 327
xBase data files, file extensions for  26

Y

Y, Columns  18

Z

z-Test, shortcuts for  325
About These Authors

**Curt Hinrichs** is Senior Manager of Marketing at SAS Institute Inc. Curt joined SAS in 2006 to develop and launch the JMP Academic Program that provides faculty, researchers, and students with easy access to JMP software and learning resources. Curt and his team are charged with developing JMP users among the next generation of data analytics professionals. They work directly with faculty, authors, and administrators and partner with leading academic societies, publishers, and service providers to support the effective use of JMP software in the classroom. Prior to joining SAS, Curt worked as an acquisitions editor for Thomson Learning, and later worked as Publisher and Vice President/Editor in Chief for its Mathematics and Statistics Publishing Group. He holds a bachelor’s degree in economics from San Diego State University.

**Chuck Boiler** is the U.S. Systems Engineer Manager for JMP, a business unit of SAS. Since joining SAS in 1997, he has held management roles with JMP and helped develop solutions for conducting many types of analysis, including design of experiments for the semiconductor industry, quality control for pharmaceutical manufacturing, and marketing applications for survey analysis using JMP. Boiler currently works with customers and U.S. field engineering staff to help them solve business problems and discover hidden opportunities in data. Earlier in his career he worked for Abacus Concepts, makers of StatView software, as technical services manager and software quality assurance manager. A member of the American Society of Quality, Boiler received a bachelor’s degree in education from the University of Oregon and has done graduate work in ancient philosophy at the Graduate Theological Union in Berkeley, California. He is a graduate of Gallup University's Great Manager Program.

Learn more about these authors by visiting their author pages, where you can download free book excerpts, access example code and data, read the latest reviews, get updates, and more: [http://support.sas.com/publishing/authors/hinrichs.html](http://support.sas.com/publishing/authors/hinrichs.html) and [http://support.sas.com/publishing/authors/boiler.html](http://support.sas.com/publishing/authors/boiler.html)
Gain Greater Insight into Your SAS® Software with SAS Books.

Discover all that you need on your journey to knowledge and empowerment.