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ABSTRACT  

There are many time-saving and headache-saving tips and tricks you can use to 
make working in SAS® Enterprise Guide® a breeze. Did you know that you can 

create a process flow from a program with the click of a button? You will learn 20 
tips and tricks for working in SAS Enterprise Guide in 20 minutes – tips for both 

SAS Enterprise Guide 7.x and 8.x.  One tip per minute, and out of the twenty, you 
are guaranteed to find at least one nugget that will make your life easier.  

INTRODUCTION 

There is a difference between programming and programming efficiently. You might know 

how to get your code to run and generate results, but are you doing it as painlessly as 

possible? In this paper, you will learn 20 tips for working in SAS Enterprise Guide that will 

help you become a more efficient and happier programmer. You will learn how to make SAS 

Enterprise Guide feel more like “old school Base SAS,” or how to make it feel totally cutting 

edge. Just as there are often several ways to get the same results, there are many features 

to get the SAS Enterprise Guide experience and performance that meets your needs. The 

goal of this paper is to show you at least one feature you haven’t been using but that you 

can’t wait to implement  

CUSTOMIZING GENERAL OPTIONS 

Regardless of whether you spend a lot of time or a little bit of time using SAS Enterprise 

Guide, you want it to be the most user-friendly experience you can have. But since your 

definition of user friendly might not be the same as another users, SAS Enterprise Guide  

has options that you can use to customize your experience.  

From the main menu, select Tools → Options.  

 

Figure 1: Options in the Tools Menu 
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1. FILE OPEN WINDOW 

One of the first things you might want to do when working in SAS Enterprise Guide is to 

open a program file or a data set. SAS Enterprise Guide 8 makes this easier and faster 

than ever. Now, you can select File → Open to see all the items you’ve used recently. If 

you click My Computer, you have the option to navigate to whatever file location you’d 

like, and you can choose to “pin” that location so that you can access it without the 

hassle of navigating to it each time. You can also see your recent locations from this 

view and pin them as well.  

 

 

      Figure 2: Pinned and Recent Locations           

 

2. AUTOEXEC PROCESS FLOW 

Another time saver is the Automatically run “Autoexec” process flow when project 

opens option. For example, you can create a process flow named Autoexec that defines all 

your macro variables or your LIBNAME statements. Now, every time you open the project, 

the Autoexec process flow  runs automatically, and the macro variables or libraries are 

ready to use.  

 

3. SPLIT VIEW INTO MULTIPLE WINDOWS 

By default, SAS Enterprise Guide displays only one item at a time. But you can easily 

change this and show two items at a time using the Workspace Layout option. You might 

want to have your Program Editor open, and see the input data set you’re working with. Or 

the log and Program Editor. Or the output data set and the result – the combinations are 

endless!  

In SAS Enterprise Guide 7 to view two windows at once, select View→ Workspace Layout 

and then select Stacked or Side-by-Side. To specify the window you want 

something to open in, click in the upper right corner of the workspace. 

In SAS Enterprise Guide 8, the workspace is extremely customizable, and you are not 

limited to two workspaces. In fact, you don’t have to use a project at all, and you can even 

have workspaces open on different monitors. 
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4. RESET DEFAULT LAYOUT 

Sometimes your project might seem to be misbehaving – you have lost a window, or it 

won’t go where you want it, or your cursor is nowhere to be found. In SAS Enterprise Guide 

7, try the Restore Window Layout option in the General panel.  (Note: In SAS Enterprise 

Guide 8, this option is on the main menu under View-> Reset to default layout). 

 

 

5. AUTOMATICALLY REPLACE TASK RESULTS 

In releases prior to SAS Enterprise Guide 8, you are prompted replace the results of a task 

each time you run the task.  This is the default behavior and can be annoying if you always 

want to replace the results. You can control this behavior by setting the Replace results 

option to Replace without prompting.  If you are using SAS Enterprise Guide 8, Replace 

without prompting is now the default setting. 

 

Figure 3: Automatically Replace Results 
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6. AUTOMATICALLY SUBMIT CUSTOM SAS CODE 

There might be code that you want to run every time you open SAS Enterprise Guide, or 

every time before or after you submit code from a program node. For example, you might 

want to create certain macro variables or work tables or assign or unassign libraries. You 

can include this code and set it to automatically run by selecting the SAS code options in the 

SAS Programs panel.   

 

 

Figure 4: Automatically Run Custom Code 

 

WORKING WITH THE PROGRAM EDITOR 

You might have moved to SAS Enterprise Guide from another programming interface and 

prefer coding to point-and-click. The Program Editor in SAS Enterprise Guide can be 

customized to make your coding experience easy and familiar. 

7. TURN ON LINE NUMBERS 

Line numbers are not turned on by default in the Program Editor. To turn on line numbers, 

select Tools->Options.  Open the SAS Programs panel and click Editor Options.  

In SAS Enterprise Guide 8, it’s even easier – just right-click in the Program Editor and select 

Show line numbers. 

 

8. AUTOMATICALLY FORMAT CODE 

Sometimes you are so “on a roll” with writing code that you don’t want to take the time to 

indent your code and make it readable. SAS Enterprise Guide can help! Right-click in the 

Program Editor and select Format code, and your code will transform into a more readable 

and structured format. You can also press Ctrl+I to format the code, or in SAS Enterprise 

Guide 8, you can select the            icon from the task bar.  

 



5 

9. COPY A COLUMN  

There are times when you want to copy lines of code and reuse them. But you might not 

want the whole line, just part of it. Rather than copying the lines and deleting the part you 

don’t want, press Alt+left mouse to highlight the part you want, and then copy it.  

 

 

Figure 5: Copy a Select Area 

 

10. DRAG AND DROP DATA SET NAMES AND VARIABLES INTO A PROGRAM 

 SAS Enterprise Guide 8 has a new feature that minimizes room for error and increases the 

convenience factor. You can drag and drop a data set name from the Servers pane onto 

your program, and SAS Enterprise Guide will show the libname and data set name. You can 

also expand the data set in the Server pane and drag individual variables  to your program. 

This drag-and-drop functionality eliminates the need to enter names and reduces the 

chance of spelling errors that can cause syntax errors.  

Note: You can use the Ctrl key to select multiple variables and drag them to your program  

at the same time. 

 

Figure 6: Drag and Drop Variable Names 
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11. SELECT SERVER FOR CODE EXECUTION 

Sometimes you will get an error message that you swear can’t be possible. For example, 

you might get an error saying “Library XXX does not exist”. But you look at the server list 

and see the library is there and assigned! The cause of this error could be that you are not 

running the code on the server you thought you were. 

 To see what server the code is running on, open the program and look at the value of the 

Selected Server field on the toolbar or right-click in the program and look at the Run On 

value. If you aren’t running the code on the server you want, you can change to the correct 

server either on the toolbar or by right-clicking in the program and selecting Select Server. 

 

Figure 7: Select Server for Code Execution 

 

WORKING WITH LOGS AND PROGRAM STATUS 

 

12. PROJECT LOG 

The project log is turned off by default in SAS Enterprise Guide. To turn on the project log, 

select Tools→ Options. (In SAS Enterprise Guide 8, select   Tools->Options->Project 

and Process Flows.). In the General panel, select Enable project log for new project. 

Now that the project log is on, it will track all the tasks and code run in the entire project 

and enable you to view all the logs in one place. In addition, you can use the Project Log 

Summary window to quickly see the specific log that has an error. 
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Figure 8: Project Log Summary Window 

 

13. STATUS UPDATES FOR A RUNNING PROGRAM 

Oftentimes you will run code that takes a long time to run, and you have no idea where it is 

in terms of finishing. Halfway through? Almost done? Still running the first loop?  

 You can use the SYSECHO statement  to display a custom status message . This message is 

displayed until the next status event (another SYSECHO statement, another DATA step, or a 

PROC) –.  

In SAS Enterprise Guide 7, the status message appears in the Task Status window. If you 

are using SAS Enterprise Guide 8, the message appears in the Submission Status window. 

Figure 9: Using the SYSECHO Statement 
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14. DECLUTTERING LOGS 

In the log, you might see a lot of code that you didn’t write in your program – such as  

%LET or ODS statements – and wonder where this codecame from. This code is 

automatically generated by SAS Enterprise Guide when you run a program or task. If you 

don’t want this code written to the log, select Tools → Options. Under the Results 

heading, select Results General, and thenclear the Show generated wrapper code in 

SAS log option. Now this verbose code is replaced by  %_eg_hidenotesandsource; in 

the log. 
 

TASKS AND QUERIES  

15. FINDING THE RIGHT TASK 

SAS Enterprise Guide has built-in tasks that you can use to harness the power of SAS 

procedures in a GUI format. Now, you don’t have to know the syntax for a procedure to be 

able to use one! However, it can be puzzling if you DO know the name of the procedure you 

want to use, but you don’t know the name of the corresponding SAS Enterprise Guide task. 

One way to find this task is to use the Tasks pane.  

 Select the Filters option to see a list of all the available procedures. Select the procedure 

you want, and you will see the task or tasks that use that procedure. You can also search on 

the procedure name.  

 

 Figure 10: Tasks Pane        

Here we see that PROC PRINT corresponds to the List Data task. And if you hold your 

pointer over the task, you will see an information window with more details. Click the star to 

add this task to your list of favorites for fast access in future. 
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16. FILTERING AND SORTING 

The Sort Data task can be used to sort your data. There is also a Filter and Sort option in 

the data grid. What’s the difference?  

 The Filter and Sort option enables you to select what columns you want, subset the data 

(for example, if you want to see only sedans with a City MPG greater than 25), and then 

sort the data. If you sort the data by Make, you might get rows that repeat, so the results 

aren’t quite what you had in mind. What you REALLY wanted is a list of all the Makes that 

met the criteria with no duplicate records. 

In that case, you want to use the Sort Data task.  In this task, you have all the same 

options as in Filter and Sort, but you ALSO have the option to Keep only the first record 

for each “Sort by” group, which removes any duplicate records.  

  

 

Figure 11: Sort Data Task Results Versus Filter and Sort 

 

17. CREATING DYNAMIC QUERIES  

The Query Builder is a powerful tool that generates SQL behind the scenes enabling you to 

join and manipulate data. You can use prompts (or macro variables) to make your queries 

dynamic. 

You might want to query a data set by gender and calculate the average height. Instead of 

using the same value for gender in the filter each time, you want to select the gender when 

you run the query. Use the Prompt Manager to create a variable that lets you choose the 

value when you run the query. 
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Figure 12: Creating a Prompt 

You can now use this prompt in the filter of your query. When you run the query, you will be 

“prompted” to select the gender you want.  

 

18. RESIZING COLUMNS IN THE DATA GRID 

The results of your task or query is displayed in the data grid. But sometimes the columns 

are compressed and the data is truncated. You can automatically resize the column to the 

size of the widest value by selecting the column and double clicking in the space between it 

and the right adjoining column. 

In SAS Enterprise Guide  8, the columns in the Data Grid are automatically sized by default! 

If you want to turn this feature off,  select Tools → Options →Data →General and clear 

the  Auto-size column widths option. 

 

 

Figure 13: Resizing a Column 
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19. EXTRACTING CODE FROM A TASK OR QUERY 

One of the best features about SAS Enterprise Guide is its GUI interface for tasks. You 

can create a complex graph without having to write any code. But what if you want to 

reuse this code, or if you want to tweak the code to customize it? You can see the code 

that was created by the task or query and reuse it in the Program Editor!  

 To see the code, right-click the task or query in the project and select Open → Open 

Last Submitted Code. You can then copy and paste the code into a Program Editor and 

run it or make changes. It’s even easier in SAS Enterprise Guide 8. You can just right 

click on the task and select Extract code. SAS Enterprise Guide creates a code node 

with the task or query code in it.  

 

 

Figure 14: Extract Source Code from a Task 

 

PROCESS FLOW AND PROJECTS 

You now have dynamic queries that you’d like to reuse without having to re-create them. 

This is the perfect time to create a stored process! 

 

20. CREATE A STORED PROCESS FROM A PROJECT 

You can create a stored process from your project. A stored process puts all the code from 

the project into a neat bundle and stores it in a central location where it can be accessed by 

remote clients.  
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To create a stored process, right-click in the process flow and select Create Stored 

Process.  The Create New Stored Process wizard walks you through creating the stored 

process.  After you create the stored process, you can use it in other SAS applications, such 

as SAS Add-In for Microsoft Office, or other people who have access to the stored process 

can use it.  

 

BONUS TIP!  

21. PROJECT SEARCH 

You might be working on a project and need change out a data set with another one. This 

can be a big pain if you have a large project where you used the data set multiple places. 

But never fear, you can use the project search to find all the places the data set could be 

hiding. Enter the text string that you want to search for – in our case, the data set name. A 

results box   contains all the places where the text string was found.  

 

 

Figure 15: Project Search Results 

You can search the whole project, or if you want to refine your results to just programs that 

contain the string, you can select Program. To open the results, double click the search 

result you want to view. 
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CONCLUSION 

SAS Enterprise Guide is a powerful tool designed to make data access, analysis, and sharing 

easy. Whether you are a seasoned programmer or a novice, you can use SAS Enterprise 

Guide to harness the power of SAS. We have only scratched the surface of some of the tips 

you can use when working with SAS Enterprise Guide, but hopefully you found at least one 

new tip that you can start using next time you log on.  
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