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SAS Enterprise Guide Windows

SAS Enterprise Guide has many windows. You can customize the appearance of SAS Enterprise
Guide—closing some windows, opening others, and resizing them all—until it looks just the
way you want. Then SAS Enterprise Guide will remember those settings so the next time you
open it, everything will be just where you left it.

Here is SAS Enterprise Guide with its windows in their default positions.

i€ SAS Enterprise Guide - Chapter1.egp E”E|g|
File Edit ‘“iew Tasks Program  Tools  Help @'ﬁv% Ehaf By X | » o[- gQgProcessFlow -

Project Tree + ¥ Process Flow -
= gqg Process Flow [ Run - Export = Schedule = | Zoom - Project Log Properties -
=] Voloanoes 2

3

B List Data —_— y
E @
D. Maote ﬁ : *» o
- Vaolcanoes List Data 3AS Report
Project Tree - List Da...
N

Mats [ Workspace showing ]

Server List X
& GAS

iy

the Process Flow

o

- - JEm
s

rYErs
Local
SASApp

LAP Servers

-
I
=]

Resources pane showing
the Server List

Ready % Connection: sasdemo, 127.0.0.1

Some windows are open by default while some are closed or hidden behind other windows. You
can open or unhide the major windows using the View menu.

Docked windows Some of the windows in SAS Enterprise Guide are docked. Most of the
docked windows can appear on the left or right side of the application. To change a window
from one side to the other, click the down arrow (V) in the upper-right corner of the window
and select Dock Left or Dock Right from the pop-up menu. From this menu, you can also select
Auto Hide. If you hide a window, it will be reduced to a tab along the side. To view a hidden
window, position your cursor over the window’s tab. When you move the cursor out of the
window, it will be reduced to a tab again. To unhide a window, click its tab or select it from the
View menu. These windows are docked:

@ Project Tree The Project Tree window displays the items in a project in a hierarchical
tree diagram. This window is open by default.
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Server List The Server List window lists available SAS servers, and the files and SAS
data libraries on those servers. A SAS server is any computer on which SAS software is
installed. The computer on which you run SAS Enterprise Guide may or may not be a
SAS server. This window appears in the Resources pane, and is open by default.

Task List The Task List window lists all available tasks and task templates. Using the
drop-down list at the top of this window, you can choose to display tasks by category,
tasks by name, or task templates. You can open a task by double-clicking its name in
this window. This window appears in the Resources pane, and is closed by default. To
open this window, click its icon in the Resources pane.

5

SAS Folders The SAS Folders window lists any folders that have been defined in
metadata. This window appears in the Resources pane, and is closed by default. To open
this window, click its icon in the Resources pane.

current project. This window appears in the Resources pane, and is closed by default.
To open this window, click its icon in the Resources pane.

Task Status The Task Status window displays notes about tasks that are currently
running. This window is different from other docked windows because it is docked to
the bottom of the application, and you cannot move it or reduce it to a tab. This window
is closed by default. To open the Task Status window, select it from the View menu.

@ Prompt Manager The Prompt Manager window lists any prompts defined for the

Workspace The workspace is not itself a window, but it is very important. This is where the
Process Flow and document windows appear. The workspace is always there and cannot be
closed. However, you can open and close individual items inside the workspace.

g.%g Process Flow The Process Flow window displays the items in a project and their
relationship using a process flow diagram. You can open only one project at a time, but
you can create as many process flows as you wish inside a single project. You can open
the Process Flow by selecting it from the View menu, by double-clicking its name in the
Project Tree, by selecting it from the drop-down list at the top of the workspace, by

selecting the Bog Process Flow = drop-down list on the menu bar, or by pressing F4.

=8 Document windows The document windows display your data, results, programs,
logs, and notes. There is a different type of icon for every kind of document. This icon

represents a SAS data table.

Menus and tools The menus and tools across the top of SAS Enterprise Guide (also called
the menu bar) are always the same. However, the menus and tools inside the workspace (also
called the workspace toolbar) change. For example, the options above a Process Flow are
different from the options above a data table. You can also right-click many objects to open a
pop-up menu for that object. So you can see that there are often several ways to do the same
thing. This book cannot list all the ways to do every action, but with a little exploration you can
find them.

Restoring windows Once you have rearranged your windows, you may decide you want
them back where they started. To restore them to their original locations, select Tools » Options
from the menu bar. Then in the General page of the Options window, click Restore Window
Layout.
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Splitting the Resources Pane and Workspace

The Resources pane and the workspace are busy places. The Resources pane is home to four
windows, while the workspace accommodates even more. By default, you can see only one item
at a time, but you can see more if you split the Resources pane or workspace.

Splitting the
Resources pane To
split the Resources
pane, click the down-
arrow (V) at the top of
the pane, and select
Show Multiple from
the pull-down list. At
first, you will only see
one window because
only one window is
open.

& SAS Enterprise Guide - Chapter1.egp
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Data L
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< >

Propetties -

|£

Ready

\@\Connection: sasdemo, 127.0.0.1

To open other windows,
click their icons: Task

ListE llh, SAS Folders

Eﬁ, Server List ,

or Prompt Manager@.
You can open all four
windows at once in the
Resources pane if you
wish. In this example,
two windows are open,
the Task List and the
Server List.

To return the Resources
pane to normal, click the
down-arrow and select
Show One.
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Maximizing the workspace It may be helpful to make the workspace as large as possible
before you split it. To do this, select View » Maximize Workspace from the menu bar. When
you maximize the workspace, the Project Tree and Resources pane become tabs pinned to the
edge of SAS Enterprise Guide. You can temporarily expand those windows by moving the
cursor over a tab. When you move the cursor away, the window will be reduced to a tab again.
To return the workspace to its normal size, select View » Maximize Workspace again.

Splitting the [&/ SAS Enterprise Guide - Chapter1.egp
Workspace YOu File Edt View Tasks Program  Took  Hep |19~ = % 1 o2 Ba (A X |5 Al Mg gqumcess Flow ~

: Process Flow = single
can sPht the g B R Export = Schedul 2 Project L Propert Bl Sacked
workspace lnto tWO % un - XPpOrt = Schedule - oonm rojeck Log | Properties - Ijﬂ e By e
pieces. First, open g @ %%
any ltems you WISh tO Eﬂ'g} WVolcanoes List Data SAS Report
view. Then click the i -List Dan.
Workspace Layout Bl [l
icon on the menu bar Nets

D, and select

either Stacked or
Side By Side from
the pull-down list.
You can also do this
by selecting View »
Workspace Layout -
from the menu bar. Roady %, Connertion: sasders, 127.0.0.1

You can click the
down-arrow at the

[/ SAS Enterprise Guide - Chapter1.egp
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(13 | Kilimanjara Tanzania Af 5895 . 1 f h 11
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workspace.
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Projects

In SAS Enterprise Guide, all the work you do is organized into projects. A project is a collection
of related data, tasks, results, programs, and notes. Projects help you by keeping track of
everything, even if your data are scattered in many directories or on more than one computer.
That way, when you come back to an old project six months or a year later, you won't be left
wondering which data sets you used or what reports you ran.

You can have as many projects as you like, and you can use a data set over and over again in
different projects, so there is a lot of flexibility. However, you can have only one project open at a
time. Also, if you share a project file with someone else, that person must have access to your
data files and any other items you reference.

To create a new project, select File » New » Project from the menu bar. To open an existing
project, select File » Open » Project and navigate to your project.

Project Tree and Process Flow The Project Tree window displays projects in a
hierarchical tree diagram, while the Process Flow window displays projects using a process flow
diagram. In either window, the items in your project are represented by icons, and connected to
show the relationship between items. Here are examples of a Project Tree and a Process Flow
showing the same project. This project contains several types of items: data, tasks, results, a
program, and a note.

Process Flow -
Project Tree - X d
~

I+ Run = Export + Schedule ~ | Zoam =
= gQg Process Flow

=B Yolcanoes I‘—'?_}-

Lizt Drata Wolcanoes List Data 5A$ Report

Il Bar Chart ki

[£1 Hote B fu ‘—’<@
EEE Towrs Mote EBiar Chart SAS Report
= D F'rograms -BarCha...

Eﬂ' Proaram

Tours

A

Program
< >

»

Data Data files in a project may be SAS data tables, raw data files, or files from other
databases or applications, such as Microsoft Excel spreadsheets. Projects contain
shortcuts to data files, not the actual data. If you delete a project, your data files will still
exist. This icon represents a SAS data table.

I'_ﬂ'_ Tasks Tasks are specific analyses or reports that you run, such as List Data or Bar
Chart. Every time you run a task, SAS Enterprise Guide adds an icon representing that
task. This icon represents the Bar Chart task.

o Results Results are the reports or graphs produced by tasks you run. Results are
om| represented by icons labeled with the type of output (SAS Report, HTML, PDF, RTF, or
text) and the name of the task. This icon represents output in SAS Report format.
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Notes Notes are optional text files you can use to document your work, or record
comments or instructions for later use. To create a note, select File » New » Note from
the menu bar. A text window will open, allowing you to type whatever you wish.

@ Programs Programs are files that contain SAS code. You can open existing programs
in SAS Enterprise Guide, or you can write new programs.

Showing properties and opening items You can display the properties for any item by
right-clicking its icon in the Project Tree or Process Flow and selecting Properties from the pop-
up menu. You can open any item by double-clicking its icon, or by right-clicking its icon and
selecting Open from the pop-up menu.

[& SAS Enterprise Guide - Chapter1.egp
File Edt wiew Tasks Program  Tools  Help %'6'% S o= By [ X |5 o]~ gquru:essFluw -

Froject Tree » x Process Flow -
= g?.‘% Process Flaw = Run - Export = Schedule = | Zoom - Pm]ect Log Propetties +
=] Volcanoes a
List Data Froy
il Bar Chart o |_:
D_ Note = Open N
EE Tours 2y
= [ Programs Export D
El Frogram Filter and Sort...
Query Builder ...
Run Branch from Volcanoes
Server List X
— Publish. ..
& GES Send To »
el Link Volcanoes to. .,
=] Servers
Tﬂ Local My copy
545400 =
OLAP Servers Progid
Ehy Private OLAP Servers K| Delete
Renarne
Properties ~
< >

?& Connection: sasdemo, 127.0,0,1

Ready

Renaming and deleting items You can rename most items by right-clicking the item and
selecting Rename from the pop-up menu. You can delete an item in a project by right-clicking
and selecting Delete. Note that if you delete data from a project, only the shortcut to that data is
deleted, not the actual data file.

Saving a project To save a project, select File > Save project-name or File » Save project-
name As from the menu bar. Each project is saved as a single file and has a file extension of .egp.
You can save data, programs, and results in separate files by right-clicking the icon for that item
and selecting Export from the pop-up menu.
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Managing Process Flows

In SAS Enterprise Guide, you can have only one project open at a time. However, you can have
an unlimited number of process flows within a single project. So, if you have a complex project,
you may want to divide it into several process flows.

Adding new process flows Toadda
new process flow to a project, select File »
New » Process Flow from the menu bar, or
right-click the current process flow and
select New » Process Flow from the pop-
up menu. No matter how many process
flows you create, the Project Tree will show
all of them in a single tree diagram.

When you right-click a process flow, the
pop-up menu displays options for
customizing the appearance of that process
flow. Options include Grid, Layout, Auto
Arrange, Zoom, and Background Color.

To view a process flow, double-click its
name in the Project Tree, or click the down-
arrow (V) above the workspace to open a
pull-down list.

Process Flow -

[ Run -

Export = Schedule = | Zoom - @Project Lag

Mew

4 ‘ Data

_

Volcanoes

Program

v 5 Q|

[

[<l.[<]é

_-’lr]

Tours | 24

Open

Project

3 Program

4 Repart. ..

Run Process Flow

Schedule Process Flow

Create stored Process...

Stared Process. ..

(e el A

ote

ng Process Flow

[l Crdered List

Grid

Layouk

Auto Arrange
Zoam

Background Calar

Page Jetup
Print Preview

Prink

Properties

When you add a new process flow, it is named Process
Flow n. To give a process flow a more descriptive name,
right-click its name in the Project Tree and select Rename
from the pop-up menu. To delete a process flow, right-
click its name in the Project Tree and select Delete from

the pop-up menu.

Moving and copying items To move items from

one process flow to another, hold down the
(CTRL), and click all

control key

Project Tree

ful B
=-Eig Tour
Li
=~ Progr
# P
gqg Process B

R
= E‘i Wolcy

[ RunProcess Flow
Schedule Process Flow,,,

@ Create Stored Process...

B

> Delete

Rename I

Properties

VolcanoReports - ‘ TourReparts =
the items you Want tO b Rum - Export « Schedule = | Zoom - d [ Run = Export = Schedule = | Zoom = d
move. Then right- = had
. ' :
click, and select Move ' - Q __., -—><@
F (=]
- - Yl Bar Chart SAS R t
tO > process ﬂow il rr - Bar Ei‘;or Tours List Data 545 Report
- - List Da..
name from ’Fhe pop-up [:ﬁl the
menu. In this Pragram HCTIVE
example, three items
. (2]
are being moved to i
the process flow %
——* i
named TourReports. T |
-Lisgt Da.
P X Delete IS e < ¥




Chapter 1: SAS Enterprise Guide Basics 141

Copying items is similar to moving items except that you cannot copy results. Select the items to
be copied using control-click. Then right-click the items and select Copy from the pop-up menu,
and right-click the target process flow and select Paste.

YolcanoReporks -

B Run » [ Export = Schedule = Zoom - !
Qpen ]
Export »
Wolcg
%’f, Filter and Sort...
% Query Builder. ..
E Run Branch from Volcanoes
F: Publish. ..
Frog Send To »
‘ Link Yolcanoes to...
0 copy
5
X Delete
Rename
| v
< Properties -
VolcanoReports -
P Run = Export = Schedule » | Zoom = !
~
[l[l[l. @ 1
It _4; -_—
Yolcanoes "-‘ Bai Chart 545 Feport
5 -BarCha...
A
i
Program ACTIVE
EXTINCT
]
< |

& Print preview

&£ DMBMM o

- I

SAS Report
-Bar Cha...

B

Yolcahoss Bar Chart

Program ACTIME

EXTINCT

Linking items When you run a process flow, items are
executed from top left to bottom right, following the
branches created by links between items. You can add links
between items to show relationships that may not be clear,
or to force items to run in a particular order. For example, if
you create a format that is used by a task, you might want
to add a link indicating that the task follows the format. To
add a link, right-click the initial item and select Link item-
name to from the pop-up menu. A Link window will open
showing all the
other items to which
you can link. Select
the item to which
you want to link,
and click OK.

EF1ACTIVE [Valcanaes)
EXTINCT [Voleanoss)
E" Program [Volcanoes)

[ Ok H Cancel ]

In this process flow, the Volcanoes data icon has been linked
to a program icon to show that this program uses the
Volcanoes data table. Notice that when you add links they
use a dashed line instead of a solid line.

To delete a link that you previously added, right-click the

icon for that link ™ in the Project Tree and select Delete
from the pop-up menu.

Printing process flows You can print a
copy of your process flow. To control page
size and orientation, click the process flow
and select File » Page setup for Process Flow
from the menu bar. To preview a printout,
select File » Print preview for Process Flow.
To print the process flow, select File » Print
Process Flow. Here is the Print preview
window for the VolcanoReports process flow.

Q
=2
()
o
Sl
(o]
-
—



Chapter 1

142

1.5

The Little SAS Book for Enterprise Guide 4.2

Running and Rerunning Tasks

Running tasks is, of course, what SAS Enterprise Guide is all about. Regardless of which task
you choose to run, the basic steps are the same: open the task, select the data, and then run the

task.

Opening a task To
open a task, select it from
the Tasks menu, or click its
name in the Task List
window, or open a Data
Grid and then select the
task from the workspace
toolbar. The window for
that task will open. In this
example, the List Data task
is being selected in the
Task List window.

Selecting the data

table When you open a
task, it will use the data
table that is currently
active. If a Data Grid is
open, then that data table
will be active. You can also
make a data table active by
simply clicking its icon in
the Project Tree or Process
Flow before you open a
task.

After you open a task, you
can change the data table
by clicking the Edit button
in the Data page of the
task window. The Edit
Data and Filter window
(not shown) will open
where you can choose an
alternate data table for the
task. See section 5.1 for
details about the Edit Data
and Filter window.
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File ~ Edit View Tasks Program  Tools  Help

B-m- @G 8 @R X | o o[- -

Project Tree

> % Process Flow «

= feg Process Flow [ Run - Export - Schedule ~ | Zoom ~ | [53 Praject Log H
= ] Voleanoes
lial Bar Chart [
E @
1B List Drata I:il¥ ——" o
[ Mote
Bl Touws “Yolcanoes Ligt Data $AS Report
-List Da...
Task List % a Ilﬂ[! -—“ﬁ
— L% ||
I5GE e Bar Chat PDF -Bar
Hote Chart
‘ Tasks by Category - | a
Describy =
escn. e h
B List Dats k Tours
I Summary {List Data | vee wizard |
Summary Tables [use wizard |
[ List Report
B meione v, ~
4 > < 3
Ready \& Connection: sasdema, 127.0.0.1

[E List Data1 for C:\FAI Tours\DatakTours.sas7bdat

Data
Optiohs
Titles
Froperties Data source:  C:AFAI TourshD atahTours. sas7bdat
Task fiker:  Mone Lol k
Yariables to assign: Task roles:
Name [ List variables
Yoleano
% Departs @ Group analysis by
@ Days Page by [Limit: 1)
$¥ Fiice Tatal of
£ i {45 Subtotal of [Limit 1]
ey |dentifying label Sl @ el
< ¥
Enables wou to modify the input data source. By clicking Edit, vou can change the input data source or
create a filter for pour data.
e |

The “List warisbles" role must have at least 1 variable assigned ko it.
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Running a task Every task includes a Data page where you assign variables to task roles.
Using the selection pane on the left, you can open other pages. The preceding image shows the
List Data task, which has four pages: Data, Options, Titles, and Properties. When you are
satisfied with all the settings, click the Run button. If you have more than one SAS server, your
task will run on the same server where the data table is stored. If you decide you want to stop a

task while it’s running, select Program » Stop from the menu bar, or click the Stop button . on
the workspace toolbar above the Process Flow. When the task has finished running, the results
will be displayed in the workspace.

Rerunnlng a taSk [& SAS Enterprise Guide - Chapter1.egp

TO make Changes toa File Edit View Tasks Program  Tools  Hep |- - % & 3= B [ X -
task and run it again, N - x| ListDatal + x
first reopen the task B Elc;m;; ~ input Dot | ] Cocl | 2] Log] @ Fsels |
window. You can do L|:[Da?;t 9 Refresh | [x] Modify Task || Expart ~ SendTo + Create » Publish Properties
1 icki 1 [ Hate 3
this by Chckmg MOdlfy = Tours Fire and Ice Tours
Task on the workspace ) List Datat i
- Row number|Volcano Days| Price
toolbar for the Results 1[Etna 7 %1075
Task. List - i
tab. You can also Tt = Ll Il 7
. | EENE:) ey ’
reopen a task by right- | = 4[Kilavea =
1. 1( h k . . |Tasks by Category - 5| Kilimanjaro 9 %1,310
clicking the task icon in - 6 rakatau e
the Project Tree or Describe 7|Poas 1 %88
B ListData 8|Reventador 4] §575
Process FIOW, and I Summary Statistics [ use 9|5t Helens 4| §167
3 H - 10|"esuvius [ EE]
seleCtlng MOdlfy taSk Summary Tables [use wi
name from the pop-up ) List Feport Page Bresk
mendu. 2 Characterize Data s
£ >
Ready \Q Connection: sasdema, 127.0.0.1
Once the task window st Datal for C:\FAl Tours\Data\Tours.sas7bdat

is open, you can make
changes. Then click the Uplions

E | o

Titles

Run button tO rerun Properties Data source:  C:AFAI Tours\D atahTours. sasPhdat
the task. T
If yOu JUSt want to “arniables to assign, Task roles:
rerun a task without Name B (Lf_gt varables

. AVoleana “oloano
reopening t’he task oo @ Days
window, click Refresh @ Days - *Gé’ Fiice

%’ Piice roup anal_\fs\.s by
on the workspace A Difouly Page by (Limit 1)
) Total of

toolbar for the Results % subtotalof [Limit 1)
tab. You can also right- 8 dentiying label
click the task icon in
the Project Tree or
Process Flow, and

select Run from the
pop-up menu.

Runs the tagk with the options that you have selected.

ey o [ oo ][
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Creating and Exporting Task Templates

Even with the simplest tasks, there are many ways to customize your results. Once you have
spent a lot of time changing titles, choosing options, and specifying a style; you might wish you
could save all those settings and use them to create new results. With task templates, you can.

Task templates allow you to save tasks in a form that is independent of data. In other words, task
templates save all your settings except the assignment of variables to task roles and certain data-
dependent options. Most tasks can create templates, but a few of the more data-driven tasks
(including Summary Tables and Append Table) cannot. SAS programmers will be interested to
know that task templates are unrelated to the various kinds of templates created by the Output
Delivery System.

Creating a task template To destlenpiale Mans X
create a task template from a task L tew o X . g et
that you have already run, select Ham Basedon Task Dessripion
Tasks » Task Templates » Task
Template Manager from the menu
bar. This opens the Task Template
Manager. Click New to open the
New Task Template window.
B New Task Template
Mame: Close ] [ Help
|FAIT Lizt Data report |
Description:
List Diate wih titles, etc: In the New Task Template window, type a name for the
new template in the Name box. You can type an optional
Bl o fEmiEss description in the Description box if you wish. The area
Bat Chart labeled Create template from task lists all the tasks

] List Data

currently in the project. Choose a task by clicking its name.
Then click Create. The new task template will be listed in
the Task Template Manager. Click Close.

You can also create task templates directly from tasks. If the
task window is open, then you can click the down-arrow
(V) on the Run button, and select Create Template from the
pull-down list.

Create in group: To delete a task template, simply open the Task Template
Manager, click the task template name, and click Delete.

Task ternplates v |

Create] J;
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Using a task template Once you create a task template, unless you delete it, it will be
available to you every time you open SAS Enterprise Guide. There are two ways to open a task
template. You can select Tasks » Task Templates » task-template-name from the menu bar, or
you can open the Task List window, select Task Templates from the drop-down list, and click the
name of your task template.

By default, when you open a task template, it uses the active data table. After you open a task
template, you can choose a different data table by clicking the Edit button in the Data page.

[E& SAS Enterprise Guide - Chapter1.egp

File  Edit  Wiew | Tasks | Program Tools  Help l‘% = E" ’% 5 e By (@ X
Project Tree Data 4
=] s@ Pracess Flow Besuite ' Export = Schedule = | Zoom - Prnjact Log Propertizs -
= EEE Yolcanoes Graph 3 ~
Jall Bar Ch {@
L?nk o AMOVA 3 —b— e —
List Daf Regression 3 X
B Tous List Data 545 Report
Da Mote TMultivariate 3 \» - List Da..
Survival Analysis 3 I].ll[l. @
ke
Capability 3
Task List Bar Chart FOF - Bar
_ Control Charts 3 Chart
|@|Eﬁ 2] i Pareto Chart...
Task Templates Time Serics >
FAIT List Data ref 23| Modsl Scoring...
Ligt D ata vaith b EF N
| Task Templates 4 ‘ Task Template Manager. ..
FAIT List Datareport.. | &
£ il | ¥
Ready 5& Connection: sasdema, 127.0.0.1

Exporting a task template When you create a task template, it will be saved in a default
location. This location is associated with your Windows user account. To share task templates with
other people (including anyone who uses the same computer, but a different Windows account),
you must export the templates. To

do this, open the Task Template Task Template Manager [‘5__<|
Manager, and click Export. SAS e ~ X N 1 Inport Export

Enterprlse Guide will prompt you to M ame Bazed on Task D escription "

select the templates you wish to FAIT List Data report List D ata List D ata with litles, etc.

export, and to specify a location for
saving them.

To import task templates, open the
Task Template Manager and click
Import. Then navigate to the
location of the task templates you Cose | [ Hebp
wish to import.
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SAS Data Tables

SAS Enterprise Guide can read and write many kinds of data files (see Chapter 2 for more on this
topic), but for most purposes, you will want to have your data in a special form called a SAS data
table. When you open a SAS data table, it is displayed in the workspace in a Data Grid. The
following Data Grid shows the Tours data table that was created in Tutorial A. A new tour has
been added for the volcano Lassen.

Data Table Columns
(also called a Data Set) (also called Variables)
@ ancaml@;\ Depalls@ Daj,l=;|$€¥ Pricel@} Difficul}l|
1 |[Elna Catania 7 1075 m
2 |Fui Takyo 2 g5
3 | Kenya t airobi E 830 m
4 |Kilauea Hilo 1 $55 &
Rows B |Kiimanjaro Nairobi 3 0.
(also called Observations) B |Krskatay  Jakarta 7 1995 -
7 [Lassen Sacramento 3 .
B_ Poas SahJosze 1 JE5: &
‘9 |Reventador  Quito 4 $575 m
10 | St Helens Portland 2 167 e
E Wil Rome E 335 =

Terminology In SAS Enterprise Guide, rows are also called observations, columns are also
called variables, and data tables are also called data sets. SAS Enterprise Guide uses all these
terms. Some tasks use the term columns and others refer to variables, depending on the context.

Data types and data groups In SAS Enterprise Guide, there are two basic types of data:
numeric and character. Numeric data are divided into four data groups: numeric, currency, time, and
date. For each of these, SAS Enterprise Guide has special tools: informats for reading that type of data,
functions for manipulating that type of data, and formats for displaying that type of data. SAS
Enterprise Guide uses a different icon to identify each kind of data.

Character data may contain numerals, letters, or special characters (such as $ and !) and
@ can be up to 32,767 characters long. Character data are represented by a red pyramid
with the letter A on it.

Currency data are numeric values for money and are represented by a picture of the
dollar, euro, and yen symbols.

EI Date data are numeric values equal to the number of days since January 1, 1960. The
table below lists four dates, and their corresponding SAS date and formatted values:

Date SAS date value MMDDYY10. formatted value
January 1, 1959 -365 01/01/1959
January 1, 1960 0 01/01/1960
January 1, 1961 366 01/01/1961

January 1, 2010 18263 01/01/2010
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You will rarely see unformatted SAS date values in SAS Enterprise Guide. However,
because dates are numeric, you can use them in arithmetic expressions to find, for
example, the number of days between two dates. Datetime values are included in this
data group, and are the number of seconds since January 1, 1960. Date data are
represented by a picture of a calendar.

Time data are numeric values equal to the number of seconds since midnight. Time data
are represented by a picture of a clock.

Other numeric data, that are not dates, times, or currency, are simply called numeric.

@ They may contain numerals, decimal places (.), plus signs (+), minus signs (-), and E for
scientific notation. Numeric data are represented by a blue ball with the numbers 1, 2,
and 3 on it.

Numeric versus character If the values of a column contain letters or special characters,
they must be character data. However, if the values contain only numerals, then they may be either
numeric or character. You should base your decision on how you will use the data. Sometimes data
that consist solely of numerals make more sense as character data than as numeric. Zip codes, for
example, are made up of numerals, but it just doesn’t make sense to add or subtract zip codes. Such
values work better as character data.

Column names Column names in SAS Enterprise Guide may be up to 32 characters in length,
and can begin with or contain any character, including blanks.

Moving data between SAS Enterprise Guide and Base SAS Any data created in
SAS Enterprise Guide can be used in Base SAS, but the default rules for naming variables are
different. Base SAS uses the VALIDVARNAME=V7 SAS system option, while SAS Enterprise
Guide uses VALIDVARNAME=ANY. For the sake of compatibility, you may want to follow these
rules when naming columns: choose column names that are 32 characters or fewer in length, start
with a letter or underscore, and contain only letters, numerals, and underscores.

Missing data Sometimes, despite your best efforts, your data may be incomplete. The value of
a particular column may be missing for some rows. In those cases, missing character data are
represented by blanks, and missing numeric data are represented by a single period (.). In the
preceding Data Grid, the value of Price is missing for the tour of Lassen, and its place is marked by
a period. The value of Difficulty is missing for the same tour and is left blank.

Documentation stored in SAS data tables In addition to your actual data, SAS data
tables contain information about the data table, such as its name, the date that you created it, and
the version of SAS you used to create it. SAS also stores information about each column in the data
table, including its name, type, and length. This information is sometimes called the descriptor
portion of the data table, and it makes SAS data tables self-documenting. This information is what
you see in the Properties windows for data tables and columns. These Properties windows are
described in more detail in the next two sections.
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Properties of Data Tables

Someday you may be given a SAS Enterprise Guide project that was created by someone else. If
you are unsure what the project does, then it would be a good idea to start by checking the
properties of the data tables.

Opening the Properties window To display information about a data table, first open it
in a Data Grid by double-clicking the data icon in the Project Tree or Process Flow. Then click the

v
Properties icon . on the workspace toolbar to open the table Properties window.

{& SAS Enterprise Guide - Chapter1.egp

File  Edit ‘“iew Tasks Program  Tools  Help @' ﬁ' % 5 2 By (B X | B & (- gqurocess Flow -
Project Tree + x Wolcanoes - 4
= gq% Process Flow %Filter and Sork %Query Builder | Data = Describe = Graph = Analyze - | Export + Send To -
= EE ﬁlc;;o;;an @ Yolcano |@ Country |@ Region @ Height |@ Activily |@ Typ ~
List Data |1 | Abkar Ecuadar S, 5321 Extinct Stratovolcano{jpmperties
D' Mate | Arthur's Seat LK, Eu 251 Extinct
Eid Tours |3 [Bamen lsland India Ag 354 Active Shratovolcano
4 |Elbrus Russia Eu 5633 Extinct Stratovolcano
E Erebus An 3794 Active Stratovolcano
6 |Etna Italy Eu 3350 Active Stratovolcana
?_ Fuii Japan Az AFTE Active Stratovolcano
Server List Tx 8_ Garibaldi Canada MA, 2678 Stratovalcano
) El_i||@ E Grimavotn lceland Eu 1725 Active Caldera
— |10 | llimari Buolivia S& 6458 Extinct Stratovolcano
5 7 21 |Kenys Kenya af 5193 Etinct
Servers E Kilauea LSa AP 1222 Active Shield
[y OL&P Servers |13 | Kiimanjara Tanzaria Af 5835 Stratovolcano
Eb Private OLAP Servers |14 | Kliucheyskoi Russia As 4835 Active Stratovolcano
|15 | Krakatau Indonesia Az 813 Active Caldera
16 |Laszen USa M 3187 Active Stratovolcano
[17 |MaunaLoa LSa AP 4170 Active Shield
W Myarmuragira DRCongo Af 3058 Active Shield
W Myiragongo DRCongo Af 3470 Active Stratovolcano
E Finatubo Fhilippines As 1486 Active Stratovolcano
|21 |Poas Costa Rica M 2708 Active Shratovolcano e
an | D L, L kd i bl EADC by oot L
Ready 5& Connection: sasdemo, 127.0.0.1

You can also right-click a data icon in the Project Tree or Process Flow, and select Properties from
the pop-up menu.
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Gel‘leral page #¥ Properties for, Volcanoes El =

When the table B . | eona

Properties window ek d[%

opens, it displays the Summany

General page. The ﬂ% oleanses |

General page lists basic

. a File properties

information about the

table: its name, when it File name | E:4FA Tours\D ataWoleanoes.sas7heat | [ changs...
Created Salurday, Febiuary 25, 2008 3:32 PM

was created and last o sy ey
Last modified: Tuesday, August 11, 2009 3:37 PM

modified, and whether
it is a SAS data table or B SAS Data Set
some other type of file. Label:

The selection pane enables you to select a category of options to view

tdore [F1)...

&% Properties for Volcanoes E| COlumnS page If
- you click Columns in
fi Columns A
Lo the selection pane on
Advanced
Summary MName Type Length  Format Informat Label the left, the COlumI‘lS

Yolcano Character 15 $15. $15. Yolcano .

Courntry Character 13 $13 $13 Country page will open. Here,

Region Character 2 32 32 Reqion . .

Height Numeric 9 b F5. Height SAS Enterprise Guide

Activity Character 10 8 $8. Activity . . .

Type Cheracter 15§13 #13 Type displays information
about each column: its
name, type, length,
format, informat, and
label. You cannot
change the properties
of columns in the
Properties window for
a data table. To make
changes, use the
Properties window for
an individual column

The selech bl to select e f options . .

e selechon pane enables you to select a category of ophions [0 view, as descrlbed ln the
ol next section.
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Properties of Columns

The column Properties window displays properties for an individual column. You can use this
window inside a task to change labels and display formats, but those changes will apply only to
the results of that task rather than the original data table. However, if you open the column
Properties window inside a Data Grid, then any changes you make will be saved with the data
table.

Setting the update mode The Data Grid opens in read-only mode. In this mode you
cannot edit the data, and you cannot change column properties. To switch to update mode, select
Edit » Protect Data from the menu bar. This toggles the data table from read-only to update
mode. To return to

read—only mode, fE SAS Enterprise Guide - Chapter1.egp : E”E|E|
. File Edit ¥ Tasks P Totls  Help | Ev (S | -
select Edit » Protect le  JEd e Teste pogan, Tock e ) o i @ B Bu B 2|0 0| O] 5
. - ol - x
Data agaln. Froject Tree x dlcannes
El g‘ﬁ&'}”‘:e“ Flow 3 Filter and Sort B Query Builder | Data - Describe - Graph + Analyze -
=-fr VYolcanoes S ——
Opening the Wl Bar Chatt I/ Volcano |@ Dnunlly|® Region(zll Heigh at ‘ ﬂ L5
¢ % Link to Frogram | |1 |Alar Ecuador 54 B oy a0
Properties T8 Lt Date (2 |Autur's Seat UK Eu | Paste
. E Tours |2 |Bamenlsland - India Az ano
window To open [ Mote (4 |[Eibrs Russia Eu Hide ano
5 |Ersbug An a0
the column &1 ;
|6 |Etna Italy Eu Hold ano
Properties window, Task List - x |7 |Fui Japan A ano
. . — 8 | Gaibaldi Canada NA et a0
rlght_Cth the | @l ETi @ E Grimavotn leeland Eu Ines:rtECqumn |
header of a column [ Tasks by Catsgary ~ | |10 limani Bolva ... eno
|11 | Kenpa Kenpa Af width, .
and select Data ~ 1z [Kiauea USh AP |
I’roperties from the £ Fiter and Sart |13 | Kilmanjara Tanzania  Af atovolcano
% 1 Build |14 | Kluchevskol Russia Az Active Stratovolcano
pop-up menu. In L S [15 |KiskatouIndonesia As botive Caldera
this Data Grid [ append Table |16 |Laszen USh Ha Active Stratovoleano
. . 4 . EE Sert Nats ¥| |17 [Maunsloa - USA AP Active Shield
Propertles 1S bemg < > |18 |Mpamuagia  DRCongn  AF Aclive Shield 3
selected for the Ready W Connection: sasdema, 127.0,0.1
column Height.

General page The Properties ¥ Properties B

window has several pages. If there is no

1 G |
selection pane on the left, then the data o General
table is in read-only mode and you Informats

Conlfirn Options Name: ‘He|gthEt8rS |

The G ) disol b Label:  Height in Meters | @

e General page displays basic

information fIZ)rgéhe ccﬁur}r’m: its name, Toee Lenaih{i by
label, type, group, and length. You can Group

change any of these properties. In this
example, the column name has been
changed to HeightMeters, and the label
to Height in Meters. This column is
numeric and has a length of 8.

need to switch to update mode.

Maore [F1]

Ok ] [ Cancel
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Informats page Click Informats in the ; e =

. 8 Properties r__lrngl

selection pane on the left to open the

Informats page. Informats (also called input pener Informats

formats or read-in formats) tell SAS Infomnats Categers —

Confirm Options ategaries: hformats:

Enterprise Guide how to interpret input Nore ~ | [GMFSTAMPw. 3

. . Mumeric TODSTAMPY
data. There are different informats for Date TRAILS G,
. . T
character, numeric, date, time, and currency DaterTine UNKEPOCH.d
N Currency WhASZ M d
data. In this example, the column uses the User Defined | X
default numeric informat, w.d, with a width Attibutes
of 6 and no decimal places. This informat Dveral vt B glMind a2
. . o} | places: _U 5| Min 0 Max 5
can be written as 6.0. See the next section Femepes e

Description
standard numeric; format

for a table of commonly used informats.

In SAS Enterprise Guide 4.2, you can use Example
: : . Input:
informats when you import data files, and Vaue 123

when you write SAS programs. However,
informats are not used when you type data

Specify how many characters will be displayed in the colurn,

. . Moare [F1]..
values into a Data Grid. Instead, the Data =
. oK Ci |
Grid uses the data type and data group that J [ Comee
you specify to determine how to interpret
any data values you enter.
B Properties @[=Ed] Formats page Click Formats in the
selection pane on the left to open the
General Formats .
Fomats Formats page. Formats (also called display
I l . .
Confim Oplions | Categoes: — formats) tell SAS Enterprise Guide how data
Namere “ | BEerns 4/ | should look in Data Grids or reports. There
Dete %ﬁm_F are different formats for character, numeric,
pate/Tine EDHbA.d date, time, and currency data. In this
v v .
Dser Defined ERSPOAD.. example, the format COMMAw.d with a
Attributes s s
e i it o 32 width of 6 a'nd no decimal plaC('es has been
Decinal places: e [ selected. This format can be written as
. COMMAG.0. See section 1.11 for a table of
sammas in rubrs commonly used formats.
Erample
Walug: 123451
Output — [TT2]. T3T45]
Select the name of the format or infarmat that you want ta use. When
you select a format or informat, a description of the format or informat
appears in the Description bos. More (F1)...
oK ] [ Cancel ]

|@,\. Yolcamo |@ Countr}l|.é"\}. Hegmn@ ngtheth\} Actwll}l|@ Type | Results Here is the Data

1 |[Alar Ecuador 5,321 Extinct Stratavolcana . .

2 |Atthur's Seat LK Eu 251 Estinct Grl.d showmg the new name,
3 |Bamenldand India Az 354 Active Stratovolcano HelghtMeters, and the

4 |Elbnus Fussia Eu 5,633 Eslinct Statovolcann  format with commas.

5 |Ercbus An 3,794 Active Stratovolcano

£ |Ftna Italn Fu IR Artive Chrabevsnleann
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1.10 Selected Informats

SAS informats (also called input formats or read-in formats) tell SAS Enterprise Guide how to
interpret input data. You can specify informats when you import data, in a SAS program, or in a
Data Grid. However, in SAS Enterprise Guide 4.2, informats are not used to interpret data that you
type into a Data Grid. Here are a few of the many informats available in SAS Enterprise Guide.

Informat Definition Width range | Default width
Character

$w. Reads character data—trims leading blanks 1-32,767 none
$UPCASEw. Converts character data to uppercase 1-32,767 8

Date, Time, and Datetime’

ANYDTDTEw. | Reads dates in any form—when dates are 5-32 9
ambiguous, uses the DATESTYLE system
option to determine

DATEw. Reads dates in the form: ddmonyy or 7-32 7
ddmonyyyy

DATETIMEw. | Reads datetime values in the form: 13-40 18
ddmonyy hh:mm:ss.ss

DDMMYYw. Reads dates in the form: ddmmyy or 6-32 6
ddmmyyyy

JULIANw. Reads Julian dates in the form: yyddd or 5-32 5
yyyyddd

MMDDYYw. Reads dates in the form: mmddyy or 6-32 6
mmddyyyy

TIMEw. Reads time in the form: hh:mm:ss.ss 5-32 8
(hours:minutes:seconds—24-hour clock)

Numeric

w.d Reads standard numeric data 1-32 none

COMMAw.d Removes embedded commas and $, 1-32 1
converts left parentheses to minus sign

PERCENTw. Converts percentages to proportions 1-32 6

' SAS date values are the number of days since January 1, 1960. Time values are the number of seconds past midnight, and
datetime values are the number of seconds past midnight on January 1, 1960.
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The examples below show input data and resulting data values for each informat. The results
shown are unformatted data values. See sections 3.1 and 3.2 for information about assigning

153

display formats.

Informat Input data Results Input data Results

Character

$10. Lassen Lassen St. Helens St. Helens

$UPCASE10. Lassen LASSEN St. Helens ST. HELENS

Date, Time, and Datetime

ANYDTDTE10. | 01jan1961 366 31.01.1961 396
1961001 366 01/31/61 396

DATE9. 1janl961 366 31 jan 61 396

DATETIME14. 1janl1960 10:30 37800 1janl961 10:30 31660200

DDMMYY10. 01.01.1961 366 31/01/61 396

JULIAN?. 1961001 366 61031 396

MMDDYY10. 01-01-1961 366 01/31/61 396

TIMES. 10:30 37800 10:30:15 37815

Numeric

5.1 1234 123.4 -12.3 -12.3

COMMA10.0 $1,000,001 1000001 (1,234) -1234

PERCENTS5. 5% 0.05 (20%) -0.2
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1.1+ Selected Standard Formats

SAS formats (also called display formats) tell SAS Enterprise Guide how to display or print data.
You can apply formats in a column Properties window in a Data Grid, a task, or a query. Here are a
few of the many formats available in SAS Enterprise Guide.

Format | Definition Width range | Default width

Character

$UPCASEw. Converts character data to uppercase 1-32767 Length of variable or 8

$w. Writes standard character data—default for 1-32767 Length of variable
character data orl

Date, Time, and Datetime!

DATEw. Writes SAS date values in form ddmonyy or 5-11 7
ddmonyyyy

DATETIMEw.d | Writes SAS datetime values in form 7-40 16
ddmmmyy:hh:mm:ss.ss

DTDATEw. Writes SAS datetime values in form ddmonyy 5-9 7
or ddmonyyyy

EURDFDDw. Writes SAS date values in form dd.mm.yy or 2-10 8
dd.mm.yyyy

JULIANw. Writes SAS date values in Julian date form 5-7 5
yyddd or yyyyddd

MMDDYYw. Writes SAS date values in form mm/dd/yy or 2-10 8
mm/dd/yyyy—default for dates

TIMEw.d Writes SAS time values in form hh:mm:ss.ss— | 2-20 8
default for times

WEEKDATEw. Writes SAS date values in form 3-37 29
day-of-week, month-name dd, yy or yyyy

WORDDATEw. | Writes SAS date values in form 3-32 18
month-name dd, yyyy

Numeric

BESTw. SAS System chooses best format—default 1-32 12
format for numeric data

COMMAw.d Writes numbers with commas 2-32 6

DOLLARw.d Writes numbers with a leading $ and commas 2-32 6
separating every three digits—default for
currency

Ew. Writes numbers in scientific notation 7-32 12

EUROXw.d Writes numbers with a leading € and periods | 2-32 6
separating every three digits

PERCENTw.d Writes numeric data as percentages 4-32 6

w.d Writes standard numeric data 1-32 none

' SAS date values are the number of days since January 1, 1960. Time values are the number of seconds past midnight, and
datetime values are the number of seconds past midnight on January 1, 1960.
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The examples below show unformatted data values and formatted results for each display format.

Format Data value | Results Data value Results
Character

$UPCASE10. Lassen LASSEN St. Helens ST. HELENS
$6. Lassen Lassen St. Helens St. He

Date, Time, and Datetime

DATE9. 366 01JAN1961 396 31JAN1961
DATETIME16. 37800 01JAN60:10:30 2629800 31JAN60:10:30
DTDATE?9. 37800 01JAN1960 2629800 31JAN1960
EURDFDD10. 366 01.01.1961 396 31.01.1961
JULIANY?. 366 1961001 396 1961031
MMDDYY10. 366 01/01/1961 396 01/31/1961
TIMES. 37800 10:30:00 37815 10:30:15
WEEKDATE15. | 366 Sun, Jan 1, 61 396 Tue, Jan 31, 61
WORDDATE12. | 366 Jan 1, 1961 396 Jan 31, 1961
Numeric

BEST10. 1000001 1000001 -12.34 -12.34
BESTS6. 1000001 1E6 100001 100001
COMMA12.2 1000001 1,000,001.00 -12.34 -12.34
DOLLAR13.2 1000001 $1,000,001.00 -12.34 $-12.34

E10. 1000001 1.000E+06 -12.34 -1.234E+01
EUROX13.2 1000001 €1.000.001,00 -12.34 €-12,34
PERCENT9.2 0.05 5.00% -1.20 (120.00%)
10.2 1000001 1000001.00 -12.34 -12.34
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Scheduling Projects to Run at Specific Times

Sometimes you may want to create a project now, but run it later. For example, if you have data
files that are updated on a regular basis, you might want to automatically rerun the project once
a week using the new data. Or, if your data files are very large, you might want to run your
projects at night so that SAS Enterprise Guide is not using valuable resources during work

hours.

Opening the Schedule window You
can schedule a complete project or just a process
flow. To schedule a project, select File »
Schedule project-name from the menu bar. To
schedule a process flow, right-click the name of
the process flow in the Project Tree and select
Schedule process-flow-name from the pop-up
menu. This opens the Microsoft Windows Task
Scheduler with the Task tab on top. When you
schedule a project, SAS Enterprise Guide creates
a script that is saved in a file on your computer.
The name and path of this script is displayed in
the Run box. The Start in box displays the
folder in which the script will run. Your
computer and user name are displayed in the
Run as box.

If you will not be logged on at the time the

project runs, then make sure the box next to

Run only if logged on is unchecked, and click

the Set password button to open the Set Password
window. Enter the password for your user

name (the same password you use when you log
on to your computer), and click OK.

Set Password

LLll 11l
Passward: | |

Confirm pazzword: |..0000| |

by
Lo |

Cancel ]

Setting the run frequency To tell SAS
Enterprise Guide when to run the project, click
the Schedule tab. Click the New button. Then
select the frequency to run the project from the
drop-down list under Schedule Task. You can
schedule your project to run just once at a
specified time as shown here, or you can
schedule your project to run on a regular basis.

Schedule - TourSalesProject

Task |Schedule Settings

ﬁ CwWINDOWSAT azkshSchedule - TowrS dlesProject. job

Rur: |"C:\FAI ToursYProjectsh\EGScript] . vbs" ‘
Stark in: |"C:\FAI TourshProjects” ‘
Comments:

Fiun as: BEUAUTHOR sasdema | [ 58 P %J

[ Run arly it lngged on
Enabled [scheduled tagk runs at specified time]

Schedule - TourSalesProject E|E‘
Task | Schedule |Settings
[1. 4£2:00 &M on 8/17/2009 ~|

Schedule Task: Stak time:

Once v || so0am 2| [[advanced .

Draily

weekly

Ianthl

m [ Mondsy . Augist 17,2003 v
At Spstem Startup

At Lagon

‘when idle

Shaw multipls schedules.
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Setting the date and time To set the

Schedule - TourSalesProject

time the project will start running, click the
up and down arrows on the Start time box, or Task | Sehedule | Setiings
simply click the time and type a new. value. 1. A1200 AM an B/18/2003 3
To choose a date other than today, click the = | (oo ]
down-arrow in the Run on box and select a = ==
date from the pull-down calendar.
Schedule Task: Start time:
Other settings If you click the Settings loce S [r200an ] [chenced. ]
tab, you will see other options, including the Schedule Task Once
maximum length of time a project will be Run an; [ Tuesday . August 18,2009 ﬂ
allowed to run, and whether it will run if
your computer has gone into sleep mode. e Mon Tue wred Tho Fiioa
-
When you are satisfied with all the settings, 2 3 4 5 6 7 8
. . 3 10 11 12 13 14 15
click OK to schedule the project. 16 9 0 2 2
23 2 Bl 27 o 2
. . . . 0
Running the project The project will Show muliple schedules. Today: 8/17/2009
not run if it is open or if the computer is
turned off at the time the project is scheduled [ ok ][ cancel |
to run. However, if you have a different
project open, the scheduled project will still run.
VleWIHg the [& Properties for TourSalesProject El
results To see the )
results of your Sty S
scheduled run, open Praject Log
the project after lt has Metadala Label: TowSalesProject
Completed ru'nnlng If Created: 8/17/2009 7:14:51 P
you are not sure
whether a project ran Last modified: 8/18/2009 12:00:43 AM, using version 4.2.0.9016
You can Confirm thlS Madified by: SAS Demo User [sasdema)
by opening the _
Properties WmeW fOI' File name: C:4Fal TourshProjectshT ourS alesProject eqp
that project To open Location: My Computer
the Properties
window for a project,
select File » Project
Properties from the
menu bar. The Last
modified field shows
the date and time that Horel IS

the project last ran. oK | [ Cancdd |
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1.18 Editing SAS Programs Generated by a Task

If you are a SAS programmer, you may want to make a few changes to the programs generated
by SAS Enterprise Guide. There is more than one way to do this. You can insert your own SAS

code into the program associated with a task, or you can save the code generated by a task in a

separate file which you can then edit and run.

Previewing code
generated by a task

Many task windows
have a Preview code
button in the lower-left
corner. If you click this
button, SAS Enterprise
Guide will open a Code
Preview window
displaying the code that
SAS Enterprise Guide
has written for that task.

[E List Data for C:\FAI Tours\Data\Tours.sas Thdat El
Data
Options
Titles
Froperties Data source:  C:ARA| TowrshData\Tours. sas?bdat
Task fiter.  Mone
“Yariables to assign, Task roles,
P i
olzano
@ Departs % Diifficulty
Days
@ Days 55* Price
sg" Price
@ Difficull @ Group analysis by
¥ @ Page by [Lirmit: 1]
Total of
{85 subtatal of (Limit: 1)
185 Identitying label
Enables pou ta preview the code that is generated automatically when pou wn a task. when pou
preview your task code, pou can insert your own code into the automatically generated code.

Fiun 'I [ Save ] I Cancel l [ Help
Code Preview for Task @ Inserting COde in a
task Here is a Code
TITIEL "B R — —| Preview window fora
FOOTHOTE _1re an ce tourst, List Data task. You can
! see that it uses PROC
ZPROC PRINT DATA=WORK.SORTTempTableSorted PRINT. If you want to
add code to the task,

LABEL

E

BUH,; QUIT.,

OBS="Tour Humber"

VAR Volcano Difficulty Days Price;

click the Insert Code
button. This opens a User
Code window. You
cannot edit the existing
code generated by a task,
but the User Code
window allows you to

v (| add code at specific
> points in the program.
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In the User Code window, - (T L ER —
. . ser Code E
double-click <double-click e e
to insert code> at the pOil’lt Fozitions where user code may be ingerted are indicated by the icons. Double-click on a marked line
i to add uger code or change exigting uger code.

where you wish to add your

own custom code. An Enter B2, <dovble-click fo insert code> »

User Code window will

T h d FROC PRINT DATA=%WORK.SORTTempT ableSorted
open. ype the custom code OBS =T our Murnber™
you wish to add. When you LABEL

are done, click OK. Your
new code will appear in the
User Code window. Click
OK in the User Code < 5
window. When you run the

task, SAS Enterprise Guide Lok J[ Coneel J[ Hep |

will run the code you

B < double-click to inseit code>

inserted along with Enter User Code
the code generated by the task. STYLEHEADER = {BACKGROUND = BLACK oF.
FOREGROUND =WHITE}

Cancel

Editing code generated by a task If you want to be able to edit the entire program
generated by a task, or code from tasks that do not have a Preview code button, you can make a
copy of the program, and then edit it. To do this, run the task, and then right-click the task icon
in the Project Tree or Process Flow, and select Add As Code Template. SAS Enterprise Guide
will open a Program window containing the code generated by the task.

You can edit this cod? inany way coge ror st ats ~ x
you wish. Because this code is a P
4 Program
copy of the code generated by the | ”
| Save + |+ Run -~ Select Server | Export = Send To » Create -
task, any changes you make here =
will not affect the task, nor will TITLElL "Fire and Ice Tours"; ~
any changes you make to the task FOOTHOTE ;
be reflected in this code.
ZPROC PRINT DATA=WORK.SORTTempTableSorted
When you have made all the OBS="Tour Humber" LABEL
changes you wish and are ready STYLE (HEADER) =
to run the program, click Run on {BACKGROUND = BLACK
the workspace toolbar for the FOREGROUND = WHITE},
Program window. Your program VAR Volcano Difficulty Days Price;
. RUN;
will run on the server that has T
been set as your default. To >
. . < >
choose a different server, click

Select Server. If you decide you want to stop a program while it’s running, click the Stop

button . on the workspace toolbar for the Program window. You can also use the Program
menu on the menu bar to control execution of your program.

Programs created in this way are embedded in your project, and are not saved as separate files.
For more information on embedding programs, see the next section.
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1.14 Writing and Running Custom SAS Programs

You can accomplish a lot using tasks in SAS Enterprise Guide, but sometimes you may need to
do something for which there is no predefined task. At those times, you can run a SAS program
that was written outside SAS Enterprise Guide, or you can write a new one.

Writing a new SAS

program To create a new SAS
program, open an empty
Program window by selecting
File » New » Program from the
menu bar. A Program window
will open in the workspace. The
program editor in SAS Enterprise
Guide is syntax-sensitive, which
means that SAS keywords are
displayed in blue, comments are
green, quoted strings are
magenta, and so forth.

Opening an existing SAS
program If you have existing

3:1 Frogram
[ save ~ b Run ~

Select Server | Export » Send To » Create - Properties

<

* Add new data to Tours data table;

- IDATA HewData;
INPUT Volcano :512. Departs :512. Days

Price Difficulty §;

DATALINES ;

Etna . . 1225

Lassen Sacramento 3 250 m

- DATA HewTours,
UPDATE 'C:\FAI Tours‘\Data\Tours' HewData,
BY Volcano;

-IPEOC PEINT DATA = HewTours;
TITLEl 'Updated Tours Price List';

RUN ;

b3

SAS programs that you want to include in your project, you can open them by selecting File »
Open » Program from the menu bar. Navigate to the existing SAS program and click Open. This
opens a Program window in the workspace, where you can edit the program.

Saving a program in a
file Any new programs you
write are automatically
embedded in your project. This
means that the program’s code
does not exist in a file outside of
the project. To save a SAS
program outside its project, click
Save on the workspace toolbar
for the Program window, or
right-click the program icon in
the Project Tree or Process Flow
and select Save program-name
As from the pop-up menu. You
can also save a program from the
Properties for program-name
window. To view the properties
of a program, click Properties on
the workspace toolbar for the
Program window, or right-click
the program icon in the Project
Tree or Process Flow and select

Results
Prompts
Summary

E4 Properties for Program

General

Label:

Program

Code will run on server:

Local v
Last Execution Time:

Urknowan

File path:

[Embedded In Project)

Location: Project

Saves the code to the location that you specify.

tare [F1]...

[ ar ] [ Cancel ]

Properties from the pop-up menu. Then in the General page, click Save As. If you save the
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program in a file, then it is not embedded, and any changes you make to it in SAS Enterprise Guide
will be saved in the file rather than as part of your project. The icon for a program saved in a file
includes a little arrow indicating that the project contains a shortcut to the program rather than

the actual program Iﬁ

Embedding a program in
a project When you opena
SAS program that has been
saved in a separate file, it is not
automatically embedded in your
project. If you want to embed
the program in your project,
then open the Properties
window for the program and
click Embed. After you embed
the program, any changes you
make to it in SAS Enterprise
Guide will be saved as part of
your project rather than in the
separate file. The icon for
embedded code looks like

this @

Running your program
When you are ready to run your
program, click Run on the
workspace toolbar for the
Program window. Your program
will run on the server that has
been set as your default. To
choose a different server, click
Select Server. If you decide you
want to stop a program while it’s
running, click the Stop button .
on the workspace toolbar for the
Program window. You can also
use the Program menu on the
main menu bar to control your
program.

£ Properties for UpdateTours EI
General
Results
Prompts
Summary
Label
UpdateT ours

Cade will run on server:

Local v
Last Execution Time

Urknown

File path:

C:AFal Tours\S4S Programs\UpdateT ours.zas

Locatior: Local

Embed %J [ Save fs...

Embeds the code in the SAS Enterprise Guide project so that any changes that you
make to the code in SAS Enterprise Guide are nat applied ta the original code file. This

e - A 5 A S————— -
option iz available only for existing code files that you have inzerted into erora 7.

Ok ] [ Cancel

}l Program

Save - Select Server | Export = SendTo = Create - Properties

* Add new data to Tours data table;
-IDATA HewData;
INPUT Volcano :$12. Departs :512. Days
Price Difficulty §;
DATALINES ;
Etna . . 1225
Lassen Sacramento 3 250 m

-IDATA HewTours,
UPDATE 'C:\FAI Tours‘\Data\Tours' HewData,
BY Volcano;
=IPROC PEINT DATA = HewTours;
TITLEl 'Updated Tours Price List';
RUN ;
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1.15 Viewing Program and Project Logs

A SAS log is a record of what SAS did. Just about everything you do in SAS Enterprise Guide
generates a SAS log. Logs contain the actual code that SAS ran, plus any error messages,
warnings, or notes.

Different types of logs A program log is the log that is generated when you run a SAS
program. Tasks generate logs too, but when you run tasks, you have little need to view the task
log. That is because tasks rarely produce errors or warnings. Every time you rerun a program or
task, the old log is replaced with a new one.

The Project Log, on the other hand, is a single cumulative record of everything that has been run
in a particular project. By default, the Project Log is turned off. Once you turn the Project Log on,
nothing disappears from it unless you clear the log.

Viewing a program log After a program runs, the results are displayed in the workspace.
To open the program log, click the tab labeled Log. Here is a portion of the program log
generated by the SAS program in the preceding section.

é} Program =] Log Ei3 Output Data[2) | 1 Results
Export » Send To = &ate = | [5# Project Log Properties

23 DATAL NewTours:
24 UPDATE 'C:VFAI TourshDats),Tours' MNewDats:
25 BY Wolocano:

MNOTE: There were 10 obserwvations read from the dats set C:4WFAI TourshData)Tours.
NOTE: There were & observations read from the data set WORE.WEWDLTL.

NOTE: The data Set WORE.NEWTOURS has 11 ochserwvations and 5 wvariables.

MNOTE: DATL statement used [(Total process time) :

real time 0.14 seconds
cpu time 0.04 seconds
26 PROC PRINT DATA = NewTours; a3
< ¥

One of the first things you will notice when you look at a log is that it contains more lines of SAS
code than were in your original program. That is because SAS Enterprise Guide adds
housekeeping statements to the beginning and end of your program to make sure that it runs
properly when it is passed to your SAS server.

If your program contains any errors, its icon will include a red X T%l Programs that contain

&
warnings (but no errors) have icons with yellow triangles @ Even if there are no errors or
warnings, it is a good habit to check the program log when you write your own SAS programs.
Just because a program runs without errors or warnings does not mean that it produced the
correct results.
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Viewing the Project Log To turn on the Project Log, first open it by clicking Project Log
on the workspace toolbar for the Process Flow or selecting View » Project Log from the menu
bar. Then on the workspace toolbar for the Project Log, click Turn On. Once the Project Log is
turned on, it will keep a continuous history of everything that runs in that project.

[ SAS Enterprise Guide - Chapter1.egp

File  Edit  View Tasks Program  Toals  Help é'ﬁv% £l ¥ Ba @ X |5 o - gqurncessFlﬂw -

Project Tree

3

Project Log -

x

= gqg Process Flow
= ] Voleances
il Bar Chart

Turn On S

Clear Log  Export = Send To =

Properties

Froject Log turned off

@ List Data
El Hote
= [ Programs

Iﬁ Program

Server List X
B (i[9

b

Servers
OLAP Servers
Frivate OLAP Servers

Ready R{ Connection: sasdemo, 127.0.0.1 Line 2, Cal 1

The Project Log includes the date and time when each action occurred. Click the plus sign (+) to
expand a section, or the minus sign (-) to collapse it. You can also split the Project Log into two
pieces by clicking and dragging the top border (the line just below the workspace toolbar) of the
Project Log window.

[ SAS Enterprise Guide - Chapter1.egp

X

File Edit Wiew Tasks Program Tools  Help Q'Bﬂ‘-'% B 9% By X | » o[- gqgf-‘r’ocessF\ow -
Project Tree = x Projectlog - ®
= g?% Frocess Flow Turn OFf | Clear Log  Exporkt ~ Send To = Properties
= Yoloanoes
Wil Bar Chart # Project Log turned on at 11/17/2009 10:04:03 PH A
@Lileala #Log for "Bar Chart"™ run at 11/17/2009 10:05:14 PM on
(21 Note #Log for "List Data™ run at 11/17/2008 10:05:21 PM on
=[] Programs Log for "Program” run at 11/17/2009 10:05:28 FM on L
m Program + Log for "Program" rum at 11/17/2009 10:05:55 FM on L
# Log for "Program" run at 11/17/2009 10:08:05 FM on L
Loy for "Bar Chart" run at 11/17/Z009 10:05:30 FM on
# Loy for "List Data"™ run at 11/17/2009 10:08:35 PM ong
Server Lisk - X < - I > .
®GES® 23 DATA NewTours; ~
24 UPDATE 'C:VFAI Tours\Data\Tours' HNeuwDla
- 25 BY Volcano;
Servers
[y OLAP Servers MOTE: There were 10 observations read from the data
[ly Private OLAP Servers NOTE: There were 2 observations read from the data s
MNOTE: The data set WORK.MEWTOURS has 11 observations—
NOTE: DATAL statement used (Total process time) :
real time 0.01 seconds
cpu time 0.01 seconds 3
< | 3
Ready %\Cnnnectinn: sasdemo, 127.0.0.1 Line 628, Cal 1

To clear the Project Log, click Clear Log on the workspace toolbar for the Project Log. To turn it

off, click Turn Off.
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1.16 Using the Options Window

The Options window allows you to change many default behaviors in SAS Enterprise Guide. To
open the Options window, select Tools » Options from the menu bar.

Changing the way data are handled To see options for data, click Data General in the
selection pane on the left. If you have large data tables, columns might be easier to find if they
are arranged in alphabetical order. To list columns alphabetically in task windows, check the box
in front of Display columns in alphabetical order. By default, the Data Grid uses column names,
not labels, for column headers. To change this, check the box in front of Use labels for column
names. If you have large data tables on remote servers, you may be able to improve performance
by unchecking Automatically open data when added to project.

Options g|
General Data > Data General
Project Views
Project Recovery
Results Dizplay columnz in alphabetical order within task windows and the Buery Builder
Results General
Viewer Use labels for column names
545 Report [] Use data tables in unprotected (readdwrite) mode
HTHL
RTF Automatically open data when added to project
FDF Always prompt when closing a project with temporary data references
Graph
Stared Process [ &hways obtain the total record count for DEMS tables
Data Drefault &ction for Dpening Importable D ata Files
D ata General
Peformance (&) Always [mport () Add file to project as data
Guery
OLAF Data Drefault Dimenzsions for Mew Data Grid
Tasks Default number of columing: Deefault number of rows:
Tasks General & = 7 o=
Custom Code
Output Library
SAS Programs SA5 Formats/Informats Cache
SECL.J”.UJ . Mo formatsdinformats information is currently cached.
Administration

Automatically displays the contents of data tables in a data grid when they are added to a project.

More [F1]...

T

Changing the default titles and footnotes To change the default titles and footnotes,
click Tasks General in the selection pane on the left. In this page, you can specify new default
titles and footnotes, or set them to blank. Some tasks include in the results the name of the SAS
procedure used by that task. In these results you will see titles like “The FREQ Procedure” or

“The ANOVA Procedure.” You can eliminate these titles by unchecking the box labeled Include
SAS procedure titles in results.
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[¢]
| =
Options g| -
General ) Tasks > Tasks General
Project Views
Project Recoverny
Resultz Eerem
Results General
iewer Drefault tile text for task output:
a’?iﬂﬁwmt Fire and lce Tours
RTF
FDF Drefault footnote text for tazk output:
Graph
Stored Process Exciting travel worldwide
Data
D ata General
Performance [ Display all generated 545 code in task output
Query
OLAP Data SAS procedure settings
Tasks
Tasks General [J U= PROC SOL instead of PROC SORT for sorting in tasks
Eustom ;ode Include 545 procedure titles in results
Output Library
SAS Programs Filer unuzed wvariables:
Security
Administration Auta v
Includes the name of the SAS procedure that is associated with the task in the heading of the task
results.
tore [F1]...
Reset All [ Ok, ] [ Apply ] [ Cancel ]

Changing the default result format and style To change the default format for
results, click Results General in the selection pane on the left to open the Results General page
(not shown). Then check all the formats you want to use: SAS Report, HTML, PDF, RTF, or text
output. To change the default style for results, click the name of the format (such as PDF) in the
selection pane on the left to open a page for that format (not shown), and then select a style. See
Tutorial B or Chapter 11 for more about changing result formats and styles.

Running code automatically If you have SAS code that you would like to run
automatically, click SAS Programs in the selection pane on the left to open the SAS Programs
page (not shown). Select an option under the heading Additional SAS code. Then click Edit,
type your code in the Edit window, and click Save. The option Submit SAS code when server is
connected is particularly useful for submitting LIBNAME statements. You can also click Custom
Code in the selection pane on the left, and specify code to be run before or after tasks.

Restoring the window layout To restore windows to their default layout, click General
in the selection pane on the left to open the General page (not shown). Then click the Restore
Window Layout button.

Saving and resetting options To close the Options window and save the changes you
have made, click OK. Once you set options, they stay in effect for future SAS Enterprise Guide
sessions. If at a later time, you decide you want to restore everything in the Options window to
the default settings, simply click the Reset All button in the lower left corner.

From The Little SAS® Book for Enterprise Guide® 4.2 by Susan J. Slaughter and Lora D. Delwiche.
Copyright © 2010, SAS Institute Inc., Cary, North Carolina, USA. ALL RIGHTS RESERVED.
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Auto Hide 134
automatically running SAS code 165
axes 308-309

B

Background Color option for process flows
140

Bar Chart task 298-299

batch programs, running 156-157
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box area in Summary Tables 275

C

character data
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functions 210-211
informats 152-153
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pie 300-301
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properties 160-161, 334-335
running 158-161
server for 159
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viewing 137, 158-159
writing 160-161
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in styles 314-317
in Summary Tables 274-281
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attributes when importing 181, 183, 185
computing in Data Grid 178-179
computing in query 80-86, 206-209
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deleting from Data Grid 16, 177
deleting in a query 90, 204
inserting in Data Grid 176-179
labels 51-56, 150-151
list of 149
names 8-9, 147
order of 90-91, 164-165
properties 8-17, 87-89,150-151, 174-177,
190-193, 198-199, 205, 217, 266-267
recoding 81, 218-219
selecting in a query 78-79, 204-205
sorting data values 226-231
combining data tables 109-117, 123-128, 240-247
filters 234-235
results 318-321
comma-delimited files
exporting 186-187
reading 168-169, 182-183
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COMMAw.d

format 154-155

informat 152-153
compound filters 234-235
computing columns

in Data Grid 178-179

in query 80-86, 206-209, 212-217
concatenating data tables 240, 242-243
conditional selection of rows 92-99, 224-227,

232-237, 328-329

conditions for projects 338-341
confidence limits 284-287, 293
contents of data tables 148-149
copying

data tables 176

items in process flows 141
Correlations task (CORR procedure) 290-291
COUNT statistic in query 212-217
counts

in Summary Tables 270-271

one-way 258-259

two-way 260-261
Create Format task 57-62, 194-197
cross-tabulations

in Summary Tables 270-271

in Table Analysis 260-261, 288-289
CSV files

exporting 186-187

reading 168-169, 182-183
currency data

definition 13, 146

formats 154-155

informats 152-153

D

data engines, SAS 173

data files
exporting 186-187
options 164-165
reading 168-171, 180-185
types 168-169

Data Grid
appending rows 177
computing columns 178-179
creating 5-21, 174-175
definition 146
deleting columns 16, 177
deleting rows 20, 177
editing 19, 176-177

formats, applying 190-191
inserting columns 176-179
inserting rows 177
data sets, definition 6, 146
data tables
active 142
appending 240, 242-243
compared to data sets 6
copying 176
creating summary 264-265
creating with a query 220-221
definition 6, 146
editing 19, 150, 176-177
exporting 186-187
filtering 92-99, 118-123, 224-227, 232-237,
328-329
joining 109-117, 123-128, 240-241, 244-247
locations 170-171
merging 109-117, 123-128, 240-241, 244-247
names 6-7,174
new 5-21,174-175
opening 29, 40-43, 75-76, 170
opening large 164-165
options 164-165
properties 148-149
sorting 100-102, 226-231
subsetting 92-99, 118-123, 224-227, 232-237,
328-329
data values
appearance of 51-56, 190-193
groups 13, 146-147, 150-151
labels for 57-62,194-199
length of 9,12
missing 18, 147
options 164-165
recoding in a query 218-219
sorting 100-102, 226-231
summarizing 212-217, 264-265
types 9-14, 146-147, 150-151
data views 220-221
date data
computations with 206-207
definition 146-147
formats 154-155, 190-193
functions 210-211
informats 152-153
DATEPART function 210-211
datetime data
definition 146-147
functions 210-211



DATETIMEw.d
format 154-155
informat 152-153
DATEw.
format 154-155
informat 152-153
DAY function 208-211
DB2 169
dBASE files 169, 186-187
DDMMYYw. informat 152-153
deleting
columns from Data Grid 16, 177
columns in a query 90, 204
duplicate rows 229
items from a project 139
process flows 140
rows from Data Grid 20, 177
task templates 144
delimited files
exporting 186-187
reading 182-183
types 168-169
descending sort order 101, 227-228, 231
descriptive statistics
in Distribution Analysis 284-285
in query 212-217
in Summary Statistics 262-263, 286-287
in Summary Tables 272-273
display formats
applying standard 151
applying user-defined 63-65, 198-199
creating user-defined 57-62, 194-197
grouping with 266-267
in Data Grid 176-177, 190-191
in query 204-205, 217
in tasks 51-56, 192-193
names 58
table of 154-155
Distribution Analysis task 284-285
division in expression editor 178-179, 206-207
docked windows 135
document windows 135
documenting
data tables 147-149
projects 34-35
DOLLARw.d format 154-155
DTDATEw. format 154-155
duplicate rows, deleting 229
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E
EBCDIC sort order 229
Edit button in task window 142, 224-225
editing
data tables 19, 150, 176-177
reports 318-321
SAS programs 158-159
styles 316-317
EGTASK library 7,170
embedding program in project 161
engines, SAS data 173
errors 162
EURDFDDw. format 154-155
EUROXw.d format 154-155
Ew. format 154-155
Excel files 169
exporting 186-187
importing 180-181
Exchange files 169
Export wizard 186-187
exporting
data 186-187
items from a project 139
results 322-323
task templates 145
expression editor
in a filter 236-237
in a query 82-86, 206-209
in Data Grid 179

F
filename of data table 149
files, data
exporting 186-187
options 164-165
reading 168-171, 180-185
types 168-169
filtering data
compound filters 234-235
dynamic 328-329
Filter and Sort task 226-227
in a query 92-99, 118-123, 232-233
in a task 224-225
summarized data 232-233
using expressions 236-237
Fisher’s Exact test 288-289
fixed columns raw data files 184-185
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fonts pie charts 300-301
in graphs 308 regression plot 293
in reports 320-321 result format 313
in styles 316-317 scatter plots 28-32, 306-307
in Summary Tables 274-281 Grid option for process flows 140
footers, adding to reports 320-321 grouping data
footnotes cross-tabulations 260-261
changing 46-50, 252-253 frequency reports 258-259
changing default 164-165 in query 212-217

default 48 list reports 254-257
FORMAT procedure (Create Format task) 57-62, output data table 264-265
194-197 recoding values 218-219
formats summary reports 262-263, 270-273

applying standard 151 with user-defined formats 194-197, 266-267

applying user-defined 63-65, 198-199

creating user-defined 57-62, 194-197
grouping with 266-267

in Data Grid 176-177, 190-191

in query 204-205, 217

in tasks 51-56, 192-193

names 58

table of 154-155

FREQ procedure

(One-Way Frequencies task) 22-28, 258-259
(Table Analysis task) 260-261, 288-289

frequencies

cross-tabulations 260-261
in Summary Tables 270-271
one-way 22-28, 258-259
statistical analysis 288-289

full outer join 241, 246-247
functions

definition 82

in Data Grid 179

in filter conditions 236-237
in query 208-209

table of 210-211

GCHART procedure

(Bar Chart task) 298-299
(Pie Chart task) 300-301

GPLOT procedure

(Line Plot task) 302-305
(Scatter Plot task) 28-32, 306-307

graphs

bar charts 298-299
controlling axes 308-309
line plots 302-305

H
headings
adding to reports 320-321
changing in a task 51-56
in Summary Tables 274-277
help, SAS Technical Support x
hiding windows 135
histograms 298-299
Hoeffding correlation coefficients 290-291
HTML data files 169, 186-187
HTML results 68-69, 312-313
styles for 314-317

1
images
adding to reports 320-321
adding to style 316-317
Import Data wizard 180-185
importing data 171
delimited raw data 182-183
Excel files 180-181
fixed columns raw data 184-185
JMP files 169
SPSS files 169
Stata files 169
types of data 168-169
importing, task templates 145
informats
in Data Grid 150-151, 176-177
table of 152-153
inner join 241, 246-247
inserting
columns in Data Grid 176-179
rows in Data Grid 177
SAS code in a task 158-159



J
JMP files, importing 169
joining data tables 109-117, 240-241, 244-245
join types 240-241
modifying a join 123-128, 246-247
JULIANw.
format 154-155
informat 152-153

K
Kendall correlation coefficients 290-291
kurtosis 284-285

L
labels

axes 308-309

columns 51-56, 150-151

data values 194-199

headings in Summary Tables 274-275
Layout option for process flows 140
left join 241, 246-247
LENGTH function 210-211
length of data values 9,12, 150-151
LIBNAME statement 165, 171
libraries

for data 7, 41-42,170-174

for formats 57,194

temporary data 7, 170-171
libref 170, 172
Line Plot task 302-305
Linear Regression task 292-293
linking items in process flows 141
List Data task 43-56, 63-65, 250-251, 254-257
listing files (text output) 312-313
log files, SAS 162-163
LOG function 210-211
LOG10 function 210-211
Lotus 1-2-3 files 169, 186-187

M
macro variables
creating for data values 326-327
creating for text values 336-337
creating for variable names 330-331
using in filters 328-329
using in programs 334-335
using in project conditions 338-341
using in tasks 332-333
many-to-many merge 240
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mathematical
functions 210-211
operators 178-179, 206-207
MAX
function 210-211
in Distribution Analysis 284-285
in query 212-217
in Summary Statistics 263, 286-287
in Summary Tables 272-273
maximizing workspace 137
MDY function 210-211
MEAN
function 210-211
in Distribution Analysis 284-285
in query 212-217
in Summary Statistics 263, 286-287
in Summary Tables 272-273
MEANS procedure (Summary Statistics task)
262-265, 286-287
means, comparison of 294-295
median
in Distribution Analysis 284-285
in Summary Statistics 286-287
in Summary Tables 272-273
menus 135
compared to Task List window 22
merging data tables 109-117, 123-128, 240-241,
244-247
MIN
function 210-211
in Distribution Analysis 284-285
in query 212-217
in Summary Statistics 263, 286-287
in Summary Tables 272-273
missing data values 18, 147
number of 212-217, 263, 272-273, 286-287
MMDDYYw.
format 154-155
informat 152-153
mode statistic 284-285
modifying
joins 123-128, 246-247
tasks 25-26, 46, 143
moments 284-285
MONTH function 210-211
moving items in process flows 140
multiple comparison 294-295
multiplication in expression editor 178-179,
206-207
My Styles, creating 316-317
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N
N statistic
in Distribution Analysis 284-285
in query (COUNT) 212-217
in Summary Statistics 263, 286-287
in Summary Tables 270-273
names
column 8-9, 147, 150-151, 181, 183, 185
data tables 6-7, 174
format 58
library 172
prompts 326, 329, 330
New Computed Column wizard 81-85, 206-209,
218-219
New Data wizard 5-17, 174-175
New Filter wizard 93-98, 119-121, 232-237
NMISS statistic
in query 212-217
in Summary Tables 272-273
normality, tests for 284-285
notes 34-35, 139
numeric data
definition 12, 146-147
formats 154-155
groups 13, 146-147
informats 152-153
labels for 196-197
user-defined formats 196-197

(@)
observations, definition 146
ODBC 169
one-to-many merge 240
one-to-one merge 240
One-Way ANOVA task 294-295
One-Way Frequencies task 22-28, 258-259
opening files 168-171
delimited files 182-183
Excel files 180-181
fixed columns raw data 184-185
SAS data tables 40-43, 75-76, 170
opening items in a project 139
opening tasks 22, 25-26, 142
operators
computing new columns using 178-179,
206-207
in filter conditions 224-227, 232-237, 328-329
options
changing default footnote 48

data 164-165
graph format 313
query 220-221
resetting 165
restore window layout 4, 135, 165
result format 68-70, 165, 312-313
result style 69, 165, 314-315
SAS programs 165
titles 164-165
VALIDVARNAME= 147
OR logic in filters 99, 234-235
Oracle 169
ordering
columns in a query 90-91
columns in task windows 164-165
rows with a query 100-102, 230-231
rows with Filter and Sort task 226-227
rows with Sort Data task 228-229
outer join 241, 246-247
output
combining 318-321
data tables 264-265
graph format 313
options 164-165
report format 68-70, 165, 312-313
report style 165
saving 322-323
style for 66-69, 314-317
P
Paradox files 169, 186-187
parameters 326
PDF
results 68-70, 312-313
styles for 314-315
Pearson correlation coefficients 290-291
Pearson tests of association 288-289
percentages
in One-Way Frequencies 258-259
in Summary Tables 272-273
in Table Analysis 260-261
percentiles
in Distribution Analysis 284-285
in Summary Statistics 286-287
in Summary Tables 272-273
PERCENTw.d
format 154-155
informat 152-153
performance, improving 164-165
Pie Chart task 300-301
pivot table 270-273



plots
controlling axes 308-309
line 302-305
regression 293
result format 313
scatter 28-32, 306-307
previewing
query results 78
SAS code 158
PRINT procedure (List Data task) 43-56, 63-65,
250-251, 254-257
printing
process flows 141
reports 321
procedure titles in results 164-165, 321
procedures
ANOVA (One-Way ANOVA task) 294-295
CORR (Correlations task) 290-291
FORMAT (Create Format task) 57-62, 194-197
FREQ (One-Way Frequencies task) 22-28,
258-259
FREQ (Table Analysis task) 260-261, 288-289
GCHART (Bar Chart task) 298-299
GCHART (Pie Chart task) 300-301
GPLOT (Line Plot task) 302-305
GPLOT (Scatter Plot task) 28-32, 306-307
MEANS (Summary Statistics task) 262-265,
286-287
PRINT (List Data task) 43-56, 63-65, 250-251,
254-257
REG (Linear Regression task) 292-293
SORT 228-229
SQL (Append Table task) 242-243
SQL (Query Builder) 202-221, 230-237, 240-241,
244-247,328-329
SUMMARY (Summary Statistics task) 262-265,
286-287
TABULATE (Summary Tables task) 270-281
UNIVARIATE (Distribution Analysis task)
284-285
process flows 4, 32-33, 134-135, 138-141
programs, SAS
code template 159
editing 158-159
embedding in project 161
inserting code in task 158-159
item in project 139
log 162
options 165
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prompts in 334-335
properties 160-161, 334-335
running 158-161
server for 159
stopping 161
viewing 137, 158-159
writing 160-161
Project Log 162-163
Project Tree 4, 33, 134, 138-139
projects
conditions 338-341
definition 3, 138-139
documenting 34-35
saving 36-37, 139
scheduling 156-157
Prompt Manager window 135-136, 326-327,
330-331, 336-337
prompts
creating for data values 326-327
creating for text values 336-337
creating for variable names 330-331
using in filters 328-329
using in programs 334-335
using in project conditions 338-341
using in tasks 332-333
properties
of columns 8-17, 87-89, 150-151, 174-175,
190-193, 198-199, 205, 217, 266-267
of data tables 148-149
of items in project 139
of joins 124-126, 246-247
of projects 157
of SAS programs 160-161, 334-335
of tasks 66-69, 313
protecting data 150

Q
QTR function 210-211

quantiles
in Distribution Analysis 284-285
in Summary Statistics 286-287
in Summary Tables 272-273
queries
computing new columns 80-86, 206-209
filtering data 92-99, 118-123, 232-237, 328-329
joining data tables 109-117, 123-128, 240-241,
244-247
naming 203
options 220-221
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queries (continued)
order of columns 90-91, 204
prompts in 328-329
recoding values 218-219
result name 203
result type 102, 220-221
selecting columns 78-79, 204-205
sorting rows 100-102, 230-231
summary groups 214-217

R
range statistic
in Distribution Analysis 284-285
in query 212-217
in Summary Statistics 263, 286-287
in Summary Tables 272-273
raw data files
delimited 182-183
fixed columns 184-185
types 168
read-in formats
in Data Grid 150-151, 176-177
table of 152-153
read-only mode 150, 176
reading
delimited raw data 182-183
Excel files 180-181
fixed columns raw data 184-185
SAS data tables 40-43, 75-76, 170
types of data 168-169
recoding values in a query 81, 218-219
refreshing
query preview 86
Server List window 173
tasks 143
REG procedure (Linear Regression task) 292-293
regression, linear 292-293
renaming
columns 150
columns from Excel 181
columns from raw data 183, 185
items in a project 139
process flows 140
queries 202
reopening tasks 25-26, 46, 143
replacing values in a query 218-219
reports
creating custom 318-321
creating with a query 220-221
cross-tabulations 260-261

footnotes 164-165, 252-253
frequency 22-28, 258-259
grouping with formats 266-267
list 43-56, 250-251
list by group 254-255
list with totals 256-257
SAS report result format 318-321
summary statistics 262-263
summary tables 270-281
titles 164-165, 252-253
titles of procedures in 164-165, 321
resetting options 165
Resources pane 4-5, 134-136, 170-171, 326-327,
330-331, 336-337
restoring windows 4, 135, 165
results 138
combining 318-321
footnotes 164-165, 252-253
format 68-70, 165, 312-313
graph format 313
queries 102, 202-203, 220-221
saving 322-323
style of 66-69, 165, 314-317
titles 164-165, 252-253
titles of procedures in 164-165, 321
viewing 137
right join 241, 246-247
row number in list reports 51, 251, 255
rows
appending in Data Grid 177
definition 146
deleting duplicates 229
deleting from Data Grid 20, 177
grouping in a report 254-255
inserting in Data Grid 177
selecting 92-99, 118-123, 224-227, 232-233,
236-237
RTF
results 68-69, 312-313
styles for 314-315
running
projects 156-157
projects with conditions 340-341
SAS programs 158-161, 165
tasks 143

S

SAS data engines 173

SAS Folders window 135-136
SAS listing (text) output 312-313



SAS log, viewing 162-163
SAS names 8, 147,172,174, 181, 183, 185
SAS Report result format 45, 68-69, 312-313,
318-321
styles for 314-317
SAS/ACCESS 169
Excel files 181
SASUSER library 7, 41-42,170
saving
data 186-187
items in a project 139
projects 36-37, 139
results 220-221, 322-323
SAS programs 160-161
Scatter Plot task 28-32, 306-307
scheduling projects 156-157
Scheffe’s multiple comparison procedure 294-295
scientific notation format 154-155
selecting
columns in a query 78-79, 204-205
rows in a query 92-99, 118-123, 232-235
Server List window 135-136, 170-171, 173
server, SAS
for data 41-42,170
for program 159, 161
for task 143
Show Multiple 136
Show One 136
skewness 284-285
Sort Data task (SORT procedure) 228-229
sorting data values
in a query 100-102, 230-231
in Filter and Sort task 226-227
in Sort Data task 228-229
space-delimited files
exporting 186-187
reading 168-169, 182-183
Spearman correlation coefficients 290-291
splitting
Project Log 163
Resources pane 136
workspace 137
spreadsheets 180-181, 186-187
SPSS files, importing 169
SQL procedure
(Append Table task) 242-243
(Query Builder) 202-221, 230-237, 240-241,
244-247, 328-329
stacking workspace 137
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standard deviation
in Distribution Analysis 284-285
in query 212-217
in Summary Statistics 263, 286-287
in Summary Tables 272-273
standard error
in Distribution Analysis 284-285
in query 212-217
in Summary Statistics 263, 286-287
in Summary Tables 272-273
starting SAS Enterprise Guide 3
Stata files, importing 169
statistics
analysis of variance 294-295
association 288-289
correlation 290-291
descriptive 212-217, 262-263, 272-273, 284-287
distribution 284-285
functions 210-211
multiple comparisons 294-295
regression 292-293
saving to a data table 264-265
stopping
SAS programs 159, 161
tasks 143
Style Manager 316-317
styles
changing 66-69, 165, 314-315
creating new 316-317
subsetting data tables 92-99, 118-123, 224-227,
232-237, 328-329
SUBSTR function 210-211
subtraction in expression editor 178-179, 206-207
summarized columns
filtering 232-233
groups 212-217
in query 81-85, 212-215
Summary Statistics task (SUMMARY procedure)
262-265, 286-287
Summary Tables task 270-281
box area properties 275
class level properties 276-277
data value properties 280-281
heading properties 274-275
table properties 278-279
sums
function 210-211
in List Data 256-257
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sums (continued)
in query 212-217
in Summary Statistics 263, 286-287
in Summary Tables 272-273

T
tab-delimited files
exporting 186-187
reading 168-169, 182-183
Table Analysis task 260-261, 288-289
TABULATE procedure (Summary Tables task)
270-281
Task List window 4-5, 135-136, 142
compared to menu bar 22
task roles, assigning 24, 250
Task Status window 5, 135
tasks 138
Append Table 242-243
Assign Project Library 172-173
assigning formats 51-56, 192-193
Bar Chart 298-299
code generated by 158-159
compared to wizards 22
Correlations 290-291
Create Format 57-62, 194-197
data for 224-225
Distribution Analysis 284-285
dynamic 330-333
Filter and Sort 226-227
filtering in 224-225
footnotes 46-50, 164-165, 252-253
Line Plot 302-305
Linear Regression 292-293
List Data 43-56, 63-65, 250-251, 254-257
log 162
modifying 25-26, 46, 143
One-Way ANOVA 294-295
One-Way Frequencies 22-28, 258-259
opening 22, 25-26, 46, 142-143
options for 164-165
Pie Chart 300-301
prompts in 330-333
properties 66-69, 313
Query Builder 244-247
refreshing 143
result format 312-313
running 143
Scatter Plot 28-32, 306-307
server for 143
Sort Data 228-229

stopping 143
Summary Statistics 262-265, 286-287
Summary Tables 270-281
Table Analysis 260-261, 288-289
templates 144-145
titles 46-50, 164-165, 252-253
Technical Support x
templates
code 159
task 144-145
temporary library 7, 170
text
adding to reports 320-321
results files 68-69, 312-313
text data files
exporting 186-187
reading delimited 182-183
reading fixed columns 184-185
tick marks 308-309
time data
definition 147
formats 154-155
informats 152-153
TIMEw.d
format 154-155
informat 152-153
titles
changing 46-50, 252-253
changing default 164-165
of procedures in results 164-165, 321
prompts in 332-333
TODAY function 210-211
toolbar, workspace 25,135
totals
in List Data 256-257
in query 212-215
in Summary Statistics 262-265
in Summary Tables 272-273
TRANSLATE function 210-211

U
UNIVARIATE procedure (Distribution Analysis
task) 284-285
UPCASE function 210-211
update mode 150, 176
uppercase
format 154-155
informat 152-153
user-defined formats
applying 63-65, 198-199
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creating character 57-62, 194-195 informat 152-153

creating numeric 196-197 &

grouping with 266-267 in data icon 332

in name of prompt 328

Vv ?inicon 329, 333, 335
VALIDVARNAME= option 147 _FREQ_ variable 265
variables, definition 24, 146 _TYPE_ variable 265
variance _WAY_ variable 265

in Distribution Analysis 284-285
in query 212-217
in Summary Statistics 263, 286-287

W
w.d
format 154-155
informat 152-153
warnings 162-163
WEEKDATEw. format 154-155
windows 4-5, 134-135
document 135
hiding 135
maximizing workspace 137
Process Flow 4, 32-33, 134-135, 138-139
Project Tree 4, 33, 134, 138-139
Resources pane 134-135, 170-171, 326-327,
330-331, 336-337
restore window layout 4, 135, 165
splitting workspace 137
wizards
Assign Project Library 172-173
compared to tasks 22
Export 186-187, 322-323
Import Data 180-185
New Computed Column 81-85, 206-209,
218-219
New Data 5-17,174-175
New Filter 93-98, 119-121, 232-237
WORDDATEw. format 154-155
WORK library 7,170
workspace 4, 134-135, 137
toolbar 25
Workspace Layout icon 137

zZ
Zoom option for process flows 140

Special Characters
$UPCASEw.

format 154-155

informat 152-153
$w.

format 154-155
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